Soporte » Instalación – Actualizaciones » Error Fatal. No puedo entrar en la web.

  • Resuelto adriangm89

    (@adriangm89)


    Buenos días,

    Es posible que tras una actualización aparezca en blanco la web y el siguiente mensaje al intentar acceder al administrador:

    Warning: require_once(/home/famousbrands/famousbrands.es/wp-settings.php): failed to open stream: No such file or directory in /home/famousbrands/famousbrands.es/wp-config.php on line 92

    Fatal error: require_once(): Failed opening required ‘/home/famousbrands/famousbrands.es/wp-settings.php’ (include_path=’.:/usr/local/lib/php:/usr/local/php5/lib/pear’) in /home/famousbrands/famousbrands.es/wp-config.php on line 92

    ¿Qué se puede hacer para solucionarlo?

    Gracias.

Viendo 11 respuestas - de la 1 a la 11 (de un total de 11)
  • Moderador almendron

    (@almendron)

    1.- Si la actualización era de un plugin, accede vía FTP y borra la carpeta de ese plugin. Ésta estará dentro de wp-contens/plugins
    2.- Si la actualización era de wordpress, entonces prueba a reinstalar de forma manual: https://codex.wordpress.org/es:Actualizar_WordPress
    3.- Otra opción es hacer una copia en tu ordenador del archivo wp-config.php, borrar este archivo del servidor y luego intentar entrar en la administración. Eso forzará a wordpress a reconstruir dicho archivo.
    IMPORTANTE: ten a mano los datos necesarios, es decir,
    El nombre de tu base de datos de WordPress: DB_NAME
    Tu nombre de usuario de MySQL: DB_USER
    Tu contraseña de MySQL: DB_PASSWORD
    Host de MySQL: DB_HOST (normalmente localhost).
    Todos estos datos los tienes en tu wp-config.php actual.

    Iniciador del debate adriangm89

    (@adriangm89)

    Buenas,

    He optado por la tercera opción pero al entrar en el administrador me redirecciona a http://www.famousbrands.es/wp-admin/setup-config.php y aparece de nuevo la pantalla en blanco.

    Moderador almendron

    (@almendron)

    No has dicho qué actualización fue la provocó el error.

    Iniciador del debate adriangm89

    (@adriangm89)

    El tema es que desconocemos si alguna actualización, pues ha sido de repente cuando nos hemos dado cuenta de la pantalla en blanco. Lo exponía, por si alguna actualización había podido ser la causa.

    Moderador almendron

    (@almendron)

    1.- Edita el wp-config.php y echa un vistazo a la línea 92 a ver si te da alguna pista.
    2.- Accede vía FTP y renombra la carpeta «plugins» (dentro de wp-content). Eso hará que todos los plugins se desactiven. Intenta entrar después.

    Iniciador del debate adriangm89

    (@adriangm89)

    En la línea 92 me aparece lo siguiente:
    require_once(ABSPATH . 'wp-settings.php');

    Respecto a lo de renombrar la carpeta me sigue devolviendo el mismo error.

    Moderador almendron

    (@almendron)

    Lo que te está sucediendo es que, por algún motivo, no puede abrir el archivo wp-settings.php, que debería estar en el directorio de instalación de wordpress.
    Lo primero de todo comprueba que efectivamente ese archivo existe y que tiene los permisos adecuados.
    Y lo segundo es comprobar que nadie ha tocado Dirección de WordPress (URL) y Dirección del sitio (URL). Par ello tendrás que acceder a la base de datos y visualizar la tabla wp-options. Aquí podrás ver el valor asignado a dichos campos.

    Iniciador del debate adriangm89

    (@adriangm89)

    Hola, acabo de comprobar vía FTP y no hay ningún archivo wp-settings.php en la ruta en la que me da el error (/home/famousbrands/famousbrands.es/wp-settings.php), que es la misma en la que está el archivo wp-config.php

    ¿Cómo podría solucionarlo?

    Moderador almendron

    (@almendron)

    Pero, ¿has mirado en la raíz del directorio donde está instalado wordpress?
    Por cierto, ¿en qué carpeta está instalado? ¿en la raíz o en otra carpeta?

    Yo realizaría una actualización manual:
    https://codex.wordpress.org/es:Actualizar_WordPress

    Iniciador del debate adriangm89

    (@adriangm89)

    De acuerdo ya está solucionado el problema:

    – He descargado los archivos de la ultima actualización de wordpress, y he añadido a la carpeta raíz el archivo wp-settings.php vía FTP. Con esto me ha permitido acceder al backend de la web, y desde ahí he realizado una reinstalación de wordpress.

    Muchas gracias @almendron por tu ayuda y paciencia 😉

    Un saludo.

    • Esta respuesta fue modificada hace 5 años por adriangm89.
    Moderador almendron

    (@almendron)

    De nada. Me alegro de que se hay solucionado.
    Un saludo.
    PD. Por favor, marca el tema como resuelto.

Viendo 11 respuestas - de la 1 a la 11 (de un total de 11)
  • El debate ‘Error Fatal. No puedo entrar en la web.’ está cerrado a nuevas respuestas.