Soporte » Instalación – Actualizaciones » Error instalar WordPress

  • Resuelto Javier Santoyo

    (@javiersantoyo89)


    Hola a todos(as)

    Estoy tratando de instalar wordpress en local mediante XAMPP for Windows 8.1.1 (Funciona bien, levanta el server(Probado), corro MySQL(Abre y creo la BD)

    Bajo wordpress de wordpress.org y me da la version mas nueva y lo pego en htdocs

    — Todo normal hasta aqui —

    El problema es que ya creado la base de datos, con usuario(Root y robado con otros)
    No me permite iniciar wordpress para trabajar.

    Ya lo intente en linux(Ubuntu), windows(W10) e intento lo mismo y nada, aun haciendo manual creando el wp-config.php en ingresando los mismos nombres(BS, BDUser, Pass) reviso tutoriales y foros en internet y nada, llevo así casi 2 semanas. Alguna idea???

Viendo 8 respuestas - de la 1 a la 8 (de un total de 8)
  • Hola @javiersantoyo89, ¿qué error te da?

    Activa el modo DEBUG https://wordpress.org/support/article/debugging-in-wordpress/ para ver más información dle error

    Moderador Jose Luis

    (@jose64)

    Hola @javiersantoyo89

    Bienvenido al foro de soporte. Revisa este debate:

    Error al crear un sitio web

    Ahí se indican dos opciones para trabajar en local sin complicaciones.

    Coméntanos si los pruebas y, por favor, recuerda marcar el debate como resuelto cuando así lo consideres, de esta forma nos ayudas a mantener el foro al día.

    Iniciador del debate Javier Santoyo

    (@javiersantoyo89)

    Hola @cuxaro logre correrlo en modo debbug y me dio esto…

    Fatal error: Uncaught mysqli_sql_exception: Table 'wordpress.wp_options' doesn't exist in C:\xampp\htdocs\wordpress\wp-includes\wp-db.php:2056 Stack trace: 
    #0 C:\xampp\htdocs\wordpress\wp-includes\wp-db.php(2056): mysqli_query(Object(mysqli), 'SELECT option_n...') 
    #1 C:\xampp\htdocs\wordpress\wp-includes\wp-db.php(1945): wpdb->_do_query('SELECT option_n...') 
    #2 C:\xampp\htdocs\wordpress\wp-includes\wp-db.php(2695): wpdb->query('SELECT option_n...') 
    #3 C:\xampp\htdocs\wordpress\wp-includes\option.php(284): wpdb->get_results('SELECT option_n...') 
    #4 C:\xampp\htdocs\wordpress\wp-includes\functions.php(1730): wp_load_alloptions() 
    #5 C:\xampp\htdocs\wordpress\wp-includes\load.php(752): is_blog_installed() 
    #6 C:\xampp\htdocs\wordpress\wp-settings.php(159): wp_not_installed() 
    #7 C:\xampp\htdocs\wordpress\wp-config.php(96): require_once('C:\\xampp\\htdocs...') 
    #8 C:\xampp\htdocs\wordpress\wp-load.php(50): require_once('C:\\xampp\\htdocs...') 
    #9 C:\xampp\htdocs\wordpress\wp-blog-header.php(13): require_once('C:\\xampp\\htdocs...') 
    #10 C:\xampp\htdocs\wordpress\index.php(17): require('C:\\xampp\\htdocs...') 
    #11 {main} thrown in C:\xampp\htdocs\wordpress\wp-includes\wp-db.php on line 2056

    Hola @jose64 ya revise con el link que me diste y nada.

    Viendo el log del bug’s todo indica que es error entre el mysql y wordpress pero mysql esta funcionando bien, alguna idea?

    Pues revisa el wp-config y la base de datos, ya que tiene pinta que o bien el prefijo no es ‘wp_’, el host no es correcto, la base de datos no es ‘wordpress’ o el usuario y/o contraseña no son correctos.

    Iniciador del debate Javier Santoyo

    (@javiersantoyo89)

    Yo no tengo wp-config, sino wp-config-sample intento con el asistente y no funciona, creo el archivo wp-config y lleno los datos manuales y nada.

    BD: wordpress (utf8mb4_general_cl)
    User: root
    Pass: «en blanco»
    host: localhost
    Table prefix: wp_

    Ya intente poniendo otra cuenta con password y nada.

    Pues si no está la base de datos mal configurada debe tener algún otro bloqueo como firewall, pero el mensaje apunta claramente a que o o no es la BD wordpress o no es wp_ el prefijo.

    Iniciador del debate Javier Santoyo

    (@javiersantoyo89)

    @cuxaro ya logre que funcione, borre el XAMPP e instale el WampServer…

    Me funciono a la primera, muchas gracias por el apoyo, ojala este link sirva para mas usuarios, saludos!!!.

    Moderador Jose Luis

    (@jose64)

    Hola @javiersantoyo89

    En este otro debate optan por instalar la versión anterior de XAMPP, lo dejo por completar la información:

    https://es.wordpress.org/support/topic/problema-instalando-wordpress-no-crea-tablas/#post-12205258

Viendo 8 respuestas - de la 1 a la 8 (de un total de 8)
  • Debes estar registrado para responder a este debate.