Soporte » Instalación – Actualizaciones » Error modificando unos blogs escolares con wordpress y PHP

  • bartolada

    (@bartolada)


    Me han encargado echarle un ojo a unos blogs que no funcionaban en un hosting de 1&1, algunos iban y otros no. Al entrar vía FTP al hosting me he dado cuenta de que lo que faltaba era el archivo «.htacess» en varios carpetas de los blogs, siendo que las que sí funcionaban (eran 3 de 10) sí que tenían dicho archivo.

    Bien, una vez he conseguido que los blogs, que están alojados en subdominios (ejemplo: mates.colegio.com), funcionen, hay dos que no tengo ni idea de por qué no funcionan. Muestran este error:

    Fatal error: Array and string offset access syntax with curly braces is no longer supported in /homepages/***/wordpress/wp-includes/script-loader.php on line 707

    Las líneas 707 y 708 son estas:

    ( ‘{‘ == $value{0} && ‘}’ == $value{strlen( $value ) – 1} ) ||
    ( ‘[‘ == $value{0} && ‘]’ == $value{strlen( $value ) – 1} ) ||

    He leído que es debido a que parte de ese código ya no está soportado en la versión de PHP que esté instalada en ese servidor… Pero ¿Cómo es que van los demás blogs? Sólo fallan 2. He probado a poner el archivo «script-loader.php» de un blog que sí que funciona en uno de los dos que no funciona y sigue dando el mismo error mientras que los otros 8 blogs cargan perfectamente. El archivo .htacess que he puesto es el mismo para todos. Es rarísimo.

    ¿Qué creéis que puedo hacer? Gracias de antemano.

    Gracias!!

Viendo 6 respuestas - de la 1 a la 6 (de un total de 6)
  • Moderador Mariano Perez

    (@mpcdigital)

    Es un problema de que en PHP 7.4 ya no soporta esa forma de acceso a las claves. En los que funciona debe ser porque no llegan a pasar por ese código. La solución es bajar la versión de PHP para que funcione y así poder extraer los datos.

    Iniciador del debate bartolada

    (@bartolada)

    Hola Mariano, muchas gracias por tu respuesta.

    El wordpress está alojado en un hosting donde casi todo funciona a través de paneles, ¿Cómo podría «bajar» la versión de PHP, y ¿a cuál versión lo bajo?.

    Tengo acceso al ssh y ftp, supongo que por ahí le podría meter mano al asunto.

    Gracias de nuevo.

    Iniciador del debate bartolada

    (@bartolada)

    Hola de nuevo, hemos cambiado la versión de php por blog hasta que han funcionado todos excepto uno que da este error (nos deja elegir entre php 7.2, 7.3, 7.4 y 8).

    Warning: require_once(/homepages/***/wordpress/wp-includes/plugin.php): failed to open stream: Permission denied in /homepages/***/wordpress/wp-settings.php on line 40

    Fatal error: require_once(): Failed opening required ‘/homepages/***/wordpress/wp-includes/plugin.php’ (include_path=’.:/usr/lib/php7.4′) in /homepages/***/wordpress/wp-settings.php on line 40

    Ahora está en php 7.4, si cambiamos a 7.3 o 7.2 da el error aquí en función del php seleccionado -> /usr/lib/php7.3 o /usr/lib/php7.2

    Alguna idea de qué tocar? Es uno de los blogs más importantes.

    Muchas gracias.

    Iniciador del debate bartolada

    (@bartolada)

    Buenas tardes. Vuelvo a actualizar el caso.

    Dimos permisos a unos archivos y ahora al cargar el blog nos sale exactamente:

    No se ha podido establecer conexión con la base de datos.

    ¿Cómo puede ser esto? Sólo nos falla un blog de 15 ya, éste, y de ese error. He probado a darle permisos al wp-config.php que parece que lleva información de la base de datos pero no parece ser el problema ya que sigue dando el error.

    Gracias de ante mano por su ayuda.

    Soy novato en wordpress, en curso on line, nos hicieron instalar el XAMPP para tener un servidor local, todo muy bien, descargamos en WordPress y lo instale, el profesor me dijo que solo de continuar y listo. Cree la base de datos con nombre WORDPRESS, instale el programa y cuando puse la ruta localhost/wordpress y aparece la pantalla de bienvenida donde habla de archivo CONFIG-WP.PHP y hacer cambios que lo hacen parecer muy fácil, como mi profesor decia que solo de enter, lo hice y de pronto: «Error al establecer una conexión con la base de datos».

    Edite con paciencia decenas de veces el famoso archivo, vi decenas de tutoriales en youtube, varias webs y a pesar de seguir todos los «simples cambios»de los codigos siempre terminaba con el conocido aviso, hasta que encontre en google una solución simple que comparto para los que como yo no saben mucho de esto:

    NOMBRE DE BASE DE DATOS: WORDPRESS (que puede ser otro nombre, pero este es simple.
    NOMBRE DE USUARIO: ROOT (este es dato que no habia en otros tutoriales o foros)
    CONTRASEÑA: vacia (no puse nada)
    SERVIDOR DE LA BASE DE DATOS: LOCALHOST (la que es por defecto)
    PERFIJO DE TABLA: WP_ (igual a la que esta)

    de nuevo entre y zaaass!, entro, después de dias de intentarlo lo pude hacer, lejos de foros complicados y que a pesar de ser oficiales preguntas algo y te responden otras cosas. Prueben, a mi me funciono, claro que los algunos diran que la contraseña no esta pero como es para principantes, y estas en un servidor local ,se supone que lo que deseas es hacer una página o al menos aprender a manejar WordPress, ya luego investigas lo de la contraseña, pero que vas a avanzar y sonreir… eso, sí.

    Suerte!

    Oscar Pinto
    Lima – Perú

    • Esta respuesta fue modificada hace 1 mes, 2 semanas por Oscar Pinto.

    Hola Óscar, lo normal es que ya desde la misma interface de WordPress, desde el navegador, incorpores la base de datos previamente creada en XAMPP. El método sería:

    nombre de la BASE DE DATOS: BASE_DE_DATOS_1
    nombre del usuario: root
    pass: «si el usuario es root déjalo vacío»

    Con esto ya tendría que funcionar la instalación.

    Siempre es recomendable crear un usuario pero en local, tampoco es realmente necesario. Aún así te invito a seguir este tutorial que lo explica perfectamente, espero que te ayude:
    Instalar WordPress en XAMPP

Viendo 6 respuestas - de la 1 a la 6 (de un total de 6)
  • Debes estar registrado para responder a este debate.