Soporte » Guías – Resolución de problemas » Error para hacer una entrada nueva

  • Resuelto jordi arasa santiago

    (@jordi-arasa-santiago)


    Además de los problemas con las imágenes ahora no puedo crear entradas nuevas de blog. Me da éste error:

    Warning: Creating default object from empty value in /homepages/8/d411863922/htdocs/wp-admin/includes/post.php on line 713

    Warning: Cannot modify header information – headers already sent by (output started at /homepages/8/d411863922/htdocs/wp-admin/includes/post.php:713) in /homepages/8/d411863922/htdocs/wp-admin/admin-header.php on line 9

    Warning: Invalid argument supplied for foreach() in /homepages/8/d411863922/htdocs/wp-content/plugins/wordpress-seo/admin/metabox/class-metabox.php on line 1033

    Lo de homepages 8 no sé qué es, pero he ido a las carpetas wp-admin y las otras y he abierto los php de los que habla y las líneas que se supone que fallan son éstas.

    En post.php:

    $post->post_content = (string) apply_filters( ‘default_content’, $post_content, $post );

    En class-metabox.php:

    foreach ( $custom_fields as $custom_field_name => $custom_field ) {

    Y en admin-header.php:

    header( ‘Content-Type: ‘ . get_option( ‘html_type’ ) . ‘; charset=’ . get_option( ‘blog_charset’ ) );

    Es posible que estos errores los haya generado yo al intentar pasar de Weaver II Theme Extras a Weaver II to Weaver Xtreme.

    Comentar que llevo dos días intentando restaurar una versión guardad en UpdraftPlus pero no parece hacer nada. Se pasa horas y horas dando vueltas un icono debajo de la frase «Recuperando (si es necesario) y preparando los ficheros de respaldo…» pero no veo yo que pasa de ahí ni que restaure nada.

    Gracias por vuestra ayuda

    La página con la que necesito ayuda: [accede para ver el enlace]

Viendo 15 respuestas - de la 1 a la 15 (de un total de 96)
  • Moderador almendron

    (@almendron)

    Esto vale para las dos consultas que has realizado:

    ¿Qué versión de PHP y MySql tienes?

    Por otro lado, las pruebas estándar para estos casos pasan por desactivar todos los plugins y cambiar de tema. Después compruebas y si desaparece el problema, es cuestión de ir activando-comprobando hasta encontrar al responsable.

    PHP 7.3

    MySql 5.5

    Desactivados los plugin, me sigue dando error. Desactivado el plugin de SEO ya no me sale la última línea porque se refiere al SEO.

    Cambiado el tema, me sigue dando error. He activado el Twenty Twenty que es ahora mismo el único que tengo aparte del que uso. Y con éste tema, además de mantenerse los errores, no se puede ver la página.

    Eso sí, ahora me sale este mensaje debajo del tema:

    Temas dañados
    Los siguientes temas se instalaron pero están incompletos.

    Nombre Descripción
    weaver-ii-theme-extras Falta la hoja de estilo. Borrar

    Saludos

    Moderador almendron

    (@almendron)

    A mi me da la impresión que es un problema del tema. De hecho aparece como ibsoleto en la página de soporte: https://weavertheme.com/why-weaver/

    Yo haría la siguiente prueba:

    1) Desactiva todos los plugins
    2) Instala y activa uno de los «Twenty….» que trae por defecto WordPress. Si es necesario, primero borra esos temas y luego instalas (OJO: no borres el que estás usando actualmente).
    2) Comprueba.

    jordi arasa santiago

    (@jordi-arasa-santiago)

    Bueno, te cuento últimas acciones.

    1. He desactivado los plugins

    2. Me he subido el tema Weaver Xtreme, instalado y activado.

    Conclusiones:

    1. Me sigue pasando lo mismo, no puedo subir imágenes ni hacer una nueva entrada.

    2. No puedo cambiar la imagen de cabecera en el nuevo tema.

    3. Veo la página web en el navegador con el nuevo tema (se carga como http://www.caricaturasalacarta.com)

    Vuelvo a activar los plugins. Y con los pluguins activados, me pasa esto:

    1. Me sigue pasando lo mismo, no puedo subir imágenes ni hacer una nueva entrada.

    2. Cuando voy a hacer cambios en el tema, no puedo y me sale un «warning» muy largo que empieza así.

    «Your WP host server has only -1M of PHP Memory. Depending on your WordPress configuration, this could cause settings made in the Weaver Xtreme Customizer Interface to fail to be saved and applied to your live site.»

    3. Una vez activado el plugin del SEO y con la URL entera, la página no se carga en el navegador y me aparece este mensaje:

    «Esta página no funciona

    La página http://www.caricaturasalacarta.com te ha redirigido demasiadas veces»

    No sé si esto os puede dar nuevas pistas.

    Muchas gracias por vuestra ayuda.

    Saludos

    jordi arasa santiago

    (@jordi-arasa-santiago)

    En conclusión, de momento he vuelto al Weaver II Theme, que al menos la página se ve. Saludos

    Moderador almendron

    (@almendron)

    Yo haría las pruebas que te dije y así podrás saber si el tema o algún plugin.

    jordi arasa santiago

    (@jordi-arasa-santiago)

    Pues, o no te he entendido bien, o ya están hechas las pruebas. Desactivando los plugins y cambiando el tema, me sigue pasando lo mismo.

    ¿Qué me dices del warning que te pegué?

    «Your WP host server has only -1M of PHP Memory. Depending on your WordPress configuration, this could cause settings made in the Weaver Xtreme Customizer Interface to fail to be saved and applied to your live site.»

    Mi inglés no es muy bueno, pero entiendo que me dice que tengo un mega de memoria PHP en mi host de WordPress.

    Según la información de mi hosting, no he utilizado ni un 10% de mi memoria, así que no sé si se referirá a otra cosa.

    Saludos

    jordi arasa santiago

    (@jordi-arasa-santiago)

    Toqueteando el panel de control del hosting he visto que tengo la capacidad de la base de datos MySQL llena. No sé si esto es el aviso del que te he hablado. Tampoco sé si es importante. De momento no me atrevo a vaciarla. Saludos

    Moderador almendron

    (@almendron)

    Disculpa que no había visto tu comentario explicando las pruebas.

    Habría que descartar al tema porque podría ser el responsable o bien deberse a un problema de recursos en el hosting.

    Si no estoy equivocado no has hecho las pruebas con alguno de los «Twenty….» que trae por defecto WordPress sino con Weaver Xtreme. Tienes que hacer la prueba con uno de esos temas y con todos los plugins desactivados.

    jordi arasa santiago

    (@jordi-arasa-santiago)

    Ahora ya no puedo entrar al administrador, la página no se carga. Ni en Chrome ni en opera. Ni en el móvil. Llevo una hora dándole vueltas y no hay manera. He probado poniendo /cpanel, /wp-login.php, etc. Nada. Me da el mensaje de redireccionado demasiadas veces, pero borro cookies, datos de navegador, etc y tampoco. No creo que sea eso.

    jordi arasa santiago

    (@jordi-arasa-santiago)

    Ya he conseguido acceder quitando las www.

    jordi arasa santiago

    (@jordi-arasa-santiago)

    Bueno, accedo donde me pide usuario y contraseña, pero entrar, no entro. Se está una hora dando vueltas la rueda pero no me muestra el panel.

    Con esta dirección:

    https://caricaturasalacarta.com/wp-login.php

    Moderador almendron

    (@almendron)

    Ponte en contacto con el soporte de tu hosting a ver si es que te has quedado sin espacio y estamos aquí mareando la perdiz. Lo digo por eso de «la capacidad de la base de datos MySQL llena».

    Además, entra por vía FTP, haz una copia en tu ordenador del «htaccess» y luego lo eliminas del servidor. Es un fichero oculto. Según que programa de FTP uses, deberás buscar la opción que permite ver ese tipo de archivos.

    jordi arasa santiago

    (@jordi-arasa-santiago)

    Hay dos archivos, htaccess y 1.htaccess. He copiado los dos y borrado los dos. Sigo sin poder entrar al administrador.

    Voy a escribir al hosting para comentar lo de la capacidad de la base de datos.

    Saludos

Viendo 15 respuestas - de la 1 a la 15 (de un total de 96)
  • El debate ‘Error para hacer una entrada nueva’ está cerrado a nuevas respuestas.