Soporte » Guías – Resolución de problemas » Error para hacer una entrada nueva

  • Resuelto jordi arasa santiago

    (@jordi-arasa-santiago)


    Además de los problemas con las imágenes ahora no puedo crear entradas nuevas de blog. Me da éste error:

    Warning: Creating default object from empty value in /homepages/8/d411863922/htdocs/wp-admin/includes/post.php on line 713

    Warning: Cannot modify header information – headers already sent by (output started at /homepages/8/d411863922/htdocs/wp-admin/includes/post.php:713) in /homepages/8/d411863922/htdocs/wp-admin/admin-header.php on line 9

    Warning: Invalid argument supplied for foreach() in /homepages/8/d411863922/htdocs/wp-content/plugins/wordpress-seo/admin/metabox/class-metabox.php on line 1033

    Lo de homepages 8 no sé qué es, pero he ido a las carpetas wp-admin y las otras y he abierto los php de los que habla y las líneas que se supone que fallan son éstas.

    En post.php:

    $post->post_content = (string) apply_filters( ‘default_content’, $post_content, $post );

    En class-metabox.php:

    foreach ( $custom_fields as $custom_field_name => $custom_field ) {

    Y en admin-header.php:

    header( ‘Content-Type: ‘ . get_option( ‘html_type’ ) . ‘; charset=’ . get_option( ‘blog_charset’ ) );

    Es posible que estos errores los haya generado yo al intentar pasar de Weaver II Theme Extras a Weaver II to Weaver Xtreme.

    Comentar que llevo dos días intentando restaurar una versión guardad en UpdraftPlus pero no parece hacer nada. Se pasa horas y horas dando vueltas un icono debajo de la frase «Recuperando (si es necesario) y preparando los ficheros de respaldo…» pero no veo yo que pasa de ahí ni que restaure nada.

    Gracias por vuestra ayuda

    La página con la que necesito ayuda: [accede para ver el enlace]

Viendo 6 respuestas - 91 de 96 (de 96 total)
  • Moderador almendron

    (@almendron)

    Déjalo activo. No molesta.

    ¿Borro la carpeta «prueba» y su base de datos?

    Te cuento que intentando solucionar el lío del dominio y subdominio he cambiado el nombre de la página a «https://caricaturasalacarta.com» (sin http://www., ya que es el dominio) en ajustes generales y he redireccionado el subdominio al dominio en el panel de control del hosting. La página carga bien, sigo editando y no parece haber ningún problemas. He consultado la base de datos y los cambios se han hecho correctamente.

    Lo que de momento no consigo encontrar es la manera para que se muestre la URL de la página de inicio al cargar la página.

    Si eres tan amable de contestarme estas cosillas, marcaré el tema como solucionado y cerrado.

    Saludos

    Moderador almendron

    (@almendron)

    Puedes borrar ambas.

    Y desactiva el plugin que tienes en la carpeta «wordpress-seo». Puede que te desaparezcan todos los errores que ahora se ven.

    Pues vaya tontería!! Lo de la URL lo he cambiado en los ajustes de lectura.

    Sólo falta que me digas si borro o no «prueba» y su base de datos.

    Saludos

    Ok!! Tema zanjado. Saludos y gracias

Viendo 6 respuestas - 91 de 96 (de 96 total)
  • Debes estar registrado para responder a este debate.