Soporte » Diseño – Temas y plantillas » error «‘theme_mod_background_image’»

  • Resuelto altur

    (@altur)


    I have a problem with a theme and I’m very new to this and I don’t understand what the error is,

    Fatal error: Uncaught Error: Undefined constant «‘theme_mod_background_image'» in G:\xampp\apps\wordpress\htdocs\wp-content\themes\magicraft\library\creepy.php:427 Stack trace: #0 G:\xampp\ apps\wordpress\htdocs\wp-content\themes\magicraft\functions.php(17): require_once() #1 G:\xampp\apps\wordpress\htdocs\wp-settings.php(566): include(‘G :\\xampp\\apps\\w…’) #2 G:\xampp\apps\wordpress\htdocs\wp-config.php(111): require_once(‘G:\\xampp\\apps\\ w…’) #3 G:\xampp\apps\wordpress\htdocs\wp-load.php(50): require_once(‘G:\\xampp\\apps\\w…’) #4 G :\xampp\apps\wordpress\htdocs\wp-admin\admin.php(34): require_once(‘G:\\xampp\\apps\\w…’) #5 G:\xampp\apps\wordpress \htdocs\wp-admin\customize.php(13): require_once(‘G:\\xampp\\apps\\w…’) #6 {main} thrown in G:\xampp\apps\wordpress\htdocs \wp-content\themes\magicraft\library\creepy.php on line 427

    If someone can help me I would be very grateful and sorry for my language, I am not an English speaker.

Viendo 5 respuestas - de la 1 a la 5 (de un total de 5)
  • Moderador almendron

    (@almendron)

    Estás en el foro de España así que no solo puedes sino que debes usar dicho idioma.

    El error es debido al uso incorrecto de una comillas en la línea 427 del archivo «\library\creepy.php». En lugar de usar la comilla simple recta ha usado otra. El problema se resuelve cambiando

    add_filter( ‘theme_mod_background_image’, ‘backstretch_background_image_mod’ );

    por

    add_filter( 'theme_mod_background_image', 'backstretch_background_image_mod' );

    Iniciador del debate altur

    (@altur)

    Lo gracioso es que soy español pero por alguna razón pensé que tenia que escribir en ingles, voy a probar a ver si funciona, tras probarlo ahora salta otro error distinto,

    Warning: Undefined array key 0 in G:\Xampp\htdocs\wp-content\themes\magicraft\functions.php on line 35

    Warning: Trying to access array offset on value of type null in G:\Xampp\htdocs\wp-content\themes\magicraft\library\creepy.php on line 172

    Fatal error: Uncaught ArgumentCountError: Too few arguments to function WP_Widget::__construct(), 0 passed in G:\Xampp\htdocs\wp-includes\class-wp-widget-factory.php on line 61 and at least 2 expected in G:\Xampp\htdocs\wp-includes\class-wp-widget.php:162 Stack trace: #0 G:\Xampp\htdocs\wp-includes\class-wp-widget-factory.php(61): WP_Widget->__construct() #1 G:\Xampp\htdocs\wp-includes\widgets.php(115): WP_Widget_Factory->register(‘Mcsolo_Server_S…’) #2 G:\Xampp\htdocs\wp-content\themes\magicraft\functions.php(629): register_widget(‘Mcsolo_Server_S…’) #3 G:\Xampp\htdocs\wp-includes\class-wp-hook.php(307): minecraft_server_stats_register_widget(») #4 G:\Xampp\htdocs\wp-includes\class-wp-hook.php(331): WP_Hook->apply_filters(», Array) #5 G:\Xampp\htdocs\wp-includes\plugin.php(476): WP_Hook->do_action(Array) #6 G:\Xampp\htdocs\wp-includes\widgets.php(1854): do_action(‘widgets_init’) #7 G:\Xampp\htdocs\wp-includes\class-wp-hook.php(307): wp_widgets_init(») #8 G:\Xampp\htdocs\wp-includes\class-wp-hook.php(331): WP_Hook->apply_filters(NULL, Array) #9 G:\Xampp\htdocs\wp-includes\plugin.php(476): WP_Hook->do_action(Array) #10 G:\Xampp\htdocs\wp-settings.php(598): do_action(‘init’) #11 G:\Xampp\htdocs\wp-config.php(96): require_once(‘G:\\Xampp\\htdocs…’) #12 G:\Xampp\htdocs\wp-load.php(50): require_once(‘G:\\Xampp\\htdocs…’) #13 G:\Xampp\htdocs\wp-admin\admin.php(34): require_once(‘G:\\Xampp\\htdocs…’) #14 G:\Xampp\htdocs\wp-admin\customize.php(13): require_once(‘G:\\Xampp\\htdocs…’) #15 {main} thrown in G:\Xampp\htdocs\wp-includes\class-wp-widget.php on line 162

    • Esta respuesta fue modificada hace 2 semanas, 2 días por altur.
    Moderador almendron

    (@almendron)

    Casi seguro que estás trabajando con la versión 8.X de PHP y por eso te da esos errores. Con la 7.4 funciona bien.

    Consejo: olvídate de ese tema y busca otro, a ser posible que esté en el repositorio de WordPress.

    Temas

    Iniciador del debate altur

    (@altur)

    Efectivamente, estoy usando la ultima version estable de php, buscare entonces otro thema y lo adaptare a mi gusto, muchas gracias

    Moderador almendron

    (@almendron)

    De nada. Un saludo.

Viendo 5 respuestas - de la 1 a la 5 (de un total de 5)
  • Debes estar registrado para responder a este debate.