Soporte » Multisitio » Error tras migración.

  • Hola a todxs!
    Configuré una instalación multisite (en local con Xampp, y con subdirectorios) y posteriormente se anuló el multisite para migrarlo a hosting con “Duplicator”. Sin problemas.

    Ahora, al querer volver a activar el multisite, aparece un aviso: “Cuidado: ya hay una red de worpress”, y al intentar activarla (modificando los archivos wp-config.php y .haccess),
    primero me remitía “localhost”; la dirección que aparecía en el texto propuesto para modificar wp-config.php era “localhost” (supongo que son “restos” de la instalación anterior)
    y trás corregir la dirección (sustituyendo “localhost” por la dirección “midominio.com”) aparece el “Error establishing a database connection” y deja de funcionar todo.

    Imagino que hay “datos” de la primera instalación que habría que modificar… ?? ¿Dónde?

    Muchas gracias.

Viendo 1 respuesta (de 1 total)
  • Moderador Jose Conti

    (@jconti)

    Hola,

    Un multisite no se puede migrar de la forma que lo has hecho. Duplicator solo modifica la parte del sitio principal y no de los subsitios o tablas globales.

    Deberás realizar de nuevo la migración, o mirar de reparar la ya migrada.

    Para hacerlo, debes utilizar el script https://interconnectit.com/products/search-and-replace-for-wordpress-databases/

    Busca el primer lugar en toda la base de datos, localhost (si es que el dominio que tenias en local era este, si fuera localhost:8080, busca este otro o el que sea.

    Una vez buscado y reemplazado, busca el antiguo path (el que tenias en tu ordenador) y sustitúyelo por el nuevo path (el que tienes ahora en el servidor). Multisite utiliza los path mucho más que WordPress simple.

    Si no consigues arreglarlo de esta forma, deberás hacerlo todo de forma manual, que es cómo yo siempre migro los multisite.

    Backup de la base de datos, backup de archivos. Se sube todo al servidor, se pasa el script y se modifica el archivo WP-config.php para poner el nuevo dominio principal y los datos de conexión con la nueva base de datos.

    Saludos

    • Esta respuesta fue modificada hace 2 meses, 3 semanas por  Jose Conti.
    • Esta respuesta fue modificada hace 2 meses, 3 semanas por  Jose Conti.
Viendo 1 respuesta (de 1 total)
  • Debes estar registrado para responder a este tema.