Soporte » Guías – Resolución de problemas » error: undefined variable

  • Resuelto almejoselx

    (@almejoselx)


    Hola, necesito que me digan porque al poner “debug” me salen una serie de errores, les mando una captura. Gracias. (si necesitan mas información pidan-mela”.
    Notice: Undefined variable: post in /var/www/vhosts/almelx.es/httpdocs/wp-content/themes/responsive/core/includes/post-custom-meta.php on line 113

    Notice: Trying to get property of non-object in /var/www/vhosts/almelx.es/httpdocs/wp-content/themes/responsive/core/includes/post-custom-meta.php on line 113

    Notice: Undefined variable: post in /var/www/vhosts/almelx.es/httpdocs/wp-content/themes/responsive/core/includes/post-custom-meta.php on line 113

    Notice: Trying to get property of non-object in /var/www/vhosts/almelx.es/httpdocs/wp-content/themes/responsive/core/includes/post-custom-meta.php on line 113

    Notice: Undefined variable: post in /var/www/vhosts/almelx.es/httpdocs/wp-content/themes/responsive/core/includes/post-custom-meta.php on line 113

    Notice: Trying to get property of non-object in /var/www/vhosts/almelx.es/httpdocs/wp-content/themes/responsive/core/includes/post-custom-meta.php on line 113

    • Este debate fue modificado hace 3 meses por  almejoselx.
Viendo 7 respuestas - 61 de 67 (de 67 total)
  • Os la dejo por aquí por si queréis verla. Está en una plataforma de pruebas de CDmon:
    http://probak.eus.mialias.net
    Usuario: probak364
    Contraseña: t25VEBjG

    Moderador Jose Conti

    (@jconti)

    @almejoselx, ¿Usas la última versión de WooCommerce? La última versión arregla varios bugs que provocaban este tipo de Notices.

    La 3.0.9

    Si @pablo-moratinos, uso exactamente igual WP 4.8, Responsive 2.7.2, WC 3.0.9 y PHP, tenia 7.0.14 y cambie para provar a 5.6, y ahora tengo 7.0.14. y sigue el problema igual…

    Moderador LGrusin

    (@lgrusin)

    Pues si, da igual la versión de PHP. No sé que pruebas hice antes que no me dió el aviso, siento el lio…

    El problema se genera cuando la página de WooCommerce Tienda se pone como página de inicio. El tema Responsive no puede comprobar los layouts puesto que no cumplen ninguna de las condiciones de los diferentes “if” del archivo core/includes/post-custom-meta.php

    Sinceramente no vale la pena complicarse puesto que no afecta para nada al funcionamiento, además tener el modo debug activado no es la forma correcta de trabajar. Se desactiva y a esperar que el autor del tema lo resuelva.

    Un saludo

    OK, muchas gracias por la información y es esfuerzo para resolverlo. Trabajare con DEBUG false asta que el autor repase esas incidencias. Un saludo a todos los que han intervenido y repito las gracias.

    Hola @almejoselx,
    Por aclararlo, deberías tener SIEMPRE el modo DEBUG en false salvo que estés realizando tareas de desarrollo y pruebas. Una vez que tengas la web en producción, especialmente, deberá estar en false.

Viendo 7 respuestas - 61 de 67 (de 67 total)
  • Debes estar registrado para responder a este tema.