• tanius3

    (@tanius3)


    Hola a todos,

    No sé si es a la única que le pasa, pero, cuando intento actualizar la versión PHP 7.4 la web se cae y no me deja entrar al panel de admin. No encuentro el problema (si es un plugin, la versión del tema…)

    Muchas gracias 🙂

    La página con la que necesito ayuda: [accede para ver el enlace]

Viendo 9 respuestas - de la 1 a la 9 (de un total de 9)
  • Moderador almendron

    (@almendron)

    Para encontrar al causante del fallo haz lo siguiente:

    1) Desactiva TODOS los plugins.

    2) Cambia de tema. Activa uno de los que trae por defecto WordPress.

    3) Cambia PHP a la versión 7.4

    Si ahora puedes entrar en la administración, solo tienes que

    1) Volver al tema y comprobar.

    2) Plugin a plugin: activar – comprobar

    tanius3

    (@tanius3)

    Muchas gracias por tu comentario. ¿Es posible que el problema solo esté en el tema? Porque he desactivado todos los plugins y se ha roto la web.

    Moderador almendron

    (@almendron)

    ¿Qué significa que se ha roto la web? Es normal que no se vea bien si desactivas los plugins. Lo importante es que sigas los pasos que te he dicho.

    tanius3

    (@tanius3)

    He recibido este correo:

    «Desde WordPress 5.2 hay una característica incorporada que detecta cuándo un plugin o un tema causa un error fatal en tu sitio y te avisa mediante este correo electrónico automático.

    En este caso, WordPress ha detectado un error con tu tema, New Standard.
    tipo E_ERROR en la línea 76 Mensaje de error: Uncaught Error: Call to undefined function register_widget() in /hosting/»

    Moderador almendron

    (@almendron)

    ¿Cuando ha sucedido el error crítico? ¿al cambiar a 7.4 o al desactivar los plugins?

    tanius3

    (@tanius3)

    Al cambiar al 7.4 ¿Cómo puedo solucionarlo o saber cuál es el widget que ocasiona el error? Gracias

    Moderador almendron

    (@almendron)

    ¿Añade el tema algún widget en concreto?

    Debes diferenciar entre los widgets propios de WordPress y los que añade el tema. Estos últimos son los que deberías quitar. Aún así, es muy probable que el error se mantenga.

    tanius3

    (@tanius3)

    ¿Cómo puedo diferenciar los widgets? Y si el error se mantiene ¿cuál es la solución?

    Moderador almendron

    (@almendron)

    Quita todos los widgtes y luego pasas a la 7.4

    Si te vuelve a dar error, entonces solo te queda ponerte en contacto con los desarrolladores del tema. Nosotros poco podemos ayudarte ya que usas un tema comercial y los voluntarios del foro no tenemos acceso a ese tipo de productos. No podemos, por tanto, realizar pruebas.

    Si quitando todos los widgets no da error, ve añadiendo-comprobando uno a uno.

Viendo 9 respuestas - de la 1 a la 9 (de un total de 9)
  • Debes estar registrado para responder a este debate.