Soporte » Instalación – Actualizaciones » errores despues de actualizar tema

  • Hola

    cada vez que actualizo el tema Divi, tengo problemas despues, como sobre todo errores 500 al querer editar una entrada o pagina.
    la unica solución que tengo es volver a poner la versión anterior

Viendo 15 respuestas - 16 de 30 (de 41 total)
  • ya! pero es la misma ruta que en las otras versiones, cambiando es o en por fr..
    de hecho, incluso poniendo el codigo del widget español, en esta pagina francés no funciona….

    puedes decirme lo que reinstalar el wordpress, es mejor borrar antes de subir que sobre escribir?

    Moderador almendron

    (@almendron)

    Hay un error en la ruta. Revísalo.
    Ruta en español: http://www.avaibook.com/widgets_propietarios/calendario.php?id=20290&lang=es
    Ruta en francés: http://www.casasierrasalamanca.com/fr/%C2%A0%C2%BBhttp:/www.avaibook.com/widgets_propietarios/loader.php?id=20290&lang=fr%C2%A0%C2%BB

    En cuanto a tu pregunta, da lo mismo aunque siempre es más seguro borrar y luego subir que sobrescribir.

    • Esta respuesta fue modificada hace 4 meses, 4 semanas por  almendron.

    ???
    esa ruta siempre es la que ha funcionado pero la que me enseñas no es la que he pegado, como si wp o no se qué ha añadido el principio por su cuenta…
    , además si cambio como te dije la ruta por una que funciona como español o inglès, tampoco funciona en esa pagina. es lo que no entiendo…

    • Esta respuesta fue modificada hace 4 meses, 4 semanas por  fredericcreusot.
    • Esta respuesta fue modificada hace 4 meses, 4 semanas por  fredericcreusot.

    el codigo que esta en la pagina es:

    <iframe style=”width: 500px; height: 355px; border: 0;” src=”http://www.avaibook.com/widgets_propietarios/loader.php?id=20290&lang=fr” width=”300″ height=”150″ frameborder=”0″>Tu navegador no soporta iframes</iframe></p><div style=”width: 500px; margin: auto;”> </div>

    Moderador almendron

    (@almendron)

    WP añade a veces la url del sitio propio cuando hay un error en el enlace.
    Comprueba las comillas que abren y cierran el enlace a avaibook, es decir, las que están antes de “http” y después de “fr”. Bórralas y las vuelves a poner a mano. Creo que ahí está el error. No son las adecuadas. No me refiero a que no sean comillas dobles sino a que son comillas “con formato”, como si las hubieras copiado desde un Word por ejemplo.

    Moderador almendron

    (@almendron)

    Mejor dicho: comprueba todas las comillas. Ponlas todas de nuevo a mano.

    no es eso, te digo que si copio el codigo de otra lengua, la coloco alli, y tampoco funciona, además esa ruta en francés no la toque y empezo a ir mal…Ayer, cuando instalé todo desde cero, funcionaba , despues se fastidio al actualizar wp …
    creo que el error no esta por alli, además desde el soporte del widget, me han dicho que funciona…

    • Esta respuesta fue modificada hace 4 meses, 4 semanas por  fredericcreusot.

    ya acabo desactivar todos los plugins y funciona, entonces, el culpable es uno de ellos al actualizarlos en mismo tiempo que el wp. ahora toca encontrar cual…

    El plugin polylang, que he actualizado el otro día.
    toca poner la version antigua, o como hacer? es un problema quedarse con una version sin actualizar? pero que no da problemas?

    es muy raro, raro raro raro como decia el padre Iglesias…

    he subido versión anteriores de 2 back up desde enero, y tampoco me funcionan, si quito el plugin el calendario se ve, pero jolines hace poco con ese plugin polylang se veía, debe haber algo más,,,,,?

    y insisto, ayer hubo un momento que me funciono….voy a tener que volver a subirlo todo otra vez…

    • Esta respuesta fue modificada hace 4 meses, 4 semanas por  fredericcreusot.
    Moderador almendron

    (@almendron)

    Por lo que veo, ahora ya funciona.
    ¿Cómo han quedado las versiones del plugin y de WP?

    si , me pasé hasta las 3 de la madrugada con esto pues tuve que volver cargar todo menos upploads.

    es una versión de backup del 09 de junio 2017. el wp anterior, divi sin actualizar, polylang y otros 7 o 9 plugins sin actualizar tampoco…

    solo con poner un polylang antiguo, no me funcionaba, he tenido que subir todo otra vez…

    voy a intentar poco a poco, primero actualizar wp a ver, y luego los plugins uno a uno.
    ,me imagino que lo importante para la seguridad es tener wp actualizado. es lo mismo con el tema y los plugins o puedo dejarlos con versiones antiguas?

    Moderador almendron

    (@almendron)

    Si todo te funciona bien, deja las versiones antiguas.

    Ahora lo importante es determinar dónde está el problema. Instala en local y haz allí las pruebas. NO TOQUES EL SERVIDOR.

    Una vez hayas determinado el origen del problema, ya veremos cómo solucionarlo.
    Activa en local el debug para ver todos los errores.

    es mejor en local en en una versión de prueba en otra parte de mi servidor? es lo que te preguntaba ayer, he subido en un dominio raro que me dijeron que era para eso. pero lo que no sé, es si google podría indexar esa versión de alguna manera, lo que sería duplicate content?

    Moderador almendron

    (@almendron)

    La verdad es que ni idea.
    Pero vamos a ver, si te manejas bien en local, no te compliques la vida y hazlo allí. Eso sí, intenta que las versiones de PHP en local y en el servidor sean las mismas.

Viendo 15 respuestas - 16 de 30 (de 41 total)
  • Debes estar registrado para responder a este tema.