Soporte » Guías – Resolución de problemas » FACEBOOK NO RECONOCE LAS METAS OPEN GRAPH

  • Buenas con todos, tengo un problema que estoy arrastrando ya hace más de tres meses.

    Sucede que no logro conseguir que Facebook detecte mi imagen destacada al momento de compartir CUALQUIER ENLACE de mi página. He probado de todo y nada.

    Dato curioso: Yo uso Yoast Seo y, se supone que esta extensión agrega los op automáticamente. Cuando desactivé Yoast Seo (para ver si este era el problema), la imagen destacada al momento de compartir en Facebook sí apareció. PERO, a los minutos, dejó de ser detectada.
    Entonces, volví a activar Yoast Seo (pensando que ahora sí los op se pondrían bien), y al instante la imagen destacada fue detectada. PERO, a los minutos, vuelve a no detectarlo. Uso el depurador de Facebook para darme cuenta de esto.

    Me ha ocurrido lo mismo al borrar caché, a los minutos lo detecta; PERO, cuando pasa un rato, deja de hacerlo.

    No sé cuál podrá ser el problema. Pero, he verificado que los OP sí están puestos.
    Esto es un dolor de cabeza, por favor, que alguien pueda ayudarme. GRACIAS.

    La página con la que necesito ayuda: [accede para ver el enlace]

Viendo 13 respuestas - de la 1 a la 13 (de un total de 13)
  • Moderador almendron

    (@almendron)

    Ahora mismo te funciona bien. Puedes comprobarlo en https://developers.facebook.com/tools/debug/

    Ten en cuenta que facebook guarda en cache los datos la primera vez que alguien comparte tu entrada. Para ver los resultados actuales deberás introducir la URl, cilc en «Depurar» y luego clic en «Volver a extraer».

    Iniciador del debate psicologiapositiva

    (@psicologiapositiva)

    Hola. Sí, detecté que el problema era W3 Total Cache. Al activarlo, me bloquea las imágenes destacadas. Ahora mi problema estaría en encontrar algún pluging que me ayude con el caché. Además, no sé si el automotize me dé el mismo error.
    Además, tengo el Cloudflare, pero no sé si este reemplaza a alguno de los dos plugins :/
    De todas formas, agradezco tu respuesta <3

    Moderador almendron

    (@almendron)

    En principio, W3 Total Cache no bloquea ninguna imagen. Cloudflare no es un cache propiamente dicho.

    Yo probaría a activar de nuevo y ver entonces el error que se produce en el depurador de Facebook.

    Iniciador del debate psicologiapositiva

    (@psicologiapositiva)

    El tema ocurre cuando activo el W3 Total Cache. El error que me figura es el error 206. Y cada vez que lo activo, me aparece el error a los minutos: me sale que faltan datos op:image. No figura la imagen destacada (en el depurador). Y, al momento de compartir el link de una entrada (así ya haya detectado la imagen cuando desactivé el W3TC), no la detecta otra vez Facebook, tanto en el depurador como en un muro de Facebook.
    Sin embargo, los datos OP ya están por el Yoast Seo. los corroboré.
    Es por eso que digo que el problema me lo está dando el W3 Total Cache 🙁
    Nota: Cuando digo que el W3 Total Cache bloquea mi imagen destacada no me refiero al WordPress, sino al problema que hay en el depurador de Facebook.

    Moderador almendron

    (@almendron)

    ¿Recuerdas si tenías activado «Gzip Compression» en W3 Total Cache? He estado investigando un poco y al parecer esa opción podría ocasionar el problema si también estuviera activada a nivel del servidor

    Iniciador del debate psicologiapositiva

    (@psicologiapositiva)

    He desactivado la única opción que decía «Comprensión HTTP (gzip)» que tenía habilitado en el W3 Total Cache en la pestaña de Cache del Navegador. Voy a esperar unas horas y verificaré si ese ha sido el error.
    Al instante que modifiqué y guarde los ajustes, borré el caché. Y he visto que en el depurador de facebook se mantiene la imagen destacada; pero, figura «Código de respuesta 206»
    Por ese motivo, esperaré unas horas y veré si se mantiene la imagen.

    Iniciador del debate psicologiapositiva

    (@psicologiapositiva)

    Saludos. Al parecer el problema se ha solucionado, por el momento, las entradas que tengo ya les aparece su imagen destacada en el depurador de facebook. Sin embargo, el depurador sigue indicando «Código de respuesta 206» y no sé si eso está bien.
    Solo espero que en las futuras entradas que realice, la imagen destacada sea detectado sin ningún problema.
    Agradezco su pronta respuesta. Un abrazo y éxitos.

    Moderador almendron

    (@almendron)

    Lo normal sería que te saliera 200 y no 206.

    ¿Tienes ahora desactivada la opción «Comprensión HTTP (gzip)»? Si es así, déjala desactivada porque me sale que tu página está comprimida lo cual indicaría que la compresión la tienes activada a nivel del servidor.

    Yo lo que haría es desactivar todos los módulos (Page Cache, Minify, Database Cache, Object Cache y Browser Cache). Luego me iría al depurador de Facebook y comprobaría si ya sale 200. En caso afirmativo, ve activando-comprobando módulo a módulo.

    Iniciador del debate psicologiapositiva

    (@psicologiapositiva)

    Hola. Al intentar compartir mis post por whatsaap, no aparecen (así hayan sido detectados por facebook). Entiendo que es por el código de respuesta 206.
    Hice lo que me indicaste, de ir viendo uno por uno, y aún se mantiene el 206 con cada uno o desactivando todo.
    El código 200 solo aparece cuando desactivo W3 Total Cache (todo el plugin).
    Recuerdo que hice algunos cambios en las otras pestañas de configuración, guiándome de un tutorial en una página. Entonces, he pesando en desinstalar el plugin y volver a instalarlo, para que regrese a su configuración por defecto. De esta forma, veré si los problemas fueron por cambiar las configuraciones de las otras pestañas que tiene W3 Total Cache o el plugin en general.
    Nota: ¿Conoce otroa plugin gratuita que pueda reemplazar a W3 Total Cache?
    Gracias.

    Iniciador del debate psicologiapositiva

    (@psicologiapositiva)

    He desinstalado el W3 Total Cache y lo he vuelto a instalar (para regresar a la configuración por defecto) y tampoco me deja de aparecer el código de respuesta 206.
    Solo desaparece cuando lo desactivo.
    ¿Existirá algún otro pluging gratuito?

    Moderador almendron

    (@almendron)

    Iniciador del debate psicologiapositiva

    (@psicologiapositiva)

    Hola. Justo iba a ponerme de desinstalar el W3 Total Cache cuando me di cuenta que en otros post el código de respuesta sí figura 200; pero, en el único post en donde me figura código de respuesta 206 es el siguiente:

    https://www.psicologiapositiva.site/salud-mental/como-saber-si-tengo-estres-causas-tipos-sintomas-tratamiento-y-prevencion/

    Puedes contrastarlo con los siguientes enlances:

    https://www.psicologiapositiva.site/salud-mental/quiero-ser-feliz-por-donde-empezar/

    https://www.psicologiapositiva.site/competencias-laborales/recursos-psicologicos-para-la-didactica-en-aulas-virtuales/

    ¿Habrá algún problema con ese post que indica 206?

    Moderador almendron

    (@almendron)

    Cambia la imagen del post del 206 y que su nombre (el de la imagen) no lleve acentos, espacios ni signos como la «ñ» u otros raros. Después comprueba.

    • Esta respuesta fue modificada hace 10 meses, 3 semanas por almendron.
    • Esta respuesta fue modificada hace 10 meses, 3 semanas por almendron.
Viendo 13 respuestas - de la 1 a la 13 (de un total de 13)
  • El debate ‘FACEBOOK NO RECONOCE LAS METAS OPEN GRAPH’ está cerrado a nuevas respuestas.