Soporte » Instalación – Actualizaciones » Falla en Migración de Hosting mismo dominio

  • Resuelto rchaves

    (@rchaves)



    Hola, agradezco la ayuda ya que no tengo mucha experiencia con WP. Me pidieron el favor de migrar un sitio web en WP desde un Hosting al que no me dieron acceso por lo que el webmaster de ese sitio me envío el archivo backup en .zip incluida la base de datos, la migración es a un hosting con CPANEL (Colombiahosting). Lo primero que hice fue subir el .zip al directorio public_ftp del nuevo Hosting y luego descomprimí los archivos en la raíz public_html. Luego cree una base de datos y un usuario y en el phmyadmin importé el sql de la base de datos que me enviaron. Por ultimo modifiqué los datos de acceso a la base de datos en wp-config.php con los de la nueva y luego re-apunté el dominio a los DNS del nuevo Hosting. El problema es que el sitio solo muestra la pagina inicial y no navega hacia las otras paginas, error 500 y para complicar cuando intento ingresar a valenciajoyas/wp-admin.php o wp-lugin.php me da error de autenticación porque automáticamente me disecciona al hosting anterior a pesar de que ya están replicados los DNS. Alguna idea? Gracias.

Viendo 9 respuestas - 1 de 9 (de 9 total)
  • kallookoo

    (@kallookoo)

    Hola,
    Las DNS pueden tardar en divulgarse, aparte no existe wp-admin.php ni wp-lugin.php (este ultimo creo que sera un error tipografico ya que es wp-login.php)

    Si el WordPress usa el mismo dominio si o si deberias poder visualizarla o entrar en el admin. Veo que comentas que te redirecciona al hosting anterior, con lo dudo de lo que comentas.
    O las DNS no estan divulgadas aun o el WordPress no usa el mismo dominio.

    Ya comentas pero lo mejor es comprobar hacia donde apunta el dominio y si realmente usas el mismo dominio.

    Prueba con eliminar el archivo .htaccess de la carpeta raís y vuelve a seleccionar la opción predeterminada de enlaces permanentes en el admin. Luego vuelve a modificarla por la de nombre de entrada.

    Esta es la forma manual de hacer la función <?php flush_rewrite_rules(); ?> para darle acceso a las URLs personalizadas.

    • Esta respuesta fue modificada hace 2 meses, 4 semanas por  Lunestudio.
    Moderador LGrusin

    (@lgrusin)

    @rchaves si has solucionado el problema, por favor, marca el debate como resuelto.

    Un saludo

    Muchas gracias a todos, aunque llevaba dos días con el descubrimiento de los DNS decidí volver a realizar todo el procedimiento desde cero y ya está resolviendo bien.

    rchaves

    (@rchaves)

    Hola a todos, De nuevo acudo al foro porque después de mes y medio de estar operativo el sitio me llamaron porque se había caído, fui a revisar y salia famoso error de conexión a la base de datos. Revisé el archivo config.php y estaba con otra información de la base de datos por lo que lo actualice con los datos de conexión correctos y ahora cuando queremos ver el sitio pide instalar el WP. Como hago para que me muestre lo existente? Ya intenté aceptar la instalación pero genera un WP nuevo en blanco así que tuve que subir la base de datos de nuevo pero sigue pidiéndome instalarlo de nuevo.

    Este es el sitio: https://valenciajoyas.com/

    Agradezco mucho la ayuda ya que he tratado de solucionarlo y no he podido.

    Saludos,

    Lunestudio

    (@lunestudio)

    Revisa en el config.php el prefix de las tablas para que coincida con las del WP ya instalado.

    rchaves

    (@rchaves)

    Definitivamente es mejor preguntarle a los mejores. Lunaestudio mil gracias, no se porque se me había pasado ese en la revisión, ya me estaba matando la cabeza.

    Ya esta OK de nuevo, lo que no entiendo es porque sucedió eso si el propietario me dijo que no había tocado nada. Seria algún intento de ataque? Igualmente yo le cambie la calve del Cpanel por una mas segura.

    Saludos,

    Lunestudio

    (@lunestudio)

    Sería raro un ataque de ese tipo.
    Es más probable que hayan reemplazado sin querer o sin darse cuenta el archivo wp-config.php, salvo que en el host hayan puesto un número de IP, lo cual serviría para mostrar un sitio completamente distinto. Si seguía diciendo “localhost” lo más probable es que haya sido un error del propietario.
    Saludos y me alegro que se haya solucionado!

    rchaves

    (@rchaves)

    OK Gracias¡

Viendo 9 respuestas - 1 de 9 (de 9 total)
  • Debes estar registrado para responder a este tema.