Soporte » Plugins y Hacks » Fallo en sendinblue?

  • Hola, desde que pasé mi página de http:// a https:// no me funciona el formulario de sendinblue que tengo en el footer, alguien me puede dar alguna directriz de cómo solucionarlo?

    La página con la que necesito ayuda: [accede para ver el enlace]

Viendo 15 respuestas - 1 de 15 (de 20 total)
  • Moderador almendron

    (@almendron)

    ¿Te da algún mensaje de error? ¿qué plugin es exactamente el que usas?

    Otra cosa. he visto en la consola un mensaje de error: «Se ha bloqueado la carga del contenido activo mixto «http://alfagenerators.es/wp-content/plugins/woocommerce-multilingual/templates/currency-switchers/legacy-dropdown/style.css»

    El bloqueo se produce en Firefox porque sirves bajo http dicho recurso en lugar de hacerlo vano htpps.

    El plugin es sendinblue. El error que me comentas que has visto en un principio hizo que me desapareciera el footer también y lo «solucioné» con css. Pero a la vista está que no lo solucioné porque no funciona el plugin en sí. Es el formulario de ocntacto de la empresa en la que trabajo y tengo que solucionarlo por mi propio bien jajajja. Muchas gracias por la ayuda

    Moderador almendron

    (@almendron)

    Pero ese plugin: ¿está en el repositorio de WordPress o es comercial?

    Y bueno, yo lo primero que haría sería buscar un plugin con la misma funcionalidad para sustituir el que tienes: https://es.wordpress.org/plugins/search/contact/

    Prefiero buscar el fallo y solucionarlo porque la plataforma con la que trabaja la empresa es la de ese plugin y sería demasiado costoso cambiar de plataforma

    El plugin es este
    https://es.wordpress.org/plugins/mailin/

    • Esta respuesta fue modificada hace 1 año, 1 mes por  alfagen.
    Moderador almendron

    (@almendron)

    Lo primero de todo sería intentar averiguar cuál es el error exacto. Para ello:

    1) Edita wp-config.php y añade la línea define('WP_DEBUG', true);. Si ya existiera, comprueba que ponga «true». Tienes que añadirla antes de la línea que pone /* ¡Eso es todo, deja de editar! Feliz blogging */

    2) Cumplimenta el formulario y comprueba si aparece en pantalla algún mensaje de error.

    3) Accede a los logs de error del servidor y mira a ver si allí encuentras información sobre el error.

    Moderador almendron

    (@almendron)

    En cuanto al otro error, tal vez desactivando y activando de nuevo se solucione. Es de suponer que el plugin toma la ruta de las opciones de tu WordPress. Al activarlo por primera vez, cogería la http en lugar de https.
    El problema es que es muy probable que se haya quedado en la tabla correspondiente dicha ruta y tal vez no sirva esa solución.
    Siempre puedes echar un vistazo a `tusitio.xxx/wp-admin/options.php y ver si allí está.
    Si la opción está serialziada, es posible que no la veas a primera vista. Puedes usar https://es.wordpress.org/plugins/better-search-replace/ para buscarla

    • Esta respuesta fue modificada hace 1 año, 1 mes por  almendron.
    Moderador almendron

    (@almendron)

    Se me olvidaba: ¿has comprobado si el formulario funciona con TODOS los plugins desactivados?

    He escrito el código que estaba escrito pero con «false» y lo he cambiado a «true». He rellenado el formulario y sigue quedándose dando vueltas el circulito y no da error y sigue todo igual. He desactivado también y vuelto a activar el plugin de sendinblue. Y por si sirve de algo también diré que en el proceso de pasar de http:// a https:// con la herramienta «better search replace» sustituí todos los http://alfagenerators.es por https://alfagenerators.es dentro de la base de datos de la web.

    Muchas gracias, si hay alguna idea más estaré encantado de probar si funciona

    • Esta respuesta fue modificada hace 1 año, 1 mes por  alfagen.
    Moderador almendron

    (@almendron)

    1) ¿Has comprobado si el formulario funciona con TODOS los plugins desactivados excepto sendinblue?

    2) ¿Has comprobado los logs de errores del servidor?

    Perdón, me daba los siguientes errores:

    Notice: Undefined index: _ttml_job in /var/www/vhosts/alfagenerators.es/httpdocs/wp-content/plugins/responsive-testimonials/ttml.php on line 222

    Notice: Undefined index: _ttml_author in /var/www/vhosts/alfagenerators.es/httpdocs/wp-content/plugins/responsive-testimonials/ttml.php on line 221

    Notice: Undefined index: _ttml_job in /var/www/vhosts/alfagenerators.es/httpdocs/wp-content/plugins/responsive-testimonials/ttml.php on line 222

    – Pero el responsive testimonials no tiene nada que ver con el formulario.

    • Esta respuesta fue modificada hace 1 año, 1 mes por  alfagen.
    Moderador almendron

    (@almendron)

    Tenemos que descartar posibles causas y una de ellas es la interacción entre plugins o entre éstos y el tema.

    Desactiva todos los plugins (no se pierde la configuración) excepto el del formulario y después comprueba. También deberías después cambiar de tema y volver a comprobar.

    Hazlo si quieres a una hora que haya poco tráfico. Después de las pruebas, vuelves a activar y listo. No te debería llevar más de cinco minutos.

    Antes de cambiar a https:// funcionaba todo bien y sin conflicto, aún así esta noche lo comprobaré a horas que no hay tráfico para asegurarme. La consola de google me dice que hay dos errores en teoría de conflicto con la hoja de estilos de un plugin, pero no sé cómo arreglarlos. Quizá pueda ser eso también, mañana cuento que tal con la desactivación de plugins.

    Muchas gracias

    Hola de nuevo,

    lo hice el otro día y no ha habido cambios, alguna idea más?

    muchas gracias

    alguien me puede ayudar con esto? no le encuentro la solución…

Viendo 15 respuestas - 1 de 15 (de 20 total)
  • El debate ‘Fallo en sendinblue?’ está cerrado a nuevas respuestas.