Soporte » Instalación – Actualizaciones » Fatal error: require(): Failed Opening required

  • Hola, he intentado entrar a mi web a través de wp-admin y me aparecen una serie de errores que no se como solucionar.

    Warning: Use of undefined constant ‘WP_DEBUG’ – assumed ‘‘WP_DEBUG’’ (this will throw an Error in a future version of PHP) in /home1/basemxc1/public_html/ultramagicamerica.com/wp-config.php on line 164

    Warning: require(/home1/basemxc1/public_html/ultramagicamerica.com/wp-includes/class-wp-paused-extensions-storage.php): failed to open stream: No such file or directory in /home1/basemxc1/public_html/ultramagicamerica.com/wp-settings.php on line 40

    Fatal error: require(): Failed opening required ‘/home1/basemxc1/public_html/ultramagicamerica.com/wp-includes/class-wp-paused-extensions-storage.php’ (include_path=’.:/opt/cpanel/ea-php73/root/usr/share/pear’) in /home1/basemxc1/public_html/ultramagicamerica.com/wp-settings.php on line 40

    Al parecer me faltan archivos, pero no se como conseguirlos.

    La página con la que necesito ayuda: [accede para ver el enlace]

Viendo 5 respuestas - de la 1 a la 5 (de un total de 5)
  • Moderador almendron

    (@almendron)

    Por lo que veo, estás usando una versión muy antigua de WordPress (4.4.2).

    Al menos, debes actualizar a la última versión de esa rama, es decir a la 4.4.24: https://es.wordpress.org/wordpress-4.4.24-es_ES.zip

    Guía para actualizar manualmente: https://codex.wordpress.org/es:Actualizar_WordPress#Remplazamiento_manual

    Omite el paso 1.1 (Obtenga el archivo última versión de WordPress en zip (o tar.gz) y usa la versión que te he dicho en lugar de la última.

    ok, actualizare a la versión que me dices. solo una pregunta de los paso que me muestra en la guía de actualización. ¿Cómo desactivo los plugings si no puedo entrar por medio de wp-admin?

    Moderador almendron

    (@almendron)

    Los mensajes de error no están relacionados con plugins. No es necesario que los desactives. Al no cambiar de rama de WordPress, lo normal es que no den problemas.

    Lo que sí habrá que revisar después de actualices será el archivo wp-config.php.

    Listo, ya realice el cambio de archivos por la versión actualizada de wordpress que me dijiste. Ya pude ingresar a través de wp-admin, solo que me sigue apareciendo el mismo mensaje de error en la parte superior.
    ¿Qué específicamente debo revisar del wp-config.php?

    Moderador almendron

    (@almendron)

    Te salen dos errores.

    Uno es del plugin que está en la carpeta «envato-wordpress-toolkit-master». Mira a ver si lo puedes actualizar. En caso contrario, deberás desactivarlo e ir buscando un sustituto.

    Otro es el del wp-config.php. Editalo y mira a ver qué pone en la línea 164.

Viendo 5 respuestas - de la 1 a la 5 (de un total de 5)
  • Debes estar registrado para responder a este debate.