• Resuelto giolgi

    (@giolgi)


    Hola buenas. Quiero agregar fuentes propias a mi plantilla. Me he descargado la fuente en dafont.com y luego he descargado los archivos de esa fuente y el estilo mediante fontsquirrel. Esos archivos los he metido en la carpeta fonts de mi plantilla.

    El problema es que no consigo que se vea la fuente, pero parece que si que se accede a ella.

    En el style.css de mi tema he añadido esto:

    @font-face {
    font-family: ‘manuskriptgotischregular’;
    src: url(‘manuskriptgotisch-webfont.eot’);
    src: url(‘manuskriptgotisch-webfont.eot?#iefix’) format(‘embedded-opentype’),
    url(‘manuskriptgotisch-webfont.woff2’) format(‘woff2’),
    url(‘manuskriptgotisch-webfont.woff’) format(‘woff’),
    url(‘manuskriptgotisch-webfont.ttf’) format(‘truetype’),
    url(‘manuskriptgotisch-webfont.svg#manuskriptgotischregular’) format(‘svg’);
    font-weight: normal;
    font-style: normal;

    }

    y he modificado esta otra línea porque quiero que este elemento se muestre con mi nueva fuente:

    #access > .menu > ul > li > a > span {
    font-family:’cf_halloween’ !important;
    }

    Desde el inspector de mozilla, si cambio esta línea y pongo una fuente estandar si que se cambia la tipografía, por lo que entiendo que estoy modificando la línea correcta. Por el mismo motivo creo que tampoco es un problema de rutas.

    No se cual puede ser el problema, si los archivos de la tipografia son incorrectos o es otra cosa.

    Si alguien tiene alguna idea agradecería mucho vuestra ayuda.
    Gracias.

Viendo 7 respuestas - 1 de 7 (de 7 total)
  • Perdón, evidentemente ese nombre no es el mismo de la fuente, sería así:

    font-family:’manuskriptgotischregular’ !important;

    aún así no funciona

    Buenas,
    Tienes el sitio online para poder verlo?
    por otro lado en
    font-family:’manuskriptgotischregular’ !important;
    Las comillas que usas no son las correctas, ha sido cosa de ponerlo en el foro?
    la correcta sería comilla simple
    font-family:'manuskriptgotischregular' !important;

    Un saludo

    Hola @giolgi,

    ¿Has comprobado si la ruta es correcta? o sea, que tengas las fuentes en una carpeta (por ejemplo /fuentes/) y no las estés llamando correctamente.

    Ejemplo:

    src: url(‘/fuentes/manuskriptgotisch-webfont.eot’);

    Saludos!

    Gracias por las respuestas. Las comillas eran simples oldlastman y lo de la ruta lo tenia bien Roberto, primero las tenia en la ruta principal y luego dentro de fonts, y sí, especifique que accediera a esa ruta.

    Al final lo he solucionando con un plugin, así que no sé donde estaba el problema porque en ese plugin he puesto exactamente la misma etiqueta para modificar:
    #access > .menu > ul > li > a > span
    y ya me ha funcionado.

    Muchas gracias

    Me alegra que lo hayas solucionado @giolgi, ¿qué plugin usaste?

    Un saludo!

    El plugin se llama Tifinagh. Muy sencillito, subes tu fuente desde el mismo plugin y en los ajustes especificas a que elemento de tu css quieres añadirle la fuente. Un poco lioso saber exactamente que es lo que tienes que poner, pero supongo que eso ya dependerá de cada tema. Creo que ese era mi problema desde el principio.

    Saludos y gracias.

    Gracias @giolgi,

    De todos modos ten cuidado con los plugin que llevan mucho tiempo sin actualizar, ya que podrías tener problemas de seguridad. Te dejo aquí enlace al repositorio por si ves algún otro más actulizado que te permita hacer lo que necesitas https://wordpress.org/plugins/tags/custom-fonts

    Marca este post como resuelto por favor,

    Un saludo!

Viendo 7 respuestas - 1 de 7 (de 7 total)
  • El debate ‘Fuentes propias’ está cerrado a nuevas respuestas.