Soporte » WordPress Avanzado » Función obsoleta

  • ResueltoModerador almendron

    (@almendron)


    Tengo una función obsoleta para PHP 7.3 en un archivo del plugin Broken link-checker. En concreto «FILTER_FLAG_HOST_REQUIRED».

    Aparece en

    if ( !filter_var($url, FILTER_VALIDATE_URL, FILTER_FLAG_HOST_REQUIRED) ){
    	return false;
    }

    He estado buscando información y parece ser que ese filtro ya va implícito en «FILTER_VALIDATE_URL». ¿Es así? ¿bastaría con poner solo ese filtro?

    Algo así como

    if ( !filter_var($url, FILTER_VALIDATE_URL ) ){
    	return false;
    }
Viendo 6 respuestas - 1 de 6 (de 6 total)
Viendo 6 respuestas - 1 de 6 (de 6 total)
  • Debes estar registrado para responder a este debate.