Soporte » Guías – Resolución de problemas » get_currentuserinfo ha quedado obsoleto desde la versión 4.5. Utiliza wp

  • Hola
    Necesito ayuda!!
    me a aparecido este menaje:
    Notice: get_currentuserinfo ha quedado obsoleto desde la versión 4.5. Utiliza wp_get_current_user() en su lugar. in /var/www/vhosts/ropaparatodo.com/httpdocs/wp-includes/functions.php on line 3662

    si me pudieseis orientar de como solucionarlo,lo agradecería mucho

Viendo 3 respuestas - de la 1 a la 3 (de un total de 3)
  • Hola Javyereche,

    Este mensaje significa que alguno de tus plugins o tu tema está usando una función que ha quedado obsoleta en la última versión.

    El hecho de que te salga este mensaje significa que tienes activados los errores. (no especificas si es en el administrador o en tu sitio de cara al cliente)

    Para que deje de aparecer lo que puedes hacer es desactivar los mensajes de error, en el codex explica como:
    https://codex.wordpress.org/es:Depurar_en_WordPress

    En forma general lo que puedes hacer es ir al archivo wp-config.php y agregar la linea:

    define('WP_DEBUG', false);

    Esto no solucionará el problema, simplemente dejará de mostrarte el error, pero es una buena opción si tienes el sitio de cara al cliente y no quieres que vea ese tipo de errores.

    Lo que puedes hacer para solucionarlo es actualizar todos los plugins y tu tema o esperar a que ellos lo solucionen. WordPress 4.5 es muy nuevo por lo que es probable que los desarrolladores apenas estén actualizando sus plugins y temas.

    muchas gracias por tu respuesta!!
    e actualizado todo y me sale ahora este mensaje muchas veces:

    Notice: get_row_css_class ha quedado obsoleto desde la versión 4.2 y no hay alternativas disponibles. in /var/www/vhosts/ropaparatodo.com/httpdocs/wp-includes/functions.php on line 3664

    a que se debe?

    Hola Javyereche,

    Te recomiendo que leas el enlace. Allí te explican como hacer la depuración para WordPress.

    ¿Ya hiciste lo de editar la linea en el wp_config.php?
    define('WP_DEBUG', false);

    Eso por lo menos evitará que tus visitantes estén viendo un sitio lleno de errores.

    Es posible que te esté pasando eso por algún plugin que no se actualiza automáticamente.

    Puede estar relacionado con un plugin que no se actualiza automáticamente porque no es parte del repositorio de WordPress sino que lo actualizas con el proveedor directo (Ej: Visual Composer, plugin de un tema, etc).

Viendo 3 respuestas - de la 1 a la 3 (de un total de 3)
  • El debate ‘get_currentuserinfo ha quedado obsoleto desde la versión 4.5. Utiliza wp’ está cerrado a nuevas respuestas.