• Resuelto Kushif

    (@kushif)


    No tengo claro dónde poner esta duda que me mata, así que lo pongo aquí a ver si alguien me dice dónde iría mejor.
    Mi problema es sencillo.Tengo un blog llamado Egofriki.com

    Si pones «bq aquarius» en Google te da como resultado:
    1) La portada del blog > Egofriki.com, pero no te muestra la entrada.
    2) Las imágenes del artículo PERO NO EL ARTÍCULO

    La duda es ¿ cómo puedo evitar esto ? Es que la gente entra esperando ver el artículo y se les muestra esto… ¿ a qué puede ser debido ?
    En serio, invito a una cerveza a quien me eche una mano y a dos si está dispuesto a echarme una mano en otra duda que tengo.

    Un saludo. Muchas gracias.

Viendo 10 respuestas - de la 1 a la 10 (de un total de 10)
  • El problema esta en el plugin de Yoast Seo que genera dobles url canonicas de esta manera:

    <link rel="canonical" href="http://egofriki.com/bq-aquarius-dual-sim-y-libre/bq-aquarius-cabecera/" />

    como ves al final le agrega /bq-aquarius-cabecera/ por esta razón la búsqueda desde google no muestra el contenido.

    Iniciador del debate Kushif

    (@kushif)

    Teniendo en cuenta que ya te debo una cerveza 😉 ¿ Y tiene solución aparte de desinstalar el plug ?

    Hola Kushif/J3ick

    Supongo que llego tarde al pescado pero por mi parte (búsqueda desde España) veo el resultado en SERP correctamente, por lo que Kushif debes haber hecho los deberes 🙂 Si no es así, que sepas que aparece bien.
    Además sugiero revisar el juego de caracteres usado porque el sitio tiene problemas de validación importantes por esto:
    <!DOCTYPE html>
    <html lang=»es-ES» prefix=»og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#»&gt;
    <head>
    <!� Author >
    <link rel=�author� href=�[https://plus.google.com/113272544199630334852]� title=�Nombre/Descripci�n� />

    Suerte!

    Iniciador del debate Kushif

    (@kushif)

    He visto el problema varias veces, pero no logro dar con la solución. ¿Alguna sugerencia?

    Muchas gracias.

    El problema es feo pero sencillo de arreglar. Si no usas ya un editor de texto plano potente (Ultraedit, Notepad++, etc) descárgate uno de los gratuitos (recom. Notepa++ aunque yo uso profesionalmente Ultraedit desde 2003) y prueba a hacer lo siguiente (si me paso en detalle es por si lo lee alguien más con menos nivel):

    • Desde el Panel de control WP, Apariencia > Editor
    • Busca header.php en la lista para editarlo
    • Si no aparece el botón [Actualizar archivo]:
      Entra por FTP en tu hosting
      Busca tu instalación WP > wp-content > Themes > (Tema) > header.php
      Bájate una copia de header.php por si se tuerce la cosa
      Botón derecho sobre el fichero remoto y «Propiedades de archivo»
      En sus permisos debes cambiar el valor (probablemente 644) a 777
      Vuelve al editor WP y refresca la página de edición de header.php
      Cuando hayas logrado tus cambios, NO OLVIDES volver a dejar los permisos en 644 por lo menos
    • Copia el código fuente que da problemas, haz un buen repaso viendo el código fuente desde Firefox o Chrome para ver si es sólo la parte de la que header.php es responsable la que da problemas
    • Pega el código en el editor de texto, Notepad++ o similares, NO USES el bloc de notas de Windows, por mentar 🙂
    • Estos editores de texto plano te informan sobre la codificación del texto, asegúrate que coincide con el que usas en tu WP, normalmente UTF-8, en Ultraedit puedes cambiar esto si debes en Archivo > Conversión
    • Si los carácteres que se mostraban mal no se muestran correctamente tras la conversión, sencillamente comprueba (barra de estado del editor de texto) que el código usado es el que quieres y cambia los carácteres manualmente
    • Copia el texto corregido y sustituye con él la versión erronea del editor de WP, luego [Actualizar archivo]
    • Abre el frontend de tu WP en otra pestaña y mira su código fuente, deberías ver un código legible y limpio, con menos errores de validación W3C
    • Recuerda devolver el header.php a sus permisos originales con tu cliente FTP, normalmente 644

    Por cierto, veo en el post que comentabas al principio de esta conversación que ya has dado con la solución porque el link canónico redirige al permalink del post.
    Será que has activado la opción de WordPress SEO de YOAST que redirige la página de adjuntos al permalink del artículo en que aparecen 🙂

    Iniciador del debate Kushif

    (@kushif)

    ¡¡¡ Bravo !!!
    Mardito mi sueño ;_) no me enteraba de lo que me decías. Y es que uno es muy tonto (y más a las 5 de la mañana ) y he tenido que tomarme dos cafés para entenderte pero ¡ SOLUCIONADO !

    Así que dos gracias: Gracias por detectar el fallo y gracias por ayudarme a corregirlo. Estás invitado a una cerveza o a un café (los desplazamientos no corren a cargo de la invitación).

    En serio. Muchas gracias.
    Por cierto, efectívamente uso el SEO de Yoast. Curiosamente fue la mala configuración del mismo el que provocó los problemas con mis imágenes. Corregidos los problemas todo marcha sobre ruedas. Ahora sólo queda darle contenido.
    Gracias.

    Buenas tardes a todos, por un problema que tengo en wordpress desde hace más de un año, me veo en la necesidad de recurrir a ustedes que son los expertos en wordpress. El caso es que desde un tiempo acá me empezaron a salir paginas de adjuntos que es que solo sale la imagen del artículo y que para el colmo, estas rutas algo como esto http:rsanahuano.com/la-depresion/la-depresion/ (esto como ejemplo puesto que casi todas las tengo bloqueadas con un robot.txt) como se darán cuenta, el título se repite y hubo algunos casos que se repetían hasta 3 veces, ¿Raro verdad? y no solo eso que también salina así http://rsanahuano.com/la-depresion/la-depresion2/ y también http://rsanahuano.com/la-depresion/la-depresion2/#2
    http://rsanahuano.com/la-depresion/la-depresion2/#3 http://rsanahuano.com/la-depresion/la-depresion2/#4
    http://rsanahuano.com/la-depresion/la-depresion2/#5
    ¿Acaso esto no es ganas de darse un tiro en la cebeza porno saber dónde está la falla? he incursionado en casi todo, desde herramientas de web master de google, bing y no he conseguido solucionar esto. Este problema lo tuve hasta con 1335 url de esta índole y mi blog tiene 670 artículos.
    he logrado arreglar en algo con una redirección 301 pero no se puede hacerlo con los que salen la ruta repetida como las que indiqué, La pregunta del millón, ¿Se puede solucionar esto? y si se puede de qué forma se puede, por favor no me den nombres técnicos que así me confunden. Gracias de antemano.

    Me estaba olvidando, las rutas que salen repetidas se indexan de una forma que el artículo queda de lado y hasta se pierde, ahora que he arreglado en algo recién empiezan aparecer, esto me originó una perdida de visitas y PR de google de 4 a 0 incluso las visitas de 2000 al día que llegué a tener bajó a 10 porque las mayorías de las visitas terminaban en abandono por que no las encontraba, por si acaso las que me están saliendo ahora marcan un error 404 creo que es porque las tengo bloqueadas, el caso es que quiero evitar que me sigan saliendo ya que abandoné este blog por varios meses por no saber que hacer pero, como encontré la redirección 301 lo he retomado pero siguen con las páginas de adjunto, ¿Solución?

    Hola Roto,
    Creo que solucionarías fácilmente muchos de tus problemas activando la opción de redirección de página de adjuntos del plugin WordPress SEO de YOAST, aunque a priori parece que no lo usas. Esto sería en la configuración de enlaces permanente.

    Los adjuntos (attachments) a las entradas son almacenados en la base de datos como entradas, eso significa que son accesibles con sus propias URL’s si no las redireccionas.

    Una forma de combatir las páginas de adjuntos es configurar completamente y a conciencia las imágenes que incrustas en los artículos, especificando un link a una URL que te convenga o por contra ningún enlace.

    Por ejemplo, en tu entrada «Miedo y enfermedad van juntas» la imagen de la cara-calavera apunta a http://rsanahuano.com/miedo-y-enfermedad-van-juntas/miedo-y-enfermedad-van-juntas/ siendo esta una página «nula» para competir y quitando link juice al post. Deberías editar la imagen para eliminar el link, en este caso concreto.

    Por otra parte te recomiendo un buen redireccionador (yo uso Safe Redirect Manager en http://www.seomanager.es y varios clientes y va muy bien), con este plugin podrás llevar un control más exhaustivo de tus redirecciones, te aconsejo que redirijas lo que debas tras escribir tu nuevo contenido, si lo vas dejando perderás el control de nuevo!

    Un saludo y suerte

Viendo 10 respuestas - de la 1 a la 10 (de un total de 10)
  • El debate ‘Google indexa las imágenes pero no la entrada’ está cerrado a nuevas respuestas.