Soporte » Guías – Resolución de problemas » Google no muestra algunos posts de mi página web

  • Resuelto laraselles

    (@laraselles)


    Hola a todos,

    Hace un par de semanas que he creado mi blog de viajes con WordPress.org.

    He registro el sitio en Google Search Console y Google Analytics mediante el Site Kit.

    También he proporcionado un mapa XML del sitio en Google Search Console.

    Me encuentro con el problema de que ciertas entradas no se muestran en los resultados de Google, mientras que otras sí. Parece ser aleatorio, no he podido ver ningún patrón en el sentido de que todas las entradas anteriores o posteriores a una fecha dada se muestren en los resultados de búsqueda. Por ejemplo, esta entrada https://coleccionandoarenas.com/palaos-dia-2/ se muestra (y es la entrada más reciente de mi blog, publicada ayer), mientras que esta otra https://coleccionandoarenas.com/palaos-dia-1/ no, habiendo siendo esta publicada antes que la primera.

    Por poner otro ejemplo con otras 2 entradas (ambas más antiguas que las 2 anteriores): esta no se muestra https://coleccionandoarenas.com/un-dia-en-san-marino/
    Mientras que esta sí se muestra https://coleccionandoarenas.com/tres-dias-en-rimini/

    No he creado un archivo robots.txt, por lo que según tengo entendido ninguna URL debería ser excluida.

    Alguien tiene alguna idea de que puede estar sucediendo?

    Muchas gracias de antemano!

    La página con la que necesito ayuda: [accede para ver el enlace]

Viendo 4 respuestas - de la 1 a la 4 (de un total de 4)
  • Hola @laraselles

    El caso que indicas es muy extraño y necesitarías encontrar solución en algún foro sobre marketing y posicionamiento, no parece un problema específico de WP.

    Pero si te fijas en esta url: https://www.google.com/search?q=site:https://coleccionandoarenas.com&client=firefox-b-d&channel=trow2&ei=8-m2Xv7VA8rQaI_pmYAO&start=0&sa=N&ved=2ahUKEwi-m6TaqKfpAhVKKBoKHY90BuA4ChDy0wN6BAgJEC8&biw=774&bih=745

    Sólo tienes 18 páginas indexadas. Entra en el Google Search Console y revisa porque no se están indexando.

    Espero que vuelvas al foro a comentar tus avances y nos informes como lo arreglaste para futuros errores.

    Salut!

    Hola @adriandegrafreak ,

    Muchas gracias por tu respuesta! Efectivamente, estos días he entrado en Google Search Console, pero el problema se vuelve aún más extraño. Efectivamente las URL que no aparecen en los resultados de búsqueda aparecen marcadas como «Excluidas», es decir, descubiertas pero no indexadas. Y se indica, para todas ellas, el siguiente mensaje al inspeccionar la URL:

    La URL no está en Google
    Esta página no está indexada, pero no porque se haya producido algún error. Consulta los datos incluidos más adelante para saber cuál ha sido el motivo.

    Sin embargo, en los datos incluidos a continuación no se indica ningún motivo. Además, si pulso el botón de Probar URL publicada, se consigue probar satisfactoriamente. Incluso me deja solicitar indexación manual, aunque hace varios días solicite esto para 2 de ellas para probar y aún siguen excluidas (podría ser que requiera más tiempo, pero igualmente es muy extraño que ni siquiera se indique en el informe por qué han sido excluidas).

    También he confirmado que no hay ninguna intervención manual listada que haya excluido algunas de mis URL.

    Y he verificado que no hay ningún clon de mis entradas (me extrañaría mucho ya que las hemos estado escribiendo estos días, pero ya nos estamos volviendo paranoicos con todo).

    Por añadir más información, el mapa XML lo generé con Yoast SEO. Únicamente seleccioné que no se muestren en los resultados de búsqueda las plantillas y las páginas de archivo por categoría y por etiqueta. Lo cual no creo que ocasionara ningún problema, y si lo ocasionara, no debería afectar a algunas entradas y a otras no. También, todas las entradas usan la misma plantilla.

    He abierto un tema en los foros de soporte de Google a webmasters, sin duda dejaré por aquí cualquier avance!

    Estupendo @laraselles

    A ver si desde el foro de Google te dan una solución y la compartes por si algún usuario tiene el mismo problema que tu.

    Salut!

    @adriandegrafreak

    Por aquí dejo para futuras referencias la respuesta en los foros de Google!

    https://support.google.com/webmasters/thread/45603311?hl=es

    En resumen, parece ser normal y se debe al corto tiempo de vida de la página. El crawler necesita más rondas de recorrido para indexar todo correctamente.

    En cuanto al hecho de que entradas más recientes se hayan indexado antes que otras más antiguas, parece deberse a que el rastreo se inicia desde la página de inicio (con lo cual imagino que, al tener un widget de entradas recientes, encontraría primero las más recientes).

    Saludos!

Viendo 4 respuestas - de la 1 a la 4 (de un total de 4)
  • El debate ‘Google no muestra algunos posts de mi página web’ está cerrado a nuevas respuestas.