Soporte » Guías – Resolución de problemas » Google Search Console me avisa de enlaces que no he creado

  • Resuelto blastofshadows

    (@blastofshadows)


    Por algún motivo que desconozco, Google Search Console ha comenzado a detectar enlaces en mi wordpress que le dan error 404. El problema con estos enlaces, es que son url que sí existen, pero hay algo que les añade al final «/category/entrevistas-cosplay». (lo añade a todo, aunque no tenga nada que ver con la categoría). Lo que me han comentado es que he de encontrar dentro de mi web, que parte crea esos enlaces con esa terminación y cambiarlos ¡Pero buscando manualmente, inspeccionando código, etc… no lo encuentro.

    No sé que puede ser o que ha podido pasar, y me está mareando muchísimo.
    Segun google search console, los errores provienen de la misma página de la url bien escrita, como si cada artículo tuviera un enlace a si mismo terminando en «/category/entrevistas-cosplay».
    Imagen

    ¿Alguien ha visto alguna vez un error similar o sabe que podría pasar?

    La página con la que necesito ayuda: [accede para ver el enlace]

Viendo 7 respuestas - de la 1 a la 7 (de un total de 7)
  • Moderador LGrusin

    (@lgrusin)

    ¿Qué permalink usas? No entiendo la forma de organizar tu contenido, y me temo que Google tampoco.

    He visto que existe la categoría entrevistas-cosplay. ¿Has movido artículos de una categoría a otra? Puede que esa información sea contenido antiguo y que necesites indicarle que vuelva a rastrear el nuevo.

    Un saludo

    • Esta respuesta fue modificada hace 4 años, 1 mes por LGrusin.
    Iniciador del debate blastofshadows

    (@blastofshadows)

    ¡Hola! Gracias por responder.
    El permalink que utilizo en la web es el siguiente:

    http://virtualgamer.es/%category%/%postname%/%post_id%

    No tengo nada que termine con añadiendo la cateogría al final (como /category/entrevistas-cosplay).
    Las entradas que se ven afectadas por este «enlace» son absolutamente todas, independientemente de su categoría.
    No he hecho tampoco ningún cambio de categoría a ningún artículo.
    Probé a hacer que vuelva a rastrearlo de 0, y me están volviendo a aparecer todos, en cada artículo me pasa lo mismo.

    Cuando google revisa la web, dice que encuentra muchos enlaces con error 404, los marca como errores de rastreo. (En Google Search Console).

    Me dice la lista de los enlaces que dan error y su origen para que lo revise.
    Por ejemplo, me dice que encuentra un enlace a:
    http://virtualgamer.es/manga/se-acerca-sushi-splash-iii/category/entrevistas-cosplay
    Y efectivamente esta dirección no existe y da error 404.

    Y cuando le das a ver de donde ha sacado esa dirección, pone que el enlace está vinculado desde:
    http://virtualgamer.es/manga/se-acerca-sushi-splash-iii/8433

    Que efectivamente, es la dirección real. Pero, en el contenido de la dirección real, no existe un enlace que te envíe a la misma dirección + el «category/entrevistas-cosplay» que google detecta en todos los enlaces.

    Pero al parecer, cuando Google rastrea los enlaces de la web, detecta muchos enlaces que terminan con «category/entrevistas-cosplay» desde el propio artículo real, pero esos enlaces no existen, esos artículos no tienen nada que ver con la categoría ni mis enlaces terminan con la categoría, y cuando voy a la web y inspecciono el código para buscar el enlace y borrarlo ^-^» no encuentro el enlace con «category/entrevistas-cosplay» en ningún sitio…

    He probado a utilizar herramientas para ver los enlaces que que tiene la web, como esta:
    http://seomatica.com/encontrar-enlaces-rotos
    para escanear la entrada de ejemplo:

    http://virtualgamer.es/manga/se-acerca-sushi-splash-iii/8433
    Y me sale un montón de enlaces, pero no aparece el que Google dice que tengo terminado con «category/entrevistas-cosplay».

    Llevo varios años con la web, y tengo varias, pero nunca me ha pasado algo así hasta este mismo mes.

    • Esta respuesta fue modificada hace 4 años, 1 mes por blastofshadows.

    mira en la base de datos, para ello usar el plugin search and replace, a mi me sirvió para detectar enlaces inexistentes, tablas de pulgins que ya no tenía ni instalados, etc…
    mira por ahi´a ver…

    Iniciador del debate blastofshadows

    (@blastofshadows)

    He comprobado lo de la base de datos que me comentas :S y no he encontrado solución alguna. 🙁 No sé que puede pasar, aunque creo que tengo una pista. Llevo toda la mañana volviéndome loco con el problema.

    Lo estuvimos revisando varias personas y hemos visto que justamente, la fecha en la que empezaron a detectarse los errores es justo el día después de que el servicio técnico del tema que tengo en el wordpress (que es comprado) nos actualizara una parte por que no funcionaba correctamente, y justamente nos servía para que en la barra lateral derecha aparecieran las entrevistas cosplay que hacíamos (justo la categoría que ahora se añade a todos lados), pero es una de las cosas que desactivé antes de volver a poner a revisar los errores y siguen apareciendo.

    Estoy pensando en probar a cambiar el tema y esperar a ver si al día siguiente sigue detectando nuevos errores de este tipo.

    No se bien que hacer, pero voy a intentar eso, si funciona avisaré de ello. Si alguien conoce que podría ser, agradezco cualquier consejo. ¡Muchas gracias a todos por vuestras respuestas!

    Moderador Fernando Tellado

    (@fernandot)

    Hola,

    No he podido ver tu sitemap porque o no está creado o está oculto, así que por ahí no puedo ver lo que envías a Google.

    En cualquier caso, lo que te pasa no es ni medio normal, algo está inyectando o inyectó cosas adicionales a tus enlaces y el índice de Google los tiene.

    Posibles culpables:

    – Un hackeo: Yo haría limpia completa de plugins, tema, WP
    – Algún plugin: Pero como Google trata en re-indexar te quedarías días sin saber si aún te pasa.
    – El tema: Idem que antes.

    Resumiendo:

    1. Yo haría limpia completa por si es hackeo
    2. Enviaría el sitemap a la Search Console, y si ya está reindexaría el actual y a esperar a ver si desaparecen.

    Espero haberte ayudado en algo.

    Iniciador del debate blastofshadows

    (@blastofshadows)

    ¡Hola! No está el sitemap por que he probado a hacer limpieza de todo (incluyendo plugins, y eso hizo desaparecer el plugin que me hacía el sitemap, lo voy a volver a hacer ahora y enviarlo).

    ^-^» he cambiado plugins, tema y cosillas y voy a ver que tal funciona. Muchas gracias a todos por vuestras aportaciones 🙂

    Yo diría que tuviste algún enlace relativo, tipo <a href="category/entrevistas-cosplay">...</a>, que Google rastreó; esos enlaces se añaden al path de la URL actual y encaja bastante en el problema que tienes. Si ya has quitado esos enlaces, solo queda dar tiempo a Google para que vaya actualizando su índice; si tenías ese enlace por todos lados, puede tardar bastante tiempo.

    De todas formas, ten en cuenta que como esos enlaces no son enlaces válidos, el error 404 es el adecuado. Yo no le daría más importancia por lo momento, y en cambio le daría tiempo a Google.

Viendo 7 respuestas - de la 1 a la 7 (de un total de 7)
  • El debate ‘Google Search Console me avisa de enlaces que no he creado’ está cerrado a nuevas respuestas.