Soporte » Diseño – Temas y plantillas » gutenberg bloque + generatepress

Viendo 7 respuestas - de la 1 a la 7 (de un total de 7)
  • Moderador Jose Luis

    (@jose64)

    Hola

    En el inspector del navegador se ven varios errores por archivos no encontrados (404), todos relacionados con el tema. Prueba a desinstalarlo y volver a instalarlo (parece ser que faltan archivos), o desactivar autoptimize y cualquier plugin de caché que tengas instalado, haz las pruebas si todo va bien vuelve a activar.

    De todas formas, te dejo el código para eliminar el fallo, si ajustas el ancho al 99% se corrige, pero mejor que eso, oculta el desbordamiento:

    body {
        overflow-x: hidden;
    }

    Coméntanos con que opción lo resuelves y, por favor, recuerda cerrar el debate marcándolo como resuelto cuando así sea, de esta forma nos ayudas a mantener el foro al día.

    • Esta respuesta fue modificada hace 3 meses por Jose Luis. Razón: corregir código
    CP

    (@anaizar)

    Hola Jose Luis, muchas gracias, creo que ya me has ayudado pero tengo que volver con esta consulta y asegurarme que lo hice bien antes de cerrar. Mi nivel de WP es «usuario» y hay cosas que no sé hacer:

    – En el inspector del navegador se ven varios errores por archivos no encontrados (404), todos relacionados con el tema. 

    Vale, había un par de enlaces rotos y están corregidos, pero no entiendo porqué estarían «relacionados con el tema»

    – Prueba a desinstalarlo y volver a instalarlo (parece ser que faltan archivos)

    ¿tema padre? ¿tema child? No entiendo esto, nunca lo hice y me da pánico desinstalar el tema  por si pasa algo o pierdo personalizaciones

    – Desactivar autoptimize y cualquier plugin de caché que tengas instalado, haz las pruebas si todo va bien vuelve a activar

    Tampoco entiendo bien que tienen que ver estos plugin con el margen de un bloque..y no sé qué  pruebas  debo hacer

    – Si ajustas el ancho al 99% se corrige.
    ¿Donde? ¿Debo ir a «inspeccionar » y cambiarlo aquí?:

     .wp-block-cover-image .wp-block-cover__inner-container, .wp-block-cover .wp-block-cover__inner-container {
    width: calc(100% – 70px);
    z-index: 1; color: #f8f9f9;

    – pero mejor que eso, oculta el desbordamiento:  
    ¿con CSS? ¿a que te refieres? 

    – Te dejo el código para eliminar el fallo  
    Puse el código en en tema child – personalizar-css adicional ¡HA FUNCIONADO!

    Por favor dime si con el css es suficiente o crees que deno hacerlo de otra forma. Mil gracias por tu ayuda

    CP

    (@anaizar)

    No ha funcionado disculpa,
    Hubo un error con el código, si lo pongo en en tema child – personalizar-css adicional la barra de desplazammiento desaparece pero la página deja de se queda fija, no puedo desplazarme en ella.

    Moderador Jose Luis

    (@jose64)

    Hola

    Te contesto por partes, empezando por el final, que tiene un error:

    la barra de desplazammiento desaparece pero la página deja de se queda fija, no puedo desplazarme en ella

    overflow: hidden oculta el desbordamiento (en los dos ejes), por eso no se ven las barras de desplazamiento, si lo cambias por overflow-x: hidden; elimina el desbordamiento horizontal y mantiene el vertical, que es lo que necesitas, disculpa el error, ya lo corrijo en el código.

    Vale, había un par de enlaces rotos y están corregidos, pero no entiendo porqué estarían «relacionados con el tema»

    Estps son los archivos que ahora mismo general los errores 404, son archivos del tema:

    https://vozyemociones.com/wp-content/cache/autoptimize/js/autoptimize_2115056f25e192585ccd9f20fadf78c5.jscontent/cache/autoptimize/js/autoptimize_2115056f25e192585ccd9f20fadf78c5.js
    
    https://vozyemociones.com./generatepress-child/js/script.js
    
    https://vozyemociones.com./generatepress-child/style.css
    
    https://vozyemociones.com./generatepress/style.css

    ¿tema padre? ¿tema child? No entiendo esto, nunca lo hice y me da pánico desinstalar el tema por si pasa algo o pierdo personalizaciones

    Como te indiqué antes, en los dos temas indica que faltan archivos lo raro es que sin esos archivos no debería funcionar el tema.

    – Desactivar autoptimize y cualquier plugin de caché que tengas instalado, haz las pruebas si todo va bien vuelve a activar

    Tampoco entiendo bien que tienen que ver estos plugin con el margen de un bloque..y no sé qué pruebas debo hacer

    Autoptimize modifica los archivos para optimizarlos, algunas veces el tema no funciona correctamente con esas optimizaciones, es cuestión de probar, de hecho uno de los errores lo produce uno de los archivos generados por autoptimize (mal).

    Con respecto al plugin de cache es por descartar cosas, aparte de que si estás tratando de solucionar problemas lo último que necesitas es hacer una modificación y ver una página de cache en lugar de la última, es también por descartar.

    La prueba es simplemente ver si se soluciona el problema.

    – Si ajustas el ancho al 99% se corrige.
    ¿Donde? ¿Debo ir a «inspeccionar » y cambiarlo aquí?:

    No es buena idea, te descuadra los bloques, sería cambiar el ancho máximo del body.

    En resumen, la primera opción, ocultar el desbordamiento horizontal, te resuelve el aspecto gráfico, no se verá la barra de desplazamiento horizontal, pero el origen del problema sigue, lo de reinstalar el tema (padre e hijo) es para tratar de solucionar esos problemas, que pueden estar causados por el plugin autoptimize o el de cache, por eso es que te sugiero que primero borres la cache y desactives los dos plugins, verifiques si se solucionó, si es así ya sabes de dónde viene el problema.

    Para reinstalar el tema tienes que activar otro, borrar los originales y volver a instalarlos, o más fácil aún, borras la carpeta del tema desde el panel de archivos del servidor y vuelves a subirlo manualmente.

    Ya que has hecho cambios en el tema hijo, activa el padre y revisa si se soluciona el error, también puede ser que alguna modificación en el tema hijo sea la causa.

    Finalmente, lo que debe ser siempre el primer paso, haz una copia de seguridad completa, por si hay algún fallo tener forma de volver al estado anterior.

    Cualquier duda, consulta sin problema, para eso estamos. Coméntanos cómo siguen las pruebas.

    CP

    (@anaizar)

    @jose64
    Hola Jose Luis,

    Puse el código en personalizar – CSS adicional y parece corregido ¡gracias!

    Los archivos del tema que generan los errores 404 ¿donde los encuentras? Es decir, yo suelo usar “free broken link checker” como mucho, para ver enlaces rotos. Pero lo que tu me indicas no lo sabía, y tampoco sé como encontrarlo.
    Me preocupa que me digas que sin esos archivos no debería funcionar el tema.
    ¿Cómo /con qué herramienta encuentras estos errores?

    ¡Gracias por lo de autoptimize, lo tendré en cuenta!

    Hay alguien que me creo me puede ayudar y le comentaré lo de los plugin y lo de reinstalar el tema si es necesario, será una chorrada, pero es que me atrevo sin alguien que controle y me de un «paso por paso», mejor no tocar lo que no entiendo..

    Muchísimas gracias por tu tiempo, creo que entendiste muy bien mi nivel y me lo has explicado lo mejor posible 🙂

    Un saludo

    Moderador Jose Luis

    (@jose64)

    Con el inspector de elementos del navegador puedes ver los errores que genera la página, te dejo el enlaces con la información:

    Inspecciona y edita páginas y estilos

    Usar el Inspector de código para modificar un theme WordPress

    Inspector de Página

    Recuerda cerrar el debate marcándolo como resuelto.

    CP

    (@anaizar)

    ¡Gracias por tu ayuda @jose64!

Viendo 7 respuestas - de la 1 a la 7 (de un total de 7)
  • Debes estar registrado para responder a este debate.