• Resuelto asalba

    (@asalba)


    Hola, cuando intento crear una nueva entrada se me permite poner el título, hacer el post completo, dejarlo listo pero al poner publicar me arroja el siguiente mensaje:

    Ha fallado la publicación. Probablemente estás desconectado.

    Como resultado veo que se crea una entrada llamada Borrador automático, misma que por dentro está vacía. Intento editarla, pero no hay forma de resolver el problema.

    Ya verifiqué las posibles razones que se mencionan como lo del SSL por ejemplo. Tengo los plugins actualizados y probé a desactivarlos todos pero el resultado es siempre el mismo. No se me permite publicar el post y me sale ese mensaje: Ha fallado la publicación. Probablemente estás desconectado.

    ¿Me podrían ayudar a solucionarlo? Probaré cada sugerencia.

    La página con la que necesito ayuda: [accede para ver el enlace]

Viendo 10 respuestas - de la 1 a la 10 (de un total de 10)
  • Moderador almendron

    (@almendron)

    Lo primero de todo sería actualizar el tema. Si no estoy equivocado, va por la versión 1.0.7 y tú estás usando la 1.0.1

    Hola @asalba,

    Si desactivar todos los plugins no resuelve el problema trata de cambiar al tema por defecto de tu versión de WordPress por si fuese un problema relacionado con el tema activo.

    ¿Tienes actualizado el core de WordPress?
    ¿Qué versión de PHP estás usando? ¿Y de MySQL?
    ¿Hay algún aviso en el estado de salud de tu web?

    Todo eso puedes verlo en: Herramientas/Salud del sitio

    Saludos

    Iniciador del debate asalba

    (@asalba)

    Hola.

    @almendron

    Ya actualicé el tema y el pie de página desapareció en parte. Tengo otro problema, y es que elementor nunca carga para hacer las ediciones. Y además el problema de no poder publicar continúa con el mismo mensaje. Volveré al tema con la versión 1.0.1 pues el nuevo no soluciona nada y presenta más problemas que ventajas.

    @algato333

    Tengo todo actualizado el core de WordPress y todos los plugins.
    La versión de PHP es: PHP 7.4 (ea-php74)
    La versión de MySQL es : 5.5

    En cuanto a los avisos se me pide lo siguiente:
    Activar Google Analytics 4
    Deberías eliminar los plugins inactivos
    Tener un tema por defecto disponible
    Deberías utilizar una caché de objetos persistente
    Las actualizaciones automáticas están desactivadas

    • Esta respuesta fue modificada hace 1 año, 5 meses por asalba.

    Hola @asalba,

    Es normal que la web presente algunos fallos de diseño y estructura al cambiar de tema. Solo era para realizar una prueba y verificar que el problema no venía por ahí.

    ¿Cuentas con algún tipo de código personalizado en tu functions.php o en algún otro lugar de la web?

    Es probable que también estés recibiendo algún tipo de error por las versiones PHP y/o MySQL. La última versión estable de PHP es la 8.2 y la de MySQL la 8.0. Para poder actualizar esto debes hacerlo desde el servidor. De todos modos, si el error persiste tras haberlo actualizado te recomiendo volver a la versión 7.4 de PHP, ya que existen algunos plugins que aún no son compatibles con PHP 8.

    Otro problema que podrías tener es el uso de shortcodes mal configurados.

    Saludos

    Moderador almendron

    (@almendron)

    1) Es un error no actualizar el tema. Una vez soluciones el problema actual, deberías hacerlo.

    2) Prueba a activar uno de los temas que viene por defecto en WordPress (Por ejemplo: https://es.wordpress.org/themes/twentytwentytwo/ )

    Es la única forma de descartar que sea el tema el causante del fallo. Y si lo activas con todos los plugins desactivados, mucho mejor.

    Si el problema desapareciera, entonces deberás ir activando-comprobando los plugins y finalmente volver al tema original.

    Iniciador del debate asalba

    (@asalba)

    Hola, gracias por las sugerencias. Valoro el tiempo que toman para ayudarme.

    @algato333

    Sí, entiendo que hay cosas mínimas que necesiten volver a configurarse cuando el tema se actualiza. El adicional problema es que elementor tampoco me funciona. Y si algo se mueve ahora, no podré dejarlo en orden.

    No cuento con ningún código personalizado, sólo instalé el tema y los plugins requeridos por el mismo.

    Probé con las versiones de PHP 8.0 y 8.1, en ambos casos el resultado fue la pantalla blanca con este aviso: Ha habido un error crítico en esta web. Al regresarla a la 7.4 se corrige esto.

    Con respecto a MySQL estoy consultando con el proveedor del hosting para ver en donde puedo actualizar la versión. Uso cPanel pero de momento no he visto dónde cambiarlo.

    El único shortcode que recuerdo haber utilizado es para el plugin ContacForm. ¿Cómo podría comprobar esto?

    @almendron

    1) Sí, quiero actualizar el tema, el problema no sólo se trata de que me es imposible publicar los post. Tampoco me funciona elementor… Si algo se mueve ahora, no puedo editarlo. Crearé un nuevo hilo para eso, cuando encuentre la solución de esto.

    2) Cambié por un tema por defecto de wordpress y desactive de nuevo todos los plugins y el problema persiste.

    ¿Qué más podría probar?

    Iniciador del debate asalba

    (@asalba)

    @algato333

    La versión actual de MySQL es 10.6.11. No hay cambios respecto a la situación anterior.

    Moderador almendron

    (@almendron)

    Si con todos los plugins desactivados y usando el tema por defecto sigue el problema, entonces hay que ir pensando en que es el servidor.

    De todas formas, instala el plugin https://es.wordpress.org/plugins/no-gutenberg/ , no vaya a ser que sea un problema de Gutenberg.

    Y también deberías hacer lo siguiente:

    1) Provoca el error y toma nota de la hora exacta.
    2) Ponte en contacto con el soporte del hosting y que revisen el log de errores de servidor a dicha hora. A ver si allí aparece alguna pista.

    Iniciador del debate asalba

    (@asalba)

    @almendron Gracias, al bloquear Gutenberg se solucionó el problema. Marco el tema como resuelto.

    Moderador almendron

    (@almendron)

    De nada. Un saludo.

Viendo 10 respuestas - de la 1 a la 10 (de un total de 10)
  • El debate ‘Ha fallado la publicación. Probablemente estás desconectado.’ está cerrado a nuevas respuestas.