Soporte » Instalación – Actualizaciones » He instalado un wp y no me puedo loguear

  • Resuelto juans

    (@juans)


    He instalado un wp y no me puedo loguear

    Servidor: debian 8, apache, php 5, mysql5, postfix, phpmyadmin

    Versión: 4.8.1

    Método de instalación: bajar paquete -es, descomprimir locol, introdicr data de db en wp-config.php, subir por ftp y seguir los pasos.

    Estoy seguro de la contraseña, he repetido la instalación desde cero incluso crear db y pasa lo mismo, lo curioso es que en ese mismo server hasta el día de ayer, tenía otra instalación de wp muy grande y compleja migrada y tal vez debido a una mala migración algunos cosas no funcionaban pero me podía loguerar lo que me indica que no es cosa del server, pero eso me tiene muy despistado, me pongo en manos de la comunidad y agradezco por adelantado toda ayuda o tentativa de ayuda.

    Edito: me olvidaba de que no me dice contraseña errónea, simplemente vuelve a la misma pantalla

    • Este debate fue modificado hace 4 años, 3 meses por juans.

    La página con la que necesito ayuda: [accede para ver el enlace]

Viendo 9 respuestas - de la 1 a la 9 (de un total de 9)
  • Moderador LGrusin

    (@lgrusin)

    El wp-config.php no es necesario crearlo, ya lo crea WordPress durante la instalación con los datos que te va pidiendo. Lo digo porque cuando se edita se suelen cometer errores. Podrías probar instalar sin el wp-config.php a ver si hay alguna diferencia.

    Lo que no entiendo es que hace ese index.php en la URL.

    Por cierto, cambia PHP a la versión 7.

    Un saludo

    • Esta respuesta fue modificada hace 4 años, 3 meses por LGrusin.
    Iniciador del debate juans

    (@juans)

    La primera instalación la hice dejando que el instalador escriba el config.php y era exactamente lo mismo, ahora he comprobado ese archivo y no hay error es algo que hice decenas de veces (desde la época que era necesario hacerlo) y nunca rompí nada 🙂

    ¿es muy relevante lo de cambiar a php7?

    Lo del index php en las urls ahora lo veo, pero en la principal ni para loguerse, al ir a la entrada hola mundo o categorías si, tampoco ni idea, es una isntalacion nueva todo por defecto, no puedo ver la configuración de enlaces hasta que no me loguee 🙁

    El usuario lo reconoce porque me permite regenerar contraseña,

    Ahora veo que no hay un archivo .htaccess ¿wp tendría que haber generado uno? ¿el probema puede ser ese?

    Moderador LGrusin

    (@lgrusin)

    Lo suyo es que funcione con PHP7 en cualquier momento jubilan PHP5

    El .htaccess debe existir, comprueba que no esté oculto. ¿Seguro que es un servidor linux?

    Un saludo

    Iniciador del debate juans

    (@juans)

    Si, muy seguro de que es debian 8, exactamete debian 8 minimal 64 bit, era una de las opciones a instalar en un click en el vps que contarte :), el resto lo monté yo mismo… ahí puede estar el detalle 🙂 , pero… la instalación anterior migrada y actualizada a la ultima versión de wp si permitía loguear, el server parece funcionar, istaló el wp envia los correos etc… pero ahora que lo digo veo que además de faltar el .htaccess tampoco hay un archivo cgi-bin ,,, algo rompí 🙂

    Estoy viendo con filezilla forzando ver archivos ocultos y nada….

    Iniciador del debate juans

    (@juans)

    ahora php7 🙂
    archivo .hataccess por defecto compiado de sitio web de wordpess y carpeta cgi-bin con permisos 755 creada

    y todo igual

    Iniciador del debate juans

    (@juans)

    Luego de los detalles modificados acabo de hacer una instalación test en piesnegros.org/test y funciona perfectamente así que borrando todo para comenzar de limpio, gracias

    Iniciador del debate juans

    (@juans)

    Reabierto.

    No entiendo nada, la cosa funciona perfectamente si instalo fuera del directorio raiz en este caso piesnegros.org/piesnegros pero no si isntalo en el directorio raiz, ahora bien, una vez instalado en el directorio /piesnegros he subido los archivos al directorio raiz con el mismo config.php de /piesnegros entoces al ir a piesnegros.org soy direccionado a piesnegros.org/piesnegros y todo funciona perfectamente.

    Podría dejarlo así aunque es una chapuza y desconozco efectos colaterales, por ejemplo, pretendo convertirlo en una instalación múltiple con subdominios ¿funcionará?

    Y por otro lado ¿que es lo que está pasando?

    Iniciador del debate juans

    (@juans)

    Como pensaba, no puedo usar un multiuso en subdominios si el wp esta en un directorio no raiz 🙁

    así que a seguir buscando que pasa

    Iniciador del debate juans

    (@juans)

    Ahora si, arreglado, era una talba en la base de datos, en wo-options site url y home url no estaban correctas, envinaban a un directorio y no a la raiz, 🙂

Viendo 9 respuestas - de la 1 a la 9 (de un total de 9)
  • El debate ‘He instalado un wp y no me puedo loguear’ está cerrado a nuevas respuestas.