Soporte » Guías – Resolución de problemas » Imagenes no se ven en el blog

  • Hola a todos, estoy teniendo problema con las fotos en WordPress, el caso es que estoy redactando una entrada y subo una foto la coloco bien en la entrada pero cuando le doy a vista previa o publico la entrada la foto no aparece, he de decir que en el editor si que se ve bien la foto pero luego en realidad no aparece.
    Esto no me pasa con todas las fotos, alomejor una si se ve y otra no (en la misma entrada) En el apartado de Medios si que me aparecen y en el editor de entrada también las añado bién.

    Alguien me puede orientar para saber a que se debe esto?

    Saludos y muchas gracias!!

Viendo 10 respuestas - de la 16 a la 25 (de un total de 25)
  • Iniciador del debate sergio279

    (@sergio279)

    Hola a todos!!

    Mirar acabo de publicar una entrada y no sale la foto pero en cambio en el editor si que se muestra perfectamente:

    Los 72 nuevos emojis que traerá consigo Unicode 9.0 a Android este mismo verano

    La imagen está justo encima del parrafo que empieza:
    «Tampoco se han olvidado del gesto para esasfotos selfies y de nuestra querida paella….»
    En el editor está puesta pero en el post no se ve…

    A ver si me echáis una mano,

    Muchas gracias a todos!!!

    Hola les pido ayuda por favor. acabo de instalar un template pero cuando subo las imagenes no me deja verlas. estas subidas pero sale con un link roto.

    aqui les paso el link:

    http://neu2016.opera-plun.de/wp-content/uploads/2014/06/backgroundbild_1920x1080-1.png

    cuando llegan a la pagina dice: esta negado el acceso a la imagen.

    gracias por su ayuda

    Moderador LGrusin

    (@lgrusin)

    sergio279, algo has tocado en el código porque tienes
    .singular-post .entry-header img {
    display:none !important
    }
    que hace que no se vean las imágenes en algunos posts. Es decir, las imágenes destacadas las muestra, las otras no.

    Un saludo

    Iniciador del debate sergio279

    (@sergio279)

    LGrusin, ese código lo tengo para que no se muestren las imágenes destacadas al principio del post. He probado a eliminarlo y la imagen en cuestión sigue sin aparecer. Hay en post que si me aparecen las imágenes y en otros no, o me aparece una y otra no.
    A ver si podemos buscar una solución…

    Muchas gracias!

    Iniciador del debate sergio279

    (@sergio279)

    A ver la imagen está insertada en la entrada así:

    <a href="http://www.andro-life.com/wp-content/uploads/2016/06/wp-1466633785046.jpeg"><img class="alignnone size-full" title="wp-1466633785046" src="http://www.andro-life.com/wp-content/uploads/2016/06/wp-1466633785046.jpeg" alt="image" /></a>

    Pero no sale visible…No se por que

    Saludos y gracias

    Moderador almendron

    (@almendron)

    O no has quitado el código o no has vaciado la cache. Lo cierto es que LGrusin tiene razón. El código impide que se muestre la imagen.

    .singular-post .entry-header img {
        display: none !important;
    }

    Lo acabo de probar «en directo» con Firebug (una extensión de Firefox que permite ver y modificar en vivo la hoja de estilos) y la imagen aparece en cuanto deshabilitas la línea con la propiedad display.

    Por otra parte, creo que el tema tiene algún apartado para añadir estilos a la hoja de estilos y creo que lo has añadido allí porque aparece de la siguiente forma:
    <style id="custom-css-css">.singular-post .entry-header img{display:none !important}...
    Asegúrate que lo borras y que guardas los cambios si estoy en lo correcto.

    Iniciador del debate sergio279

    (@sergio279)

    Hola,

    He probado nuevamente, quitando ese código pero sigue sin aparecer, he limpiado caché etc
    Lo que hace ese código es ocultar la imagen destacada al principio del post, y si lo elimino me muestra la imagen destacada al principio de cada post.

    Pero lo que no se me muestra es otra imagen que tengo en el post, justo encima del parrafo que empieza:
    «Tampoco se han olvidado del gesto para esasfotos selfies y de nuestra querida paella….»

    Muchas gracias, seguimos intentandolo y buscando soluciones 🙂

    Moderador almendron

    (@almendron)

    Al final, me he bajado el tema y he hecho una prueba.
    Veamos: el tema tiene una opción por la cual coge una imagen de las que tenga la entrada y la coloca justo debajo del título del post. Si insertas varias, una la pondrá debajo del título y el resto aparecerá en el lugar donde las hayas colocado.
    Para cambiar este comportamiento:
    1.- Borra el código

    .singular-post .entry-header img {
        display: none !important;
    }

    2.- Ve a Apariencia > Personalizar. Busca «Miscellaneous Settings» y marca la casilla «Remove Featured Image from Single Post». Guarda.

    Iniciador del debate sergio279

    (@sergio279)

    almendron, parece que con lo que me has dicho se ha solucionado. He marcado esa opción y eliminado el código y ya me aparece la imagen.
    Eso era el problema!

    Muchas gracias 🙂

    Moderador almendron

    (@almendron)

    De nada. En cualquier caso, no era realmente un problema sino una opción del tema.
    Un saludo.
    PD. Por favor, marca el tema como resuelto.

Viendo 10 respuestas - de la 16 a la 25 (de un total de 25)
  • El debate ‘Imagenes no se ven en el blog’ está cerrado a nuevas respuestas.