Soporte » Instalación – Actualizaciones » Imposible cambiar el campo idioma en WordPress y Divi

  • Buenas chicos, a ver si os a pasado alguna vez.
    Tengo un ecommerce, de nueva instalación. WordPress esta en castellano pero la opción de idioma en ajustes generales no hay forma humana de ponerla en español, tiene seleccionado ingles de eeuu.
    Al instalar Woocommerce sale en ingles, tanto el front como el back.
    -Revise los ficheros de idioma y están todos los ficheros de traducción.
    -Puse el comando WPLang en wpconfig pese a no ser necesario ya.
    -Desactive todos los plugins
    -Cambie el tema que tengo activo que es un hijo de Divi.
    -Seleccione el idioma de todos los usuarios a español (si ya no se que hacer)

    A ver si alguien me ilumina.

    • Este debate fue modificado hace 11 meses, 2 semanas por  Fernando Tellado. Razón: Modificado el título

    La página con la que necesito ayuda: [accede para ver el enlace]

Viendo 6 respuestas - 1 de 6 (de 6 total)
  • Preguntas… 

    ¿Tienes instalado WPML? Lo digo por esto: https://wpml.org/forums/topic/cant-change-site-language/

    – Click on the WPML > Support > Troubleshooting – At the end of the page, look for «Reset» – Select the «I am about to reset all translation and language data.» option – Click on the «Reset and deactivate WPML» button. – After just reactivated the WPML ( Plugins> Installed Plugins ) – Configure the WPML again, this time selecting the correct language.

    Otras posibilidades:

    Sube los archivos po y mo del español directamente por cPanel o FTP a la carpeta /languages de /wp-content, aunque estén subidos (pueden estar corruptos o con permisos incorrectos, al subirlos se arreglan los permisos normalmente, o simplemente ya son buenos). Los tienes aquí: https://downloads.wordpress.org/translation/core/4.9.8/es_ES.zip

    Revisa los permisos de carpetas y archivos de la instalación, a saber:

    Carpetas 750
    Archivos 650

    Si falla alguno lo cambias y pruebas.

    WooCommerce deberá traducirse cuando ya tengas WP en español. Y no hace falta el wplang en el wp-config.php hace muchas versiones, puedes quitar ese DEFINE sin problemas, el problema será otro.

    La respuesta suele ser esta:
    https://wordpress.stackexchange.com/questions/217880/cant-change-language-only-english-united-states

    «To get languages in dropdown list (Settings > General Settings > Site Language) you need install translate files to wp-content/languages directory.»

    En castellano:
    «para que salgan los idiomas en el desplegable deben existir los archivos en la carpeta wp-content/languages»

    En las últimas versiones, lo que hace falta es tener esa carpeta creada, y con los permisos correctos, la instalación se hace automáticamente si es el caso.

    Si la carpeta existe y los permisos son correctos, yo me descargaría el WordPress de nuevo de la página en español y sobrescribiría todos los archivos como dice @fernandot.

    Otra opción es añadir esta línea al wp-config:

    define('FS_METHOD', 'direct');
    Que a veces soluciona problemas de permisos.

    • Esta respuesta fue modificada hace 11 meses, 3 semanas por  darkpollo.
    • Esta respuesta fue modificada hace 11 meses, 3 semanas por  darkpollo.

    Más o menos lo que comentaba yo antes

    Y la constante FS_METHOD simplemente obvia permisos, no soluciona el problema, así que sigo insistiendo en revisar los permisos «realmente» 🙂

    Tienes toda la razón @fernandot pero me pareció bien aportarlo por si acaso.

    Edito añadiendo un enlace que explica el FS_METHOD mejor:

    https://wordpress.stackexchange.com/questions/189554/what-security-concerns-should-i-have-when-setting-fs-method-to-direct-in-wp-co

    • Esta respuesta fue modificada hace 11 meses, 3 semanas por  darkpollo.

    Muchas gracias por los comentarios compañeros, pero no hubo solución. Creo que tocará reinstalar el WordPress. Un caso sin resolver para el cajón.

    Buenas chicos, resuelta la incógnita. Os comente que trabajaba con un hijo de Divi. Bien pues en las opciones del tema tenia activa la pestaña «Desactivar Traducciones» y era eso lo que no dejaba a WordPress ponerse en español.

Viendo 6 respuestas - 1 de 6 (de 6 total)
  • El debate ‘Imposible cambiar el campo idioma en WordPress y Divi’ está cerrado a nuevas respuestas.