Soporte » Plugins y Hacks » Incompatibilidad Elementor con Zerif Lite

  • Resuelto oscarxavier73

    (@oscarxavier73)



    Hola a tod@s

    Acabo de instalar Elementor Page Builder. Uso el tema Zerif lite. Al crear una nueva página y abrir Elementor me sale este mensaje: “Lo siento, el área de contenido no se encontró en su página. debe llamar a la “the_content” en la plantilla actual para que Elementor funcioneº ene sta página.

    Buscando información de como subsanar he encontrado que debo escribir este código (<?php the_content(); ?>) en el archivo page.php situado en Aparaiencia-Editor.

    ¿Dónde debo colocar este código para que funcione y no me cargue la web. ¿hay alguna otra solución? Pués también he leído que pruebe a desactivar los demás plugins para descubrir la incompatibilidad.

    No tengo idea de lenguajes ni códigos, así que acepto sugerencias de page builders que sean intuitivos, fáciles y que no pesen demasiado. Buscando comparativas parece ser que page builder es lo más avanzado y recomendable.

    Gracias
    Óscar

    La página con la que necesito ayuda: [accede para ver el enlace]

Viendo 4 respuestas - 1 de 4 (de 4 total)
  • Moderador Fernando Tellado

    (@fernandot)

    Pues según la propia página de los autores del plugin Zerif Lite es uno de los temas donde dicen que mejor funciona:

    https://docs.elementor.com/article/78-themes

    De todos modos en la misma página de documentación te indica cómo añadir compatibilidad con Elementor: https://docs.elementor.com/article/56-content-area-not-found

    Pero revisa la lista de posibles (otros) problemas que pueden estar provocando el error, como cachés y demás (abajo del todo del enlace que te he pasado.

    Moderador Fernando Tellado

    (@fernandot)

    Otra cosa que se me ocurre es que Zerif use el condicional get_the_content() para comprobar si hay contenido, con lo que tu nueva página, al no tener aún contenido, puede generar ese error en Elementor.

    El truco sería editar la página y en el editor HTML añadir &nbsp; que es un espacio en blanco y guardar. A ver si ahora ya si funciona.

    Muchas gracias Fernando.

    Creo que he descubierto el error. Tal como dice en el documento de Elementor: A veces los conflictos pueden imposibilitar la edición con Elementor en las páginas de borrador

    Había clonado una página ya publicada en formato borrador para modificar el contenido desde Elementor. Al crear una página nueva se me ha abierto Elementor sin problema.

    Entonces, la pregunta que me viene es ¿si sólo se puede trabajar con Elementor con páginas de nueva creación? He visto que si se abre una página publicada con Elementor no aparece el contenido.

    Doy por resuelto el problema.

    Muchas gracias

Viendo 4 respuestas - 1 de 4 (de 4 total)
  • El debate ‘Incompatibilidad Elementor con Zerif Lite’ está cerrado a nuevas respuestas.