Soporte » Plugins y Hacks » WooCommerce » INEXPLICABLE. Se muestran productos unas veces sin impuestos y otras con ellos

  • Saludos a todos. Ojalá puedan ayudarme.

    Tengo un problema. Estoy cambiando los precios para introducirlos sin impuestos, y en los artículos donde los he cambiado, me he dado cuenta de que unas veces la tienda los muestra con impuesto y otras veces sin impuesto. Incluso hay veces que dos productos con el mismo precio y la misma configuración, los muestra con diferentes precios, uno con impuesto y otro sin impuesto.

    En el carrito de la compra muestra bien todo, los precios y el desglose de los impuestos.

    Si voy a un producto que muestra mal el precio, hago click en «edición rápida», no cambio nada, y doy a actualizar, me muestra bien el precio con impuestos. Si voy a otro producto que lo muestre mal y hago lo mismo, entonces ya me lo muestra bien, pero el anterior lo vuelve a mostrar mal, sin impuestos.

    En este vídeo se puede ver cómo desde el administrador, solo con actualizar un producto (sin cambiar nada) cambia el precio. Si se hace lo mismo con un segundo producto también lo arregla, pero el primero vuelve a verse mal:
    VER EL ERROR

    Cuando la tienda muestra el precio incorrectamente, es decir, sin impuesto, en el administrador de Woocommerce, también aparece mal el precio.

    Tengo integración con http://www.printful.com y pensaba que podía ser problema del API, pero los errores se producen sin hacer cambios en Printful. Tan pronto aparece el producto 1 mal y el producto 2 bien, como al revés, aparece bien el producto 1 y aparece mal el producto 2.

    Es inexplicable. Mi plantilla es Flatsome.

    Muchas gracias por vuestra ayuda.

    La página con la que necesito ayuda: [accede para ver el enlace]

Viendo 1 respuesta (de un total de 1)
  • kallookoo

    (@kallookoo)

    Hola @frankmagan

    Prueba lo siguiente:
    – Desactiva la integracion con printful.
    Prueba cambiando los precios y si funciona el problema esta con el printful.
    – Desactiva cualquier plugin de cache o cache que tengas en el servidor.
    Prueba cambiando los precios y si funciona el cache es muy agresivo y deberas repasar su configuracion o si es del lado del servidor contactar con el proveedor para mirar como solucionarlo.
    – Comprueba el estado del WooCommerce por si hubiese algun error.

Viendo 1 respuesta (de un total de 1)
  • Debes estar registrado para responder a este debate.