Soporte » Plugins y Hacks » WooCommerce » Iva Woocommerce no aparece en otros navegadores

  • Resuelto mary461990

    (@mary461990)


    Hola, he introducido los productos sin IVA y he puesto que se calcule el IVA y este aparezaca en el precio de los productos, pero resulta que en chrome si que me aparecen bien pero en explorer no me aparece el Iva hasta que no le doy a finalizar compra.
    ¿alguien sabe por que me puede estar pasando esto? Gracias

    • Este debate fue modificado hace 1 año, 2 meses por  erchache2000.
Viendo 8 respuestas - 16 de 23 (de 23 total)
  • Hola @chusman, me has dado la clave para solucionar el problema.
    Sólo vendo en España y al comentar que hasta que no se ponía la dirección de envio no se calculaba el precio correcto con IVA, he cambiado los ajustes de los impuestos y ahora me funciona correctamente.
    En la opcion de “Calcular impuesto basado en”, lo tenía configurado en “Direccion de envío del cliente” y lo he cambiado a “Localizacion del negocio”.
    Ahora ya ignora la dirección de envío y me muestra siempre los precios con IVA tal y como le marco.

    Gracias por la pista!!

    Hola tetevic, eso también lo probé, pero mi cliente quiere que según el país de la persona que compre, se cobre el IVA o no, y de esa manera se cobraba el IVA a todo el mundo.

    Al final estuve desactivando y activando plugins y creo que era el de caché el que daba problemas (WP Fastest Cache), ahora parece que todo funciona bien.

    Hola @tetevic y @chusman, a mi me pasaba exactamente lo mismo: veía los precios con IVA sólo cuando estaba logada como usuaria.
    Sin logarme o en modo incógnito, todo lo veía sin IVA.
    Como yo sí hago envíos a Canarias o Ceuta, imagino que @tetevic no los hace, por lo tanto, sí necesito que a veces cargue el IVA y a veces no, dependiendo del destino del cliente.
    Por eso, para mí no es solución la opción de “Calcular impuesto basado en”, “Localización del negocio”.
    El cambio que yo he hecho es en Woocommerce-Ajustes-GENERAL-UBICACIÓN DEL CLIENTE POR DEFECTO: DIRECCIÓN PRINCIPAL DEL NEGOCIO.
    De esta manera, como el negocio está en Madrid, una zona donde el IVA se aplica, por defecto, siempre se muestran los productos con el IVA.
    Luego, cuando el cliente especifica que el pedido va a Canarias es cuando el IVA se quita.
    Espero que os funcione.
    Un saludo!

    Buena solución @mariaesf.
    Gracias por la idea

    Parece que estableciendo la aplicación del IVA por dirección del negocio, se ha solucionado esta incidencia tan rara que me ocurría sólo con un SO específico.

    Muchas gracias a tod@s!

    Muchas gracias @mariaesf, me has ayudado a encontrar la solución al problema!

    Me alegro mucho!! 🙂

    Moderador Fernando Tellado

    (@fernandot)

    Justo esto mismo me ha pasado a mi esta mañana, y es la cosa más tonta del mundo pero me tenía mareado de tanto mirar los ajustes de WooCommerce a ver cual tenía mal 😀

Viendo 8 respuestas - 16 de 23 (de 23 total)
  • Debes estar registrado para responder a este tema.