Soporte » Multisitio » Las urls de los subdominios no son TLS

  • Hola,

    Estoy con un multisite en local usando subdominios y me he fijado que cuando creo uno las urls en el administrador son http://... en vez de https://... y desde mi logica no deberian ser https ?

    Aclaro que desde la instalacion inicial ya usaba el https

    Ya tengo un redireccion inicial en la configuracion del Apache por si añado una direccion http://loquesea me mande a https://loquesea y no me habia fijado hasta hoy.

    Saludos

Viendo 4 respuestas - de la 1 a la 4 (de un total de 4)
  • Hola Sergio!!!

    A ver si puede darte un poco de luz en el asunto o entre los dos llegamos a la solución 😉

    No entiendo bien bien cual es tu duda. ¿Es que en el gestor pones http pero te redirige al https? ¿Necesitas que algunos sitios del multisite sean http y otros https?

    A ver si me especificas un poco más y podemos resolverte la duda.
    Salut!

    Hola @adriandegrafreak

    Te pongo un poco en situacion.
    Ahora mismo trabajo con un lamp en local, instalado bajo mi ubuntu, con ciertas personalizaciones referentes al Apache,etc… Y una de ellas es que todas las webs que creo se genera su propio certificado wildcard proporciando por mkcert asi que en la configuracion del Apache tengo un rewrite de http a https global, por si entro usando http, ya que todas las webs la configuracion se define en el puerto 443. Puedes ver todo el codigo de mi lamp en mi github repo lamp.

    Lo que comento (no me habia fijado antes) es que siendo un multisite TLS porque en Network – All Sites – Visit el link que aparece no es TLS y si entro para editar la site la option Site Address (URL) aparece como http y desde mi logica deberian ser https.

    Ahora mismo acabo de pensar que puede ser que el WordPress no lo especifica para evitar un error si el certificado de la web no es wildcards o no existiese, vamos. Creo que yo mismo me he aclarado la duda, jaja

    Saludos

    Adrián de Grafreak

    (@adriandegrafreak)

    Hola @kallookoo

    ¿Pudiste resolverlo? ¿Al final te la resolviste tú solo?

    Ya me dices si te puedo ayudar algo más o la cerramos 😉
    Salut!

    kallookoo

    (@kallookoo)

    Hola @adriandegrafreak

    No lo solucione, puede que sea alguna mala o falta de configuracion ya que revise el codigo del WordPress al crear una site y usa is_ssl() para definir el protocolo.
    Como te comente al ser en local y tener una redireccion global no me preocupa, ahora mismo. Estoy liado con otras cosas.

    Lo mantendre abierto, por el momento, por si alguien lo ve y que pueda dar su opinion.

    Saludos

Viendo 4 respuestas - de la 1 a la 4 (de un total de 4)
  • Debes estar registrado para responder a este debate.