Soporte » Guías – Resolución de problemas » Links que redireccionan a la página de inicio

  • Resuelto EseDeTe

    (@esedete)


    Hola a tod@s,
    Tengo un problema que me está dando dolor de cabeza…

    Tengo un Blog creado sobre la versión 2.7.1 y modificando el theme por defecto.

    El Blog (y todos sus plugins) llevan desde 2009 funcionando sin problemas y ni he modificado absolutamente nada ni en el código ni he insertado artículos o páginas últimamente.

    A partir de cosa de hará unas tres o cuatro semanas, todos los enlaces a las páginas, artículos, etc. han dejado de funcionar. Cuando hago click en ellos, en la barra de dirección me aparece la dirección correcta (ej.: http://www.misitio.es/?p=303 o http://www.misitio.es/?page_id=312&preview=true) pero el navegador me muestra siempre y solo la página principal del Blog.

    La cosa curiosa es que incluso si estoy escribiendo una nueva entrada y le doy al botón anteprima, me pasa lo mismo: me muestra la página principal.

    Por favor, necesito ayuda urgente ya que no he conseguido encontrar nada al respecto y me gustaría arreglarlo cuanto antes. Podría ser que me hayan hackeado el sitio?

    Saludos y gracias de antemano!

Viendo 3 respuestas - de la 1 a la 3 (de un total de 3)
  • Iniciador del debate EseDeTe

    (@esedete)

    Bueno… problema resuelto en parte!
    Parece ser que tenía un plugin instalado y que al desactivarlo, deja de dar el problema de la redirección de los links a la página principal.

    El plugin en cuestión se llama Photopress y es bastante antiguo. Ya no tiene soporte por parte de su desarrollador, así que tendré que buscar una alternativa viable.

    De todos modos queda pendiente una duda: PORQUE si ha funcionado bien hasta ahora, de repente y sin haber realizado ningún cambio en la configuración, ya no funciona como antes… es un misterio!

    Por cierto: he actualizado el wordpress a la versión actual (fecha de este post) y tampoco he resuelto nada.

    Moderador erchache2000

    (@erchache2000)

    Puede ser que el hosting haya actualizado el servidor web o el php y por eso lo que antes funcionaba, ahora no lo haga.

    Comprueba que el archivo .htaccess es correcto y que no redireccionas nada desde el panel de control de tu hosting.

    Si todo esta ok y no solucionas nada habla con el soporte de tu hosting.

    Ayudenme!!!
    Tengo 3 días trantando de pedir ayuda y nadie me contesta, este es mi problema:
    Fatal error: Call to undefined function is_multisite() in /home/a1523559/public_html/wp-includes/default-constants.php on line 20
    y no se que hacer… tengo la útlima version de wordpress y no sucede nada!!! porfavor respondan, gracias

Viendo 3 respuestas - de la 1 a la 3 (de un total de 3)
  • El debate ‘Links que redireccionan a la página de inicio’ está cerrado a nuevas respuestas.