Soporte » Multisitio » login multisite

Viendo 9 respuestas - 1 de 9 (de 9 total)
  • Hola

    La opción más sencilla es que crees un usuario nuevo. Te dejo un enlace a una publicación de @cybmeta donde explica Cómo crear un administrador en WordPress desde MySQL y, tanto o más importante, como darle privilegios de Super Admin.

    Recuerda cerrar el debate marcándolo como resuelto cuando la consulta esté solucionada, así nos ayudas a mantener el foro al día

    Hola como te dije wp_user y wp_usermeta no esta en mi base de datos ni decir que depronto me lo halla escondido un plugin de seguridad pues porque antes de exportar lo desactive hice la comparacion de mi copia funcional en localhost de mi base de datos y la de mi hosting, todo esta igual y no quiere funcionar. no se depronto que este pasando y obviamente, cambie los prefijos por lo que me deberia aparecer: (prefijo+user)&(prefijo+usermeta)No estan.

    Hola

    Si revisas tu pregunta verás que pones que te falta el user en la base de datos (yo entendí el usuario), no las tablas wp_user y wp_usermeta. Es posible que tengas la base de datos corrupta.

    Primeramente prueba revisando y reparando la base de datos desde MySQL Bases de datos. Si no solucionas nada (siguen sin aparecer) tendrás que crearlas nuevamente.

    Para crear las tablas nuevas prueba lo siguiente:

    Edita el archivp wp-config.php, cambia el prefijo de la tablas reemplazando el que tengas actualmente por uno nuevo

    /**
     * WordPress Database Table prefix.
     *
     * You can have multiple installations in one database if you give each
     * a unique prefix. Only numbers, letters, and underscores please!
     */
    $table_prefix = 'wp_';

    Una vez hecho esto se activará la instalación de WordPress (te pedirá el idioma para una nueva instalación).

    Completa la instalación con tu nuevo usuario y contraseña.

    Ahora verás desde phpMyAdmin que en tu base de datos tendrás las tablas viejas y las nuevas, renombra las tablas nuevas que te faltan en la instalacion (user y usermeta) con el prefijo de la instalación inicial.

    Modifica nuevamente el archivo wp-config.php volviendo a poner el prefijo de las tablas inicial.

    Ya tienes las tablas que te faltaban con un usuario administrador creado, ahora completas el proceso como te explica la publicación anterior para darle privilegios al usuario como Super Admin y deberías tenerlo resuelto.

    Saludos y sigue comentando el proceso.

    Hola de nuevo, hice la modificacion que me dijistes del prefijo en wp-config las tablas no tuvieron ningun cambio siguieron con el mismo prefijo y la pagina me direcciona a un localhost el cual me sirve para mi pero para los demas usuarios les aparece error.

    Una observación que añado es que la migracion de un multisite de localhost es muy diferente, pude modificar el htacces y realizar exitosamente la conexion de la base de datos por wpconfig.Nosotros no podemos pasar por alto estos archivos mencionados anteriormente ya que hay se encuentra configurado el codigo del multisite pero no me explico el porque no me reconoce como superadministrador. revise la base de datos y si hay registros de mi correo electronico pero esas tablas (prefijo+user)&(prefijo+usermeta) no se encuentran en mi base de datos la solucion que se me ocurre es crear las tablas con el prefijo creado y ponerle los terminos a ver si asi me funciona.

    ¡Si tienes otra idea seria de gran ayuda amigo!

    • Esta respuesta fue modificada hace 2 meses, 1 semana por  zuckmayer91.
    • Esta respuesta fue modificada hace 2 meses, 1 semana por  zuckmayer91.
    jose64

    (@jose64)

    Hola

    Si tienes todo funcionando correctamente en local entonces el problema fue al migrar el sitio. Se pudieron corromper los datos o algo en la migración no fue hecho correctamente.

    ¿En la base de datos local tienes las tablas que te faltan (user y usermeta)?

    zuckmayer91

    (@zuckmayer91)

    No tampoco y funciona de maravilla.

    zuckmayer91

    (@zuckmayer91)

    yo estoy haciendo la migración así del wordpres multisite.

    Guardo en archivo zip los ficheros de la web que se encuentran en htdocs.
    exporto la base de datos con un plugin que se llama migrate db que lo que hace es que clona la base de datos de todos mis sitios y cambia las url en mi base de datos en donde aparece el localhost/»nombreproyecto». Digo que lo clona porque el plugin aparece en ajustes de donde se manejas toda la red, he hize la comparación y las tablas son identicas a las de mi php admin de mi localhost revise manualmente todos los enlaces y estan bien.

    pero en el momento de entrar al backend no me reconoce, mi correo ni mi usurio. Hoy hare la prueba de la que te comente anteriormente si funciona o se daña todo la web.

    zuckmayer91

    (@zuckmayer91)

    No tampoco funciono de esta otra manera

Viendo 9 respuestas - 1 de 9 (de 9 total)
  • Debes estar registrado para responder a este tema.