Soporte » Instalación – Actualizaciones » WordPress 3.9 instalado en local con xampp en Mac no permite hacer nada

  • Hola, uso un Mac OS X 10.9.2 y he realizado correctamente la instalación en local de WordPress 3.9 con XAMP. El problema viene cuando quiero hacer algo en WordPress, como subir una foto, borrar una plantilla o instalar un pluing, se me abre una pantalla que dice lo siguiente:

    [[ DATOS DE CONEXIÓN
    Para realizar la operación que has solicitado WordPress necesita tener acceso a tu servidor web. Por favor, introduce tus datos de acceso FTP para proceder. Si no recuerdas tus datos de acceso deberías contactar con tu proveedor de alojamiento.

    Servidor: localhost
    Usuario FTP: root (también he probado con: root@localhost)
    Contraseña FTP (ninguna porque este apartado se dejó en blanco)
    Tipo de conexión FTP ó FTPS (SSL) ]]

    Al darle a ejecutar sale este mensaje:

    [[«Error: Se ha producido un error en la conexión con el servidor. Por favor, verifica que la configuración es correcta.»]]

    Lo he repasado todo y al final desinstalado y vuelto a hacer todo de nuevo con el mismo resultado.
    Empiezo a creer que es un problema de la versión 3.9 WordPress. ¿Alguien sabe como solucionarlo?

    Muchas gracias

Viendo 7 respuestas - de la 1 a la 7 (de un total de 7)
  • No es problema de WordPress, yo lo tengo en local funcionando perfectamente.

    Es la configuración que tienes con XAMPP y los permisos de escritura locales. Si wordpress te carga todo perfecto, pero te da problemas al querer actualizar o subir un archivo, sin duda son los permisos.

    Si XAMPP no tiene ningún ajuste apea arreglar permisos, haz lo siguiente desde al terminal.

    $ sudo chown -R _www nombre-de-tu-carpeta-de-wordpress
    $ sudo chmod -R g+w nombre-de-tu-carpeta-de-wordpress

    Con eso le das los permisos necesarios y todo te funciona.

    Gracias Peter por tu respuesta, parece prometedor, y he estado intentándolo, pero no sé muy bien donde puedo cambiar los permisos de escritura locales, ni en xammp, ni en la terminal. Perdona mi ignorancia, si puedes guiarme y ayudarme un poco más te lo agradecería mucho 🙂

    En Aplicaciones > Utilidades de tu Mac, tienes una App que se llama terminal, ábrela.
    Escribe en ella «cd» un espacio y arrastra la carpeta que contiene la carpeta de tu wordpress, no la carpeta que tiene los archivos de wordpress, la que tiene la carpeta entera.

    Elemplo:

    cd estaeslacarpeta

    Y le das enter.

    Ahora escribe ls y le das enter. (Eso es ele y ese.)

    Verás en la terminal un listado y en el tiene que estar la carpeta entera donde tienes todos los archivos de wordpress metidos. Digamos que esa carpeta se llama «miweb»

    Ahora pones en la terminal «sudo chown -R _www miweb» sin las comillas y después de eso «sudo chmod -R g+w miweb» tambien sin comillas.

    Te va a pedir tu contraseña y tienes que poner la de tu Mac, cuando la escribas no se va a ver nada, pero si se escribe.

    Con eso te queda.

    Saludos.

    Muchas gracias por tu ayuda Peter, así lo haré, pero antes una duda. Cuando acabe de trabajar en local, ¿los permisos que he autorizado supondrían algún problema al subir la web a un servidor?

    Ninguno 🙂

    Hola:
    A mi me pasa lo mismo. Estoy intentando hacer lo que me pones en la consola pero me pone esto:
    Servidorinaki:wordpress inaki$ sudo chown -R_www wordpress
    chown: illegal option — _
    usage: chown [-fhv] [-R [-H | -L | -P]] owner[:group] file …
    chown [-fhv] [-R [-H | -L | -P]] :group file …

    Te paso la secuencia completa por si me he equivocado de carpeta :
    cd /Applications/XAMPP/xamppfiles/htdocs/xampp/wordpress
    Servidorinaki:wordpress inaki$ Is
    -bash: Is: command not found
    Servidorinaki:wordpress inaki$ ls
    descargar wp wp-blog-header.php wp-load.php
    index.php wp-comments-post.php wp-login.php
    licencia.txt wp-config.php wp-mail.php
    license.txt wp-content wp-settings.php
    readme.html wp-cron.php wp-signup.php
    wp-activate.php wp-includes wp-trackback.php
    wp-admin wp-links-opml.php xmlrpc.php

    He instalado el Xampp en mi ordenador y luego el wordpress.
    Cuando intento subir una foto intenta crear un directorio y me da un error de permisos.
    me podéis ayudar por favor?
    muchas gracias

    Perdón:
    he intentado también ejecutarlo en la carpeta que contien el wordpress y me sale esto:
    Servidorinaki:xampp inaki$ ls
    AnkeCalligraph.TTF guestbook-zh.pl security.php
    biorhythm.php guestbook.dat showcode.php
    cds-fpdf.php head.php softwarelist.inc
    cds.php iart.php splash-logo.php
    cgi.cgi img splash-swf.php
    charset.php index.php splash.php
    components.php lang sqlite
    contrib lang.php ssi.inc
    guestbook-de.pl lang.tmp ssi.shtml
    guestbook-en.pl langsettings.php start.php
    guestbook-es.pl manuals.php status.php
    guestbook-fr.pl mysql.php test
    guestbook-it.pl navi.php test.php
    guestbook-nl.pl perl.pl webalizer.php
    guestbook-no.pl phonebook.php wordpress
    guestbook-pl.pl php.php xampp.css
    guestbook-pt_br.pl phpinfo.php xampp.js
    Servidorinaki:xampp inaki$ sudo chown -R_www wordpress
    Password:
    chown: illegal option — _
    usage: chown [-fhv] [-R [-H | -L | -P]] owner[:group] file …
    chown [-fhv] [-R [-H | -L | -P]] :group file …
    Servidorinaki:xampp inaki$ sudo chown -R_www xampp
    chown: illegal option — _
    usage: chown [-fhv] [-R [-H | -L | -P]] owner[:group] file …
    chown [-fhv] [-R [-H | -L | -P]] :group file …

    No sé cómo dar permisos para poder trabajar en local con wordpress…

    muchas gracias
    saludos

Viendo 7 respuestas - de la 1 a la 7 (de un total de 7)
  • El debate ‘WordPress 3.9 instalado en local con xampp en Mac no permite hacer nada’ está cerrado a nuevas respuestas.