Soporte » Diseño – Temas y plantillas » Me desaparece el menú

  • Resuelto paulamartinez

    (@paulamartinez)


    Buenos días,

    llevo semanas intentando crear dos menús, cada uno en un idioma diferente. Al principio me aparecía correctamente el menú en castellano y en inglés no me aparecían los botones de inicio-contacto… Es decir, el top menu del segundo menú esta completamente vacío donde deberían aparecer las páginas que he seleccionado.
    Para solucionarlo he decidido empezar desde cero borrando los plugins de traducción y los dos menús.
    Al crear el primero, he enlazado las páginas correspondientes y he seleccionado top menu en ajustes de menú, pero al visitar el sitio aparece totalmente vacío. No hay botón de Inicio ni ningún otro, como me ocurría con el segundo menú.

    Estoy trabajando desde una localhost.
    Tema hijo de Savona.

Viendo 7 respuestas - de la 1 a la 7 (de un total de 7)
  • Moderador LGrusin

    (@lgrusin)

    El tema tiene dos ubicaciones para menús, Top y Principal. Algo debes estar haciendo mal porque a mi me funcionan perfectamente los dos menús.

    En el menú Apariencia – Personalizar – Top bar, tienes una opción para desactivar el menú superior, comprueba que no sea eso.

    • Esta respuesta fue modificada hace 2 años, 2 meses por LGrusin.
    Iniciador del debate paulamartinez

    (@paulamartinez)

    Acabo de comprobarlo y está seleccionado.
    En apariencia me aparecen las páginas seleccionadas pero se sigue sin ver nada. Al visitar el sitio si selecciono el lugar donde me deberían aparecer los elementos -arrastrando el ratón por esa zona-, me aparecen unas líneas verticales. Si selecciono inspeccionar elemento > editar como html, me aparecen los iconos de las páginas con el código correspondiente, pero visualmente no se ve nada de nada.

    Moderador LGrusin

    (@lgrusin)

    ¿Qué tema es exactamente?

    Comprueba que el color del fondo del menú sea diferente al color de las letras del menú.

    Si has hecho modificaciones en el tema lo mejor es que pruebes una instalación limpia original.

    Iniciador del debate paulamartinez

    (@paulamartinez)

    He probado a poner el tema original y tengo el mismo problema. También he intentado averiguar si es problema de la top bar pero con el menú principal me pasa lo mismo.
    El tema es: Savona

    Iniciador del debate paulamartinez

    (@paulamartinez)

    He seguido investigando y he colocado otro tema diferente para saber si el problema viene de Savona pero al activar otro se sigue sin mostrar el menú por lo que deduzco que el problema no está en los temas sino en el propio wordpress, que estaré haciendo algo mal -y por más que miro no consigo saber qué puede ser-.

    Moderador LGrusin

    (@lgrusin)

    No todos los temas incluyen dos menús, ni se llaman igual.

    ¿Usas algún Page Builder? Das poca información para poder ayudarte.

    Yo he probado el Savona y va bien, pero dices que usas un tema hijo, por eso te pregunté. Para los efectos es un tema diferente.

    Prueba con una instalación nueva, crea una base de datos nueva y haces una instalación de WordPress en otra carpeta. Ahí pruebas el tema sin modificaciones.

    Iniciador del debate paulamartinez

    (@paulamartinez)

    Buens días, he creado una nueva base de datos y he instalado el wordpress con la última actualización y ya me va perfecto, muchas gracias.

Viendo 7 respuestas - de la 1 a la 7 (de un total de 7)
  • El debate ‘Me desaparece el menú’ está cerrado a nuevas respuestas.