Soporte » Guías – Resolución de problemas » Mi pagina solo funciona con nocache

  • Hola un saludo a todos muchas gracias por el tiempo voy a tratar de ser lo más claro posible:

    Tenía mi sitio web en Hostgator en un baby plan, pero quise hacer varios cambios.

    El primer cambio es que me pasé a Cloudways (servidor) lo cual mejoró notablemente la velocidad, seguido a ésto entré también en Cloudflare (gratis) y cambié mis name server en el dominio para que apuntada a cloudflare…

    Después en Cloudflare puse la IP de mi servidor para que estuviera OK y entrara ahora desde el servidor de Cloudwyas.

    Hasta allí todo iba genial la página cargaba super rápido y todo maravilloso.

    Pero cuando quise ponerle SSL (que al parecer Cloudways te la da opción con Let´s encryp) de una manera super sencilla lo configuré, pero seguido de ésto hice 2 cambios adicionales

    El primero es que en CLOUDFLARE puse 2 opciones la primera en la parte de SSL (cloudflare) puse

    Full
    Encrypts end-to-end, using a self signed certificate on the server

    y también allí mismo en Edge Certificates

    seleccione ON en

    Always Use HTTPS
    Redirect all requests with scheme “http” to “https”. This applies to all http requests to the zone. (ésto quedó en ON)

    Después de ésto instalé un plugin que se llama Really Simple SSL
    https://wordpress.org/plugins/really-simple-ssl/

    Lo activé en mi pagina web… pero algo adicional que hice fue la parte de ELEMENTOR que el mismo plugin Really Simple SSL sugiere.

    https://really-simple-ssl.com/knowledge-base/how-to-fix-mixed-content-in-elementor-after-moving-to-ssl/

    Bueno una vez hice todo ésto mi página web NO volvió a cargar.

    por ejemplo entro a

    https://fotografiabogota.com y si entra bien quiero que le des F5 (por lo menos a mi se queda casi 5 minutos cargando en blanco y nunca carga) pero cuando me comunico con el equipo de cloudways ellos dicen que carga perfectamente. y me envía el enlace así

    https://fotografiabogota.com/?nocache

    Lo curioso es que si funciona así pero NO normal…

    Ya borré el caché desde (wp rocket) y borré el caché desde cloudflare también borré el cache del servidor que dicen que lo debía borrar esperé más de 24 horas y NADA…

    Ahora la página de https://fotografiabogota.com y la página https://jamesfotografodebodas.com NO me sirven

    Qué creen que podría ser… estoy desesperado.

    Un abrazo muchas gracias.

    La página con la que necesito ayuda: [accede para ver el enlace]

Viendo 1 respuesta (de un total de 1)
  • Moderador LGrusin

    (@lgrusin)

    Debes tener en cuenta que tu dominio no es el mismo con http que con https. Es decir, http://fotografiabogota.com no es lo mismo que https://fotografiabogota.com para los efectos son dominios diferentes.

    Debes cambiar en la base de datos todas las referencias a la antigua URL (con HTTP) por la nueva (con HTTPS) y repite todo el proceso.

    Hay plugins que te permiten cambiar la URL y hacer backup, por ejemplo te puede servir para ese proceso https://wordpress.org/plugins/wp-migrate-db/

    • Esta respuesta fue modificada hace 1 año, 1 mes por LGrusin.
Viendo 1 respuesta (de un total de 1)
  • El debate ‘Mi pagina solo funciona con nocache’ está cerrado a nuevas respuestas.