Soporte » Guías – Resolución de problemas » Mi pagina web carga muy lento

  • Hola buenas tardes,
    Estuve haciendo los analisis de tiempo de carga de el sitio web y la verdad que es bastante lento, a pesar de haber aplicado las optimizaciones de imágenes, la carga sigue siendo bastante mala, alguna idea de cual podría ser la causa?

    Gracias por su atención.

    La página con la que necesito ayuda: [accede para ver el enlace]

Viendo 11 respuestas - 1 de 11 (de 11 total)
  • Buenas tardes, @chemaso

    por lo que he estado viendo, has hecho ya todos los cambios normales:
    – Las imágenes, efectivamente, están bien optimizadas
    – Tienes instalados y configurados autoptimize W3 Total Cache
    – Tienes bien configurados GZip y las cabeceras de caducidad
    – Tienes el servidor en tu mismo continente y tienes instalado PHP 7

    La puntuación de Pindom y GTMetrix es bastante aceptable. Te cuento lo que he visto que puedes probar sin complicarle mucho, lo siguiente ya sería empezar a mirar el servidor:

    – Desactiva la animación de precarga. No va a reducir el tiempo de carga, pero sí va a mejorar la velocidad de carga percibida.
    – Quita el mapa nativo de Google Maps que tienes en el megamenú y reemplázalo por una imagen estática que enlace a Google Maps, vas a ahora unas cuantas peticiones.
    – Parece que cada instancia de los widgets de título del siteorigin pagebuilder está cargando las fuente open-sans con @import intenta reemplazarlos por etiquetas H” nativas y CSS
    – Instala P3 (no te preocupes por que diga que lleva tres años sin actualizarse) y mira si los plugins están consumiendo más recursos de la cuenta
    https://es.wordpress.org/plugins/p3-profiler/
    – Instala Machete (disclaimer: soy el autor) y activa las opciones de optimización. Lee lo que hacen, pero las verdes y las amarillas son seguras. Seguramente te ayude a mejorar un poco: https://es.wordpress.org/plugins/machete/

    Por el lado del servidor lo único que te he podido ver desde fuera es que no tienes activado HTTP/2, en una página como la tuya con muchos ficheros pequeños te puede mejorar bastante el tiempo de carga.

    Muchas gracias @nilovelez, voy a implementar las mejoras que comentas y te cuento.

    babelns

    (@babelns)

    Buenas

    Me pasa lo mismo, la web que estoy trabajando carga muy lento. Ya he probado todo y no consigo solucionarlo. Alguna recomendación

    La web es olivaria.com

    Gracias

    BABELNS

    Moderador Fernando Tellado

    (@fernandot)

    En tu caso @babelns el principal problema es que cargas 2 imágenes que ellas solitas ya pesan, respectivamente, 12 y 6 mb. Da igual la optimización que hagas con plugins como Autoptimize, lo primero es el peso de la página.

    !2 mb: https://olivaria.com/wp-content/uploads/2018/08/1.jpg?id=1924
    6 mb: https://olivaria.com/wp-content/uploads/2018/08/356821-PAVK9V-980.jpg?id=1920

    babelns

    (@babelns)

    Buenas y muchas gracias por tu ayuda.

    Esta mañana reemplaza dichas imágenes por otras optimizadas que no pasan los 600kb. De hecho me sorprende que aúna aparezcan porque ya las he borrado del wordpress.

    A pesar de ello la página aún me va lenta en cargar, me podrías ayudar a buscar otra solución o saber si hay algún problemas respecto.

    Muchas gracias

    BABELNS

    Moderador Fernando Tellado

    (@fernandot)

    El principal problema sigue siendo ese (lo he comprobado ahora mismo). Borra las caches del servidor y WordPress y prueba de nuevo. El resto son nimiedades.

    https://tools.pingdom.com/#!/ddAhhH/https://olivaria.com/

    Y sí, tienes mapas que si pones captura en vez del mapa eliminas peticiones, y puedes especificar la cache de navegador para los PNG, principalmente, o mejorar la gestión de DNS cambiando de hosting, pero lo gordo es lo otro.

    babelns

    (@babelns)

    Fernando muchas gracias

    Lo he hecho y ahora la página va más rápida. No como quisiera, pero creo que ahora toca hablar con el hosting.

    Saludos

    BABELNS

    Moderador Fernando Tellado

    (@fernandot)

    La de 11 Mb sigue por ahí, revisa dónde la estás cargando porque te sigue ralentizando.

    Luego ya, si eso, mira a ver si de verdad necesitas el MapQuest, que genera demasiadas peticiones externas.

    Otra cosa que no me gusta en tu página es que tienes código ofuscado base64, mala señal. Mira a ver si no te han hackeado el tema o algún plugin, o está descargado de algún sitio poco fiable.

    babelns

    (@babelns)

    Hola

    1. Gracias, revisaré las imágenes y veré de donde las están descargando ya que me parece muy raro, ya que la he borrado del wordpress y ahora revisaré desde el ftp para ver si hay algo por ahí.

    2. Con respecto al código ofuscado base64, no tengo idea como verlo. Me podrías dar alguna recomendación para saber cómo solucionarlo, ya que mis conocimientos no llegan hasta allí.

    Gracias

    BabelNS

    babelns

    (@babelns)

    Perdona otra cosa

    Hace una semana el wordpress se borró completamente y volvió a la instalación base sin que hagamos nada de nada. Crees que se debe a esto.

    Gracias

    Saludos

    BABELNS

    Moderador Fernando Tellado

    (@fernandot)

    Pues con lo que dices podrían haberte hackeado. Yo haría una limpia completa de toda la instalación.

Viendo 11 respuestas - 1 de 11 (de 11 total)
  • Debes estar registrado para responder a este tema.