Soporte » Guías – Resolución de problemas » Mi sitio dejo de funcionar despues del Update, tengo 3 errores

  • Saludos a todos, nuevo miembro aqui
    Estoy buscando ayuda con mi sitio que esta dando problemas desde el ultimo update
    El sitio basicamente es para recibir un descuento, a quien agregue 3 correos de amigos
    estos correos luego se agregan a una base de datos, para promociones eventuales

    Estos son los errores que estoy recibiendo:
    Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; DB_Sql has a deprecated constructor in /home4/public/public_html/gvp/lib/inc.db_mysql.php on line 13

    Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; Template has a deprecated constructor in /home4/public/public_html/gvp/lib/inc.template.php on line 62

    Fatal error: Uncaught Error: Call to undefined function mysql_connect() in /home4/public/public_html/gvp/lib/inc.db_mysql.php:76 Stack trace: #0 /home4/public/public_html/gvp/lib/inc.db_mysql.php(110): DB_Sql->connect() #1 /home4/public/public_html/gvp/index.php(11): DB_Sql->query(‘SELECT aff_url …’) #2 {main} thrown in /home4/public/public_html/gvp/lib/inc.db_mysql.php on line 76

    La página con la que necesito ayuda: [accede para ver el enlace]

Viendo 7 respuestas - 1 de 7 (de 7 total)
  • Moderador almendron

    (@almendron)

    ¿Qué tienes instalado en el directorio «gvp»? Tu página no parece estar construida con WordPress.

    Tengo entendido que el folder gvp es el que contiene la funcion que permite agregar los correos y los agrega a una base de datos.
    Para serles sinceros, no tengo conocimientos en como funciona el sitio.
    tengo entendido que no es un plugin.

    Hola @adacale

    Lamentablemente creo que no te podemos ayudar con tu problema, al tener una función personalizada a la que no tenemos acceso no podemos indicarte cual puede ser el problema, podrías tratar de instalar una copia de seguridad, si no tienes tú consulta con tu hosting a ver si ellos tienen.

    Como dices que el problema surgió con la última actualización también podrías tratar de revertir el proceso.

    Eso de revertir suena interesante.
    Que se necesita para revertir el update?

    Moderador almendron

    (@almendron)

    1) ¿Qué actualización llevaste a cabo?

    2) ¿Usas WordPress?

    Esto no es wordpress. Supongo que la actualización que comentas es de PHP. La versión 7 de php no tiene la función mysql_connect.
    Ponte en contacto con tu proveedor de hosting y te podrán ayudar.

    Hola @adacale

    Con respecto a lo de revertir tendrías que saber exactamente que fue lo que actualizaste para instalar las versiones anteriores, en este caso los errores se producen en una página que no es de WordPress, como tu mismo dices es una página con algo hecho a medida, por lo que la solución que te da @adriandegrafreak es la más plausible, seguramente tendrás que bajar a una versión de php anterior, lo cual a la larga te traerá problemas.

    De momento sigue su consejo, pero deberías buscar un desarrollador que te adapte el código.

Viendo 7 respuestas - 1 de 7 (de 7 total)
  • Debes estar registrado para responder a este debate.