Soporte » Guías – Resolución de problemas » Migrar subdominio a dominio principal

  • Resuelto gerarddus

    (@gerarddus)


    Hola, he estado remodelando mi web http://www.castillodelariba.com desde hace meses, para ello he creado un sobdominio: obras.castillodelariba.com para poder hacerlo y que la principal estuviera operativa. Ahora quiero migar ese subdominio y convertirlo en mi dominio principal y borrar la antigua web. El problema que tengo es que me estoy liando. He estado viendo vídeos de cómo hacerlo y he utilizado los plugins duplicator y all in one migration, pero tengo problemas al exceder el máximo de megas y paso de pagar por ello. ¿Hay algún plugin que sea gratis y que me pueda valer? Otra cosa sería hacerlo trasladando los archivos de la carpeta obrascastillodelariba.com que está metida dentro del public a éste, tras haber borrado los archivos de la anterior, pero no es tan simple todo. ¿Dónde podría encontrar una explicación sencilla y en castellano para poder hacer todo esto? Tengo un miedo horrible a cagarla y perder todo el trabajo que he hecho en estos meses. Un saludo.

    La página con la que necesito ayuda: [accede para ver el enlace]

Viendo 15 respuestas - de la 16 a la 30 (de un total de 63)
  • Sí, usaba un plugin de caché que he desinstalado. He comprobado que tanto ese apartado de época musulmana como la página de inicio salían como no seguros a pesar de que todas las demás subpáginas sí que salen como seguras con el https. He vuelto a poner el enlace en la página de inicio y las imágenes de la de época musulmana y en el internet explorer me sale bien. En microsoft edge no me salen bien y en chrome voy a intentarlo a ver qué pasa.

    Google chrome me sigue dando tanto inicio como esa subpágina de época musulmana como no seguras. Estoy estancado, no se qué puedo hacer para solucionarlo.

    Por cierto, tal y como he puesto en otro post, ese vídeo de la página de inicio subido de youtube no me suena a pesar de que, en principio, tendría que oírse. He comprobado que no haya nada marcado y parece que todo está bien.

    Moderador almendron

    (@almendron)

    En la página de época musulmana he hecho eso, he eliminado la imagen y luego la he cargado. He hecho lo mismo en absolutamente todas las imágenes de esa página. Es decir, no he eliminado el bloque de imagen en sí, si no que la he editado y la he desmarcado y vuelto a marcar. He hecho eso con todas las imágenes tanto en esa página como en la inicial.
    En la inicial hay un slider en la parte de abajo del todo. ¿Es ese al que te refieres o el video de arriba del todo.
    Por cierto, no sé qué bloque elegí para lo del vídeo de arriba, ya que no es ni un título, ni un vídeo ni una imagen…no me acuerdo cúal elegí para poder borrarlo del todo y volver a ponerlo. ¿Cúal podría ser, es un vídeo con título dentro?

    El slider de la página de inicio de abajo, eliminé una por una las fotos y las volví a cargar. No eliminé el slider del tirón.

    Moderador almendron

    (@almendron)

    En la página principal, la foto es http://obras.castillodelariba.com/wp-content/uploads/2020/04/Imagen-de-portada.jpg

    No se qué bloque pudiste usar.

    gerarddus

    (@gerarddus)

    No sé si está arreglado en la página principal, he modificado esa imagen de portada de la que hablabas y parece que ya no me sale eso de si es no seguro el sitio. En cuanto a la de la época musulmana, no sé qué imagen me da problemas. He borrado una que decías de primeras taifas pero me sigue dando problema y me dice que no es seguro.
    También me están diciendo que hay problemas para cargar subpáginas desde tablet y desde móvil e incluso alguno me dice que desde pc. Problemas en el menú, pero no acabo de ver esos problemas, les he dicho que den a las flechas de los submenús y elijan las subpáginas. Si dan encima de un elemento del menú que tenga submenús, le sale la página de about us y otras páginas que he desechado, ya que construí la página entera encima de esas páginas de ejemplo. No sé qué problema puede haber.
    ¿Si borro definitivamente las subcarpeta obrascastillodelariba.com del public-html. ¿Crees que me dará problemas la página? Por cierto, cuando abro Hostinger y me meto en wordpress, me sale como wordpress el del subdominio obrascastillodelariba.com. ¿Tendría que instalar otro wordpress en la carpeta raíz?

    Moderador almendron

    (@almendron)

    1) Ahora ya salen bien todas las páginas.

    2)

    ¿Tendría que instalar otro wordpress en la carpeta raíz?

    ¿No tienes instalado el actual en la raíz? Se supone que tienes dos instalaciones: uno en una carpeta (subdominio) y otro en la raíz. ¿Es así?

    3) Haz una copia de seguridad de obrascastillodelariba.com y luego la borras.

    4) No detecto ningún problema en los menús.

    gerarddus

    (@gerarddus)

    2. Creo que sólo tengo una instalación en el subdominio y en el raiz no, pero me pilla por defecto el del subdominio. Voy a borrar la carpeta de obrascastillodelariba.com a ver qué pasa. Si después no puedo entrar en la página, tendré que instalar otro wordpress. Voy a ello.

    gerarddus

    (@gerarddus)

    Efectivamente, he borrado obrascastilodelariba.com y me sale el siguiente mensaje: ¡Uy! el escritorio de WordPress no funciona correctamente debido a errores imprevistos.
    Please check your WordPress installation, some files are missing

    gerarddus

    (@gerarddus)

    He instalado otro wordpress en el directorio raiz, pero claro, ahora no me sale mi página web para editarla, es como si fuera desde el inicio. Ahora mismo tengo dos aplicaciones instaladas: el wordpress de http.//obras.castillodelariba.com que no me funciona, tal y como dije arriba y tengo el otro wordpress que tendría que ser el definitivo, el fetén: http://castillodelariba.com, que si me funciona pero que no tiene nada y no se relaciona con mi página web.

    Moderador almendron

    (@almendron)

    Lo siento mucho pero es imposible seguir ayudándote. El proceso que querías hacer es de lo más sencillo del mundo pero la has liado de una forma que ya no entiendo nada.

    En mi primera contestación, te dije en el punto 4

    4) Mueve todos los archivos de la antigua instalación a la raíz de tu sitio.

    Y ahora me sales diciendo que no lo habías hecho y que has instalado un nuevo WordPress.

    Borra el nuevo WordPress y mueve los archivos de tu sitio a la raíz. Y ya está.

    gerarddus

    (@gerarddus)

    Lo había hecho. Todos los archivos de la antigua instalación estaban en obrascastillodelatiba.com y copié íntegro toda esa carpeta, a la raíz del sitio. Con todo, ahora he borrado la carpeta de obras, pero me da fallo wordpress, por eso he instalado otro, para ver si me funcionaba y me cogía la web, pero no me la coge.

    Moderador almendron

    (@almendron)

    Una pregunta: ¿copiaste la carpeta tal cual o el contenido de la carpeta?

Viendo 15 respuestas - de la 16 a la 30 (de un total de 63)
  • Debes estar registrado para responder a este debate.