Soporte » Plugins y Hacks » WooCommerce » No funcionan los filtros en WooCommerce

  • Hola,

    No se muestran los filtros que agrego en la barra lateral de WooCommerce, si funciona el widget «Busqueda de producto» pero no los filtros (filtrar productos por precio, productos activos, productos por puntuacion o por atributo).
    Cuando doy al botón actualizar del navegador mientras recarga la pagina se muestra un par de segundos «Filtrar por precio» debajo de «Buscar productos» pero enseguida desaparece.

    He desactivado todos los complementos pero continuan sin mostrarse los filtros. Por las dudas, tengo productos cargados que se muestran en la pagina «Tienda».
    Estoy usando ASTRA como tema y la version 5.8 de WordPress con la 5.5.1 de WooCommerce.

    Hay algo que pueda hacer para solucionar este problema?

    Gracias y saludos,

    • Este debate fue modificado hace 4 días, 2 horas por Jose Luis. Razón: Mover al foro correspondiente
Viendo 3 respuestas - de la 1 a la 3 (de un total de 3)
  • Moderador Fernando Tellado

    (@fernandot)

    Acabo de probar con WordPress 5.8, WooCommerce 5.5.1 y la última versión de Astra y funciona perfectamente, puedes comprobarlo tú mismo en esta página de pruebas.

    Lo que sí he comprobado es que sale roto el deslizador del filtro, salen unas cajas de introducción de precio, y habrá que avisar de este error 😉 , pero salir sale el filtro, raro, pero sale.

    ¿Podrías indicar en qué web te está pasando?

    Iniciador del debate marxelog

    (@marxelog)

    Hola Fernando, gracias por tu respuesta.
    La web es https://www.kukusu.com.uy/store tengo aplicada la plantilla Simply Natural. Probé cambiarla pero tampoco se muestra los filtros. Si te fijas los primeros segundos que mientras carga la web se ve la barra del filtro pero desaparece enseguida…

    Gracias y saludos,

    Iniciador del debate marxelog

    (@marxelog)

    Mas abajo pego el error que encontré con F12 en la web, aun no se como solucionarlo pero seguiré investigando…

    `JQMIGRATE: Migrate is installed, version 3.3.2
    (index):549 woocommerce_shared_settings filter in Blocks is deprecated. See https://github.com/woocommerce/woocommerce-gutenberg-products-block/blob/trunk/docs/contributors/block-assets.md
    (anonymous) @ (index):549
    deprecated.min.js?ver=932d8bb37da8bbb396a7a3f754345e08:2 select control in @wordpress/data-controls is deprecated since version 5.7. Please use built-in resolveSelect control in @wordpress/data instead.
    i @ deprecated.min.js?ver=932d8bb37da8bbb396a7a3f754345e08:2
    l @ data-controls.min.js?ver=cb4174d77c57f56732dc41d3bf3b2781:2

    Saludos,

Viendo 3 respuestas - de la 1 a la 3 (de un total de 3)
  • Debes estar registrado para responder a este debate.