Soporte » Guías – Resolución de problemas » No funcionan los filtros para productos (error 500)

  • Hola buen día.

    El día de ayer me reportaron que no funcionan los filtros en nuestra página de productos. Fui a ver si había dañado algo al editarla día anteriores pero al restaurar la versión sigue con el mismo problema.

    Al seleccionar un filtro se genera un error en la consola «admin-ajax.php» error 500.

    Y algo que se me hizo raro es que cuando hago un filtro de fabrica en la sección de Modems y Routers, al recargar la página si aparece el filtro aplicado, pero solo pasa con ese filtro. Todos los widgets de filtros están hechos con Checkboxes y la configuración es:
    – Apply type: AJAX
    – Apply on: Value change

    Me sería de mucha ayuda cualquier sugerencia, de antemano muchas gracias.

    La página con la que necesito ayuda: [accede para ver el enlace]

Viendo 8 respuestas - de la 1 a la 8 (de un total de 8)
  • Moderador almendron

    (@almendron)

    Detecto dos errores en esa página en concreto.

    Por un lado, hay etiquetas mal cerradas. Mira el código fuente y lo podrás ver al final. En Firefox esas etiquetas aparecen en rojo y si pones el ratón encima verás la explicación.

    Y luego en consola sale lo siguiente:

    Internal Server Error [500]. public-d2d0c99b65cea098bda0046534a83f45.js:1:29218
        value https://bismark.net.co/wp-content/cache/min/1/wp-content/plugins/jet-smart-filters/assets/js/public-d2d0c99b65cea098bda0046534a83f45.js:1

    ¿Usas algún tipo de cache o para minificar código?

    Iniciador del debate mauriciopr

    (@mauriciopr)

    Hola Gracias por tu respuesta.

    Estoy comparando con backups anteriores para corregir el archivo que tiene etiquetas mal cerradas.

    Y ante lo de cache sé que se está usando el plugin WP Rokect.

    Moderador almendron

    (@almendron)

    Desactiva el cache y comprueba. Es muy probable que también sea la causa de las etiquetas mal cerradas.

    Iniciador del debate mauriciopr

    (@mauriciopr)

    Bueno desactive WP Rocket, aún sigue igual, voy a ver si de casualidad haya otra herramienta que usemos para cache que no tenga en cuenta.

    Iniciador del debate mauriciopr

    (@mauriciopr)

    No, solo es ese plugin para la Caché.

    Estoy esperando que me dice Crocoblock por si llegase a ser una falla de este widget. Informaré aquí en tal caso de que sea así.

    Moderador almendron

    (@almendron)

    Deja desactivado el plugin de cache para que le pueda echar un vistazo. No va a pasar nada porque esté la página sin cache unas horas o un día.

    Iniciador del debate mauriciopr

    (@mauriciopr)

    Listo, ya lo dejé desactivado.

    • Esta respuesta fue modificada hace 1 día, 9 horas por mauriciopr.
    Moderador almendron

    (@almendron)

    1) Las etiquetas siguen mal cerradas.

    2) El error lo ocasiona el archivo https://bismark.net.co/wp-content/plugins/jet-smart-filters/assets/js/public.js?ver=1.8.3:1`

Viendo 8 respuestas - de la 1 a la 8 (de un total de 8)
  • Debes estar registrado para responder a este debate.