Soporte » Plugins y Hacks » WooCommerce » No llegan los emails (los del cliente)

  • Resuelto cienfu90

    (@cienfu90)



    Buenas,

    Tengo un problema con los emails de wordpress, la confirmación de pedidos (la que yo recibo) llega perfectamente, pero los clientes, no estan recibiendo su email de confirmacion (y si, esta configurado).

    ¿Qué puede ser?

Viendo 15 respuestas - 1 de 15 (de 15 total)
  • Carme Mias

    (@carmemias)

    Hola,

    La función que usa WordPress por defecto, PHP mail(), a menudo falla y no sólo con WooCommerce.

    En la mayoría de los casos el problema se puede solucionar instalando un cliente SMTP, como por ejemplo el WP Mail SMTP ( https://es.wordpress.org/plugins/wp-mail-smtp/ )

    • Esta respuesta fue modificada hace 7 meses por  Carme Mias.

    Solucionado, gracias.

    Hola, para solucionar un problema con los emails de wordpress, la confirmación de pedidos (la que yo recibo) llega perfectamente, pero los clientes, no están recibiendo su email de confirmación; instale “WP Mail SMTP por WPForms” y en la configuración me pide:
    ID cliente
    Clave secreta de cliente
    ¿Que es y como la obtengo?

    Gracias, quedo atento a tu respuesta.

    Hola Jose,

    Para enviar correos, tienes que darle los datos de la cuenta que quieres que use. Normalmente te pedirá el email y contraseña así como los datos del servidor SMTP.

    Personalmente yo uso el plugin WP Mail SMTP en inglés y ahora no tengo una traducción a mano, pero lo más seguro es que te esté pidiendo la dirección de email y contraseña.

    Para los datos sobre el servidor SMTP, lo mejor es chequear la documentación de tu proveidor de email (puede ser el mismo que el hosting, en cuyo caso normalmente se puede encontrar también en el Control Panel)

    Ya lo configure colocandole los datos que solicita, pero cuando lo voy a autorizar
    pulsando en “Permite al plugin enviar correos usando tu cuenta de Google
    Haz clic en el botón de arriba para confirmar la autorización”
    Me aparece esta pagina de Google
    401. Eso es un error.

    Error: cliente no válido

    No se encontró el cliente OAuth.

    Pedir detalles
    Eso es todo lo que sabemos.

    Si me salto el paso “Autorizar” guardo los ajustes y paso al “correo de prueba” y trato de enviar un correo me sale este mensaje:
    Hubo un problema al mandar el correo de prueba. Los mensajes de depuración relacionados se muestran a continuación:

    Versions:
    WordPress: 4.9.6
    WordPress MS: No
    PHP: 5.6.27
    WP Mail SMTP: 1.2.5

    Params:
    Mailer: gmail
    Constants: No
    Client ID/Secret: Yes
    Auth Code: No
    Access Token: No

    Server:
    OpenSSL: Yes
    PHP.allow_url_fopen: Yes
    PHP.stream_socket_client(): Yes
    PHP.fsockopen(): Yes
    PHP.curl_version(): Yes

    Debug:
    Error while sending via Gmail mailer: {
    “error”: {
    “errors”: [
    {
    “domain”: “global”,
    “reason”: “required”,
    “message”: “Login Required”,
    “locationType”: “header”,
    “location”: “Authorization”
    }
    ],
    “code”: 401,
    “message”: “Login Required”
    }
    }
    Error while sending via Gmail mailer: {
    “error”: {
    “errors”: [
    {
    “domain”: “global”,
    “reason”: “required”,
    “message”: “Login Required”,
    “locationType”: “header”,
    “location”: “Authorization”
    }
    ],
    “code”: 401,
    “message”: “Login Required”
    }
    }
    Error while sending via Gmail mailer: {
    “error”: {
    “errors”: [
    {
    “domain”: “global”,
    “reason”: “required”,
    “message”: “Login Required”,
    “locationType”: “header”,
    “location”: “Authorization”
    }
    ],
    “code”: 401,
    “message”: “Login Required”
    }
    }
    Error while sending via Gmail mailer: {
    “error”: {
    “errors”: [
    {
    “domain”: “global”,
    “reason”: “required”,
    “message”: “Login Required”,
    “locationType”: “header”,
    “location”: “Authorization”
    }
    ],
    “code”: 401,
    “message”: “Login Required”
    }
    }

    ¿Cual es es problema?
    Agradezco enormemente tu respuesta?

    Hola,

    Según el error log el problema es debido a que necesita el código OAuth.

    Si tu correo es con GMail, funciona un poco distinto ya que primero necesitas que GMail autorize al plugin para enviar emails. El proceso de configuración en principio tendría que pedirte que te conectes a tu cuenta GMail y darte el código OAuth que necesitas.

    Puedes probar de desactivar otros plugins temporalmente y volver a probar para ver si se trata de un problema de conexiones múltiples o de cache. Ha habido casos en que otros plugins que interaccionan con Google han causado problemas con el plugin SMTP, como en este caso: https://wordpress.org/support/topic/error-when-authorizing-plugin-from-settings-page/

    En mi opinión, si después de volver a probar todavía no funciona, lo mas sencillo es cambiar el plugin “WP Mail SMTP” por el “GMail SMTP”.

    https://es.wordpress.org/plugins/gmail-smtp/

    Mi estrategia cuando necesito instalar un cliente SMTP es la siguiente: si es el email desde el cual WordPress enviará los correos es GMail, instalo “GMail SMTP”, si no, instalo “WP Mail SMTP”.

    Hola Carme Mias, estoy muy agradecido contigo por toda la ayuda que me haz brindado, ya que soy nuevo en el mundo WordPress y tengo muchas dudas al respecto.
    Seguí tu sugerencia e instale “GMail SMTP”, y aunque es mas complejo que los demás, seguí las instrucciones de la documentación pero al conceder los permisos me aparece este mensaje:
    400. Eso es un error.

    Error: redirect_uri_mismatch

    El URI de redirección en la solicitud, http://yovendoderemate.com/wp-admin/options-general.php?page=gmail-smtp-settings&action=oauth_grant, no coincide con los autorizados para el cliente de OAuth. Para actualizar los URI de redireccionamiento autorizados, visite:

    Al verificar la información y agregarla nuevamente, me sale el mismo error que puedo hacer?

    Estoy atorado en este punto ya que mis usuarios no tienen acceso a las características importantes de mi pagina web, sino pueden ingresar o registrarse en ella y para ello necesitan ser notificados a través de su correo.

    Quedo atento a tu respuesta, que tengas un excelente día.

    Hola Jose,

    Hay un punto que no queda muy claro en las instrucciones del plugin “GMail SMTP”.

    Si vas a la página de configuración del plugin (Ajustes > GMail SMTP > General), verás en la parte de arriba “Authorized Redirect URI – Copy this URL into your web application” y una dirección que coincide con la que te pone en el mensaje de error: http://yovendoderemate.com/wp-admin/options-general.php?page=gmail-smtp-settings&action=oauth_grant

    Esta dirección tiene que entrarse en la configuración de la aplicación de Google Developers que creaste. Para hacerlo, conéctate a tu cuenta en Google Developers (console.developers.google.com). Tu aplicación habrá sido preseleccionada si sólo tienes una. A continuación escoge la opción “Credenciales” del menú de la izquierda y haz clic en el icono en forma de lápiz, “Edita cliente OAuth”.

    En la nueva pantalla, copia y pega esta dirección http://yovendoderemate.com/wp-admin/options-general.php?page=gmail-smtp-settings&action=oauth_grant donde dice “Authorized redirect URIs” y guarda los cambios.

    Ahora puedes volver a tu sitio WordPress y, de vuelta a Ajustes > GMail SMTP > General, dale al botón “Grant Permission”.

    Si todavía no pasa el test, mira que no haya algún espacio en blanco al principio o final del Client ID o Client Secret.

    Hola Carme Mias, gracias nuevamente por contestarme, seguí tus instrucciones “al pie de la letra” y verifique los espacios, pero aun no paso el test, me sigue apareciendo el mismo error.

    Otra cosa, me preocupa que mis datos de la cuenta developers hayan quedado expuestos, ¿Como puedo reparar esto o quitar esta información del foro?

    Hola,

    Siento no haber podido ayudarte, si has entrado todos los datos necesarios tendría que conectarse bien. Puede que haya algún conflicto con otro plugin, quizás lo siguiente a probar sería desconectar temporalmente otros plugins y ver si el problema todavía ocurre.

    No hay ningún dato de tu cuenta developers en el contenido de esta conversación.

    No te preocupes, tu me has colaborado muchísimo en este proceso de aprendizaje, el problema lo tengo es con el hosting por las medidas de seguridad que tiene implementadas el servidor, en todo caso muchísimas gracias por todos tus aportes me han llevado a ver otras opciones que me permitirán mejorar mi proyecto.
    Es motivador saber que no estas solo, cuando eres un novato en el mundo WordPress, ya que hay personas como tu Carme Mias, dispuestas a colaborar desinteresadamente.

    Éxitos y que tengas un excelente día.

    Igualmente José.

    Hola Carme Mias, hable con el soporte de mi hosting Godaddy y me dicen que los correos no se envían debido a que la configuración de los servidores para WordPress es el puerto 25 y que por lo tanto debo buscar un plugin que se conecte al puerto 25 o que use un plugin que no se conecte al servidor.
    ¿Sabes de alguno que puedas recomendarme?
    ¿Que hosting utilizas tu?
    Me gustaría cambiar el hosting Godaddy a Amazon web service, ¿Sabes si Amazon tiene el mismo problema con el envió de correos?
    Gracias, quedo atento a tu respuesta.

    Buenas tardes quisiera saber porque motivos no me llegan los documentos que me carga el cliente ya que en el pago solicitamos unos archivos pero no los veo por ningún lado. por favor ayuda no encuentro solución. Gracias

    Moderador LGrusin

    (@lgrusin)

    @juanpb crea un debate para tu consulta.

Viendo 15 respuestas - 1 de 15 (de 15 total)
  • Debes estar registrado para responder a este tema.