WordPress.org

Español

Soporte

Soporte » Guías – Resolución de problemas » No logro hacer funcionar el redireccionamniento de URL

No logro hacer funcionar el redireccionamniento de URL

  • Resuelto lcguardiadelanoche

    @lcguardiadelanoche

    Buenos días.

    Llevo varios días mirando paginas acerca del cambio de URL y no logro que funcione correctamente el blog. La idea es pasar de -> a:

    coe.guardiadelanoche.es -> guardiadelanoche.es
    Theme aplicado: Youplay by _nK (Themeforest)

    Tras la instalacion esta asi:
    Dirección de WordPress (URL): http://coe.guardiadelanoche.es
    Dirección del sitio (URL): http://coe.guardiadelanoche.es

    Despues lo dejo asi:
    Dirección de WordPress (URL): http://guardiadelanoche.es/coe/
    Dirección del sitio (URL): http://guardiadelanoche.es

    Os explico los diferentes intentos fallidos y como lo he hecho:

    1. Redireccionamiento desde el host.
    Si realizo este cambio el responsive no funciona en dispositivos moviles ademas de que cuando intento entrar por ejemplo en wp-admin se queda todo en blanco u no reacciona.

    2. Alias.
    Practicamente lo mismo.

    3. Siguiendo esta guia: https://codex.wordpress.org/Giving_WordPress_Its_Own_Directory

    Bien con esta guía lo que me sucede es que se pierden los iconos de las redes sociales del footer, del login, de la ayuda,… Ademas de no poder loguear y entrar en wp-admin de ninguna forma.

    4. Segui otra guia tambien de codex.wordpress.org en el que despues de seguir los pasos te recomiendan pasar un plugin para actualizar las url internas y de la base de datos.

    Toda ayuda sera muy agradecida ya que no doy con la solución.

    Un saludo
    JaPeMo

Viendo 4 respuestas - 16 de 19 (de 19 total)
  • lcguardiadelanoche

    @lcguardiadelanoche

    No me lie, segui los pasos del tutorial exactamente, y como he dicho, solo cambie la direccion del sitio. La de la instalacion de wordpress no. Por eso tenia problemas. Al cambiarla, ha funcionado todo correctamente.

    El subdominio, en one.com es una carpeta en la raiz, por tanto, si la borro, borro la instalacion. Ya lo dije antes.

    Aqui tienes como se hace un subdominio en one.com: https://www.one.com/es/support/faq/como-creo-un-subdominio

    Despuea de pasar velvet se han arreglado las urls de la base de datos y de la instalacion.

    Ahora va todo perfecto. Cierro hilo

    Moderador almendron

    @almendron

    Para quien lea este hilo: no intentéis hacer lo mismo que ha hecho @lcguardiadelanoche porque podéis cargaros vuestro sitio.
    Si tenéis wordpress instalado en una carpeta y queréis pasarlo a otra (por ejemplo, el directorio raíz), solo tenéis que seguir los pasos indicados en el CODEX: https://codex.wordpress.org/Giving_WordPress_Its_Own_Directory#Using_a_pre-existing_subdirectory_install

    lcguardiadelanoche

    @lcguardiadelanoche

    Posiblemente @almendron tenga razon.

    El caso es que mi web funciona perfectamente y al 100% habiendo hecho lo que he comentado.

    Parece ser que nunca te has encontrado con instalaciones subdominios o carpetas de one.com

    Un saludin XD

    lcguardiadelanoche

    @lcguardiadelanoche

    Posiblemente @almendron tenga razon.

    El caso es que mi web funciona perfectamente y al 100% habiendo hecho lo que he comentado.

    Parece ser que nunca te has encontrado con instalaciones subdominios o carpetas de one.com

    Un saludin XD

Viendo 4 respuestas - 16 de 19 (de 19 total)
  • El debate ‘No logro hacer funcionar el redireccionamniento de URL’ está cerrado y no admite más respuestas.
Ir a la barra de herramientas