• Resuelto tempocrea

    (@tempocrea)


    Buenas tardes,

    tengo varias páginas y me pasa algo curioso con esta. Cuando pincho en alguna de las 6 imágenes de la galería donde adjunto el enlace u otras de la web se me abre la imagen sin más pero no en galería para poder y pasando.

    No sé que puede ocurrir, he desactivado todos los plugins e igual. También he cambiado a un tema por defecto de wordpress y sigue estando igual.

    No sé que puede ser ya, ya que he instalado de nuevo wordpress y sigue sin ir.

    Gracias!

    La página con la que necesito ayuda: [accede para ver el enlace]

Viendo 15 respuestas - de la 1 a la 15 (de un total de 15)
  • Moderador almendron

    (@almendron)

    No te funciona ninguna imagen. Ni esa página ni en otras.

    ¿Qué plugin usas?

    Iniciador del debate tempocrea

    (@tempocrea)

    No uso ningún plugin, esa es la cosa. Solamente el Revolution Slider pero no creo que sea de eso. Ya probé a desactivar todos los plugins y sigue estando igual.

    Es cierto que probé hace tiempo algunos plugins para tener el efecto fancybox pero al no ir bien lo desinstalé. No sé que hacer ya ni que probar.

    Gracias por la respuesta.

    Moderador almendron

    (@almendron)

    Si no usas un plugin, la imagen se abre sin más en una nueva página. No hay ningún tipo de efecto y menos aún de galería.

    En la página que mencionas, aparece el siguiente código:

    <a rel="prettyPhoto[slides]" href="https://zwergspitzweiss.com/wp-content/uploads/2018/12/1l.jpg">

    El campo «rel» sobra, es decir, debería quedar así:

    <a href="https://zwergspitzweiss.com/wp-content/uploads/2018/12/1l.jpg">

    Por otra parte, puedes usar las galería que trae por defecto WordPress o usar el plugin https://es.wordpress.org/plugins/easy-fancybox/ que funciona bastante bien.

    Iniciador del debate tempocrea

    (@tempocrea)

    Buenas de nuevo,

    He instalado este plugin y sigue estando igual. No sé si por defecto debo debo de tocar algo.

    La galería está creada como se crea normalmente una galería … [gallery link="file" ids="1784,1785,1786,1787,1788,1789"]

    Gracias por la sugerencias.

    Moderador almendron

    (@almendron)

    A ver si puedes hacer lo siguiente:

    1) Ve a Ajustes > Medios
    .- Sección «Imágenes»: comprueba en la opción «Detección automática» aparezca, como mínimo, «.jpg .jpeg .png .gif» (sin comillas)
    .- Sección «Galería»: opción «Galería automática» que esté puesto «Solo galerías WordPress».

    2) Desactiva el plugin Revolution Slider

    3) Borra la galería y luego la vuelves a poner.

    Iniciador del debate tempocrea

    (@tempocrea)

    Acabo de hacer todo lo que me has pedido.

    De momento sigue sin ir, es un poco raro esto.

    Moderador almendron

    (@almendron)

    En esa misma entrada inserta una imagen en pequeño y pon enlazado al archivo de medios (en la 4.9.9 creo que se dice de otra forma) y me avisas cuando esté.
    https://zwergspitzweiss.com/wer-sind-wir/

    De todas formas, el problema viene de rel="prettyPhoto[slides]". Un código, el tema o un plugin te está metiendo eso en los enlaces.

    Moderador almendron

    (@almendron)

    A ver si tienes este código en algún sitio, probablemente en el archivo functions.php del tema

    add_filter( 'wp_get_attachment_link', 'sant_prettyadd');
     
    function sant_prettyadd ($content) {
    	$content = preg_replace("/<a/","<a rel=\"prettyPhoto[slides]\"",$content,1);
    	return $content;
    }

    O algo parecido.

    Iniciador del debate tempocrea

    (@tempocrea)

    He desactivado del functions.php del tema lo que comentas pero sigue sin ir.

    Ya probé anteriormente a cambiar de tema y seguía igual.

    Me sabe mal por usted que pierda tiempo en esto.

    Moderador almendron

    (@almendron)

    Ahora efectivamente ya no mete ese código pero el relativo a la galería sigue sin ser el normal.

    Con el plugin que te he recomendado activo:

    1) cambia de tema

    2) edita la entrada

    3) Borra la galería

    4) Vuelve a insertarla.

    Vamos a ver si encontramos donde está el problema. Creo que al final va ser cosa del tema.

    • Esta respuesta fue modificada hace 5 años, 3 meses por almendron.
    Iniciador del debate tempocrea

    (@tempocrea)

    Lo probaré luego más tarde y le comentaré. Con este tema tenemos hecha 7 webs más y mirando una de ellas mete el código ese también pero funciona bien.

    https://pomeraniatoy.com/criadero-pomerania-toy/

    Esta es la única que tiene problemas. La solución larga que se me ocurre es hacer la web de nuevo cambiando textos e imágenes de unas de las que funcione pero sería demasiado jaleo creo yo.

    Gracias!

    Moderador almendron

    (@almendron)

    Dos pruebas más para cuando puedas:

    1) Desactiva TODOS los plugins excepto Easy FancyBox. A ver si es que alguno interfiere.

    2) Si nada resulta, usa «swipebox» que por lo veo funciona bien en esa segunda página que has mencionado.

    Iniciador del debate tempocrea

    (@tempocrea)

    Buenos días,

    gracias @almendron

    He instalado swipebox y junto Easy FancyBox funciona. Si desactivo Easy FancyBox en vez de mostrarme la imagen me lo muestra negro conque lo dejaré activo.

    Me he fijado también que ha diferencia de las otras webs, se me abre la galería distinta a las otras. Se me abre como se ve en móviles las demás en vez con la galería típica de google como puede pasar en https://pomeraniatoy.com/criadero-pomerania-toy/

    Pero bueno, lo dejaré así, al menos funciona «correctamente».

    Gracias!!!

    Moderador almendron

    (@almendron)

    Me da la impresión que el tema incorpora algún tipo de función para mostrar las imágenes y que eso colisiona con otros plugins.

    Iniciador del debate tempocrea

    (@tempocrea)

    Si me influye en algo más adelante lo comentaré, no vamos a calentarnos la cabeza más con este asunto. Al menos ahora está funcional.

    Muchas gracias!

Viendo 15 respuestas - de la 1 a la 15 (de un total de 15)
  • El debate ‘No me aparece la galería en ventana emergente’ está cerrado a nuevas respuestas.