Soporte » Guías – Resolución de problemas » NO me muestra los post en CATEGORÍAS ni en ETIQUETAS

  • Buenas

    Después de hacer algunas redirecciones por un cambio de dominio, resulta que ahora cuando entro en el Blog y hago clic en CATEGORÍAS o ETIQUETAS no me muestra los posts relacionados, sino una página en blanco en ambos casos.

    He intentado ejecutar todas las soluciones posibles, pero ninguna me ha funcionado hasta ahora.

    ¿Alguna idea?

    La página con la que necesito ayuda: [accede para ver el enlace]

Viendo 15 respuestas - de la 1 a la 15 (de un total de 18)
  • Iniciador del debate tuneuropsicologo

    (@tuneuropsicologo)

    La redirección: redirect 301 /post/ a /blog/ (cambio de dominio de Wix a WP)

    Moderador Jose Luis

    (@jose64)

    Hola.

    Bienvenido al foro de soporte. ¿Para qué haces la redirección? si migraste todos los contenidos correctamente debería funcionar sin necesidad de ninguna redirección. En todo caso la única redirección que deberías hacer sería de la web antigua en Wix a la nueva.

    Aparte de eso, tienes instalados dos plugins con la misma finalidad: Yoast SEO y SEO Plugin by Squirrly SEO, deberías usar uno solo. Igualmente estás usando el plugin Autoptimize, los plugins de optimización y caché deben usarse cuando todo en la web esté funcionando correctamente, si no lo haces así pueden estar generando errores o mostrando versiones obsoletas de cambios.

    Haz una copia de seguridad, elimina las redirecciones, borra la caché, desactiva todos los plugins que no sean indispensables. Una vez hecho esto sigue la ruta Ajustes > Enlaces permanentes y guarda los cambios (no es necesario que cambies nada) y prueba nuevamente, seguramente haciendo eso se resuelva el problema.

    Cuando esté funcionando todo correctamente puedes activar un plugin de SEO y configurarlo y Autoptimize. Comenta si tienes alguna duda y, por favor, recuerda marcar el debate como resuelto cuando así sea, de esta forma nos ayudas a mantener el foro al día.

    Iniciador del debate tuneuropsicologo

    (@tuneuropsicologo)

    La redirección es para que los links antiguos con la estructura /post/ pasen a /blog/ y no den error

    Iniciador del debate tuneuropsicologo

    (@tuneuropsicologo)

    He desativado Squirrly SEO y mantengo Yoast. Con Autoptimize lo mismo, pero dudo que este plugin tenga algo que ver.

    Ya he hecho todo lo que comentas y sigo teniendo el mismo problema.

    Moderador Jose Luis

    (@jose64)

    La redirección es para que los links antiguos con la estructura /post/ pasen a /blog/ y no den error

    ¿Y de dónde salen esos links antiguos? En WordPress no existen links antiguos o nuevos la estructura es única y cuando la modificas se modifican todos los enlaces. Elimina esa redirección, ve a Ajustes > Enlaces permanentes y guarda los cambios, no es necesario que hagas ningún cambio, con guardar ya se actualizan los enlaces permanentes y si WordPress hace las redirecciones necesarias automáticamente.

    Iniciador del debate tuneuropsicologo

    (@tuneuropsicologo)

    A ver, he migrado* una web de Wix a otro hosting de pago, y los posts antiguos alojados en Wix estaban en el directorio /post, lo único que he hecho es redireccionar esos enlaces a /blog/ para que no se pierdan.

    * No es una migración como tal porque el de Wix no es compatible. Simplemente, he pasado los contenidos de forma manual.

    Iniciador del debate tuneuropsicologo

    (@tuneuropsicologo)

    De todas formas, también he hecho lo que comentas y no se soluciona nada.

    Iniciador del debate tuneuropsicologo

    (@tuneuropsicologo)

    Así es como tengo configurados los enlaces permanentes:

    https://i.postimg.cc/J4MDrx2x/2022-03-20-12-55-29-Window.png

    Moderador Jose Luis

    (@jose64)

    Entiendo que hiciste la migración manualmente, ya se que no hay migración automática a Wix, lo que no entiendo es dónde hiciste la redirección, en ningún momento lo has explicado. Revisando lo que tienes indexado en Google se ve que la redirección no está funcionando, así que puedes quitarla porque es evidente que, además de no funcionar, te está ocasionando problemas.

    El dominio es el mismo que tenías en Wix, lo que tienes es que ajustar la estructura de los enlaces permanentes de WordPress a la que tenías en Wix, así se mantienen los enlaces igualmente.

    Las URLs que tienes indexadas en Google tienen la estructura /blog/tags/ y /post/, por ejemplo:

    https://tuneuropsicologo.com/blog/tags/psicoterapia
    https://www.tuneuropsicologo.com/post/efectos-actividad-fisica-depresion-neuroplasticidad

    Tú tienes definida la base de las etiquetas como blog/etiquetas, debería ser /blog/tags/ (con las barras) y la estructura personalizada /post/%postname%/

    La otra opción que tienes es fijar una nueva estructura optimizada para el seo y usar las herramientas de Google para reindexar.

    Iniciador del debate tuneuropsicologo

    (@tuneuropsicologo)

    La redirección la he hecho a través de Htaccess y si que me funciona. He enviado la peticion de indexación de las nuevas URLS hace poco porque he quitado algunas y añadido otras (aún no estarán indexadas), esas que pones son las antiguas de Wix.

    Moderador Jose Luis

    (@jose64)

    Hola.

    Pues yo no las veo funcionar, no me redirigen a ningún lado y me dan un error 404. De todas formas te repito, si tienes problemas y lo único que has hecho es eso, pues la causa será esa. Aparte de eso, si estás quitando las antiguas y poniendo las nuevas ¿para qué quieres redireccionar?, yo no tengo más que decirte al respecto aparte de reafirmarme en lo anterior: crea una estructura optimizada para el SEO, valora si indexar etiquetas y categorías te crea contenido duplicado y cuando lo tengas todo funcionando sin necesidad de redirecciones solicita el indexado.

    Iniciador del debate tuneuropsicologo

    (@tuneuropsicologo)

    A ver, Jose Luis, si yo hace 2 años publiqué la URL de un post que tenía alojado con WIX con esta estructura: /post/nombre-del-post y ahora quiero que esa dirección apunte a /blog/nombre-del-post tengo que hacer una redirección. O me estoy perdiendo algo.

    No me has resuelto el problema, pero gracias de todas formas. Intentaré hacerlo por otras vías.

    Saludos

    Iniciador del debate tuneuropsicologo

    (@tuneuropsicologo)

    Qué URL te da error? Porque a mí no me da error ninguna. Lo que sí sigue igual es categorías y etiquetas, ambas salen en blanco sin código.

    Iniciador del debate tuneuropsicologo

    (@tuneuropsicologo)

    Para que tú mismo compruebes que la redirección está funcionando, tal y como te he explicado reiteradas veces.

    https://tuneuropsicologo.com/post/5-errores-que-tienes-que-evitar-si-eres-psicologa-primeriza/

    redirecciona a:

    https://tuneuropsicologo.com/blog/5-errores-que-tienes-que-evitar-si-eres-psicologa-primeriza/

    Moderador Jose Luis

    (@jose64)

    Hola @tuneuropsicologo

    Las dos que te puse en el ejemplo están copiadas tal cual de los resultados de Google, dan error 404. La forma de resolverlo sin redirecciones ya está explicada, solo tienes que definir la estructura de los enlaces permanentes correctamente, en tu página de Wix usabas tags y en esta usas etiquetas, la redirección de post a blog funciona, pero si no tienes el mismo contenido da el error. Yo te digo lo de eliminar las redirecciones porque, a no ser que la url esté referida en otros sitios, si solo se debe a la indexación Google terminará usando las nuevas de todas formas y la estructura /blog/ no es la más recomendada para el SEO.

    Si quieres descartar cosas cambia de tema que tienes instalado por Twenty Twenty, por ejemplo, y haz la prueba.

Viendo 15 respuestas - de la 1 a la 15 (de un total de 18)
  • El debate ‘NO me muestra los post en CATEGORÍAS ni en ETIQUETAS’ está cerrado a nuevas respuestas.