Soporte » Guías – Resolución de problemas » No puedo acceder a permalinks

  • Hola, no puedo acceder a permalinks desde el escritorio de wordpress, he probado con un tema estandar, desactivando todos los plugins, sigue dandome error 404 not found. Hay ciertos plugins que tras la instalación no se pueden activar, como woocommerce, seo by yoast, wp commerce. mi instalacion de wordpress no esta en el directorio raiz. Gracias de antemano.

Viendo 15 respuestas - 16 de 30 (de 30 total)
  • ya lo he subido pero sigo sin poder acceder al escritorio.

    Agradezco el interés y la ayuda que me estas ofreciendo, estoy bastante flojo con wordpress. GRACIAS!!!

    Ok, ahora wp-login.php existe en el dominio principal, pero este redirige a otro lado y ese otro lado redirige de nuevo. Entonces tienes redirecciones entre dominio, sub carpeta y subdominios que estan afectando todo el funcionamiento.

    Quita las redirecciones que tengas puestas en htaccess o plugins. (Los plugins puedes desactivarlos cambiando el nombre a la carpeta del plugin por FTP)

    Saludos.

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    esto hay en el htaccess del directorio raíz

    y esto en el de la instalación de wordpress

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /wp/
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    ¿Pero en la raiz tienes otro WordPress?

    Deja ambos en blanco, borra lo que tengan.

    Saludos.

    No tengo dos instalaciones de wordpress, tengo una que esta en el subdirectorio llamado «wp»

    He dejado en blanco los htaccess y al intentar entrar al escritorio de wordpress recibo este mensaje:

    Not Found

    The requested URL /wp-login.php was not found on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    Si estas poniendo wordpress dentro de «wp» tienes que entrar dentro de esa carpeta.

    http://fotoindalo.com/wp/wp-login.php

    Si entras en la principal no la encuentra porque ahí no tienes wordpress. De todos modos al entrar en wp/ tiene redirección a la principal, parece que cambiaste la URL de tu sitio por el principal cuando no tienes nada ahí… Porque los CSS los busca en el dominio principal, sin wp/. ¿por que?

    Vas a tener que entrar a tu base de datos y poner la URL correcta de tu web, que es con el wp/.

    Saludos.

    como entro en la base de datos para cambiar la url?

    Desde el panel de tu Hosting con PHPMyAdmin.

    Saludos.

    Ok una vez que estoy en phpmyadmin como encuentro donde cambiar la url?
    saludos.

    Creo que lo mejor es que hables con tu hosting para que te ayuden. En la tabla wp_options vienen las URLs de WordPress y ahí es donde las tienes que cambiar.

    Saludos.

    Hola ya cambie todo al directorio raiz y probe a desactivar todos los plugins y con el tema por defecto y a reinstalar wordpress pero sigo sin poder acceder a permalinks, error 404 not found. Que hago mal? como puedo solucionarlo? gracias.

    Seguramente tienes algo mal en todo lo que haz hecho. No es decirte ve aquí y ya, hay que revisar todas las cosas de tu instalación para identificar el problema.

    Tienes dos carpetas y no explicas por que razón. Una en el dominio principal y otra dentro de la carpeta wp/, después no dices que pasa con los htaccess, después que te sale un internal server error, después que te sale not found cuando se supone que ya instalaste.

    Entonces todo se va mezclando y nada esta claro con que estas haciendo y que no.

    Sigues mezclando lo del directorio, que ya te mencioné arriba.

    ¿Porque tienes http://fotoindalo.com/ y http://fotoindalo.com/wp/?

    Son dos instalaciones, mezclas todo y nada funciona.

    Viendo tu web, tienes que entrar a http://fotoindalo.com/wp-admin/options-permalink.php? y seguramente entras en la otra en el directorio wp/ y por eso no se encuentra.

    Saludos.

    Hola, sí seguramente tengo algo mal, por eso pido ayuda. Ya no hay nada en la carpeta «wp» esta todo en el directorio raíz, lo comente en mi anterior post, gracias.

    Tienes que entrar aquí:

    http://fotoindalo.com/wp-admin/options-permalink.php?

    Saludos.

Viendo 15 respuestas - 16 de 30 (de 30 total)
  • El debate ‘No puedo acceder a permalinks’ está cerrado a nuevas respuestas.