Soporte » Instalación – Actualizaciones » No puedo acceder a un wordpress en local

  • Hola a todos,

    Tengo un problema a la hora de acceder a un wordpress instalado en un servidor debian 11.

    Después de instalar MariaDB y PHP8.1

    El archivo wp-config.php está configurado con los parámetros de la base de datos y usuario creados en MariaDB.

    Al acceder a http://localhost/wordpress me sale este mensaje:

    «Parece que tu instalación de PHP no cuenta con la extensión de MySQL, necesaria para hacer funcionar WordPress.»

    Según he visto en la página oficial de PHP pone: «Esta extensión está obsoleta a partir de PHP 5.5.0, por lo que ha sido eliminada a partir de PHP 7.0.0. En su lugar, se debería utilizar la extensión mysqli o PDO_MySQL. Véase también la Información general de la API de MySQL para obtener ayuda al elegir una API de MySQL.»; sin embargo, las versiones de mysql y php son versiones actualizadas, entendiendo que si hay que modificar algo ha de ser en wordpress. Pero no sé donde.

    La versión que he instalado es la 5.9.3 de wordpress.

    Versión de mysql

    joserodriguezan@iocserver:/var/www/html/wordpress$ mysql --version
    mysql  Ver 15.1 Distrib 10.5.15-MariaDB, for debian-linux-gnu (x86_64) using  EditLine wrapper

    Versión de PHP

    joserodriguezan@iocserver:/var/www/html/wordpress$ php --version
    PHP 8.1.5 (cli) (built: Apr 22 2022 04:56:05) (NTS)
    Copyright (c) The PHP Group
    Zend Engine v4.1.5, Copyright (c) Zend Technologies
        with Zend OPcache v8.1.5, Copyright (c), by Zend Technologies

    Llevo todo el día con esto y no encuentro solución. He desinstalado los paquetes de php y vuelto a instalar con una versión superior. También desinstalado y vuelto a instalar MariaDB.

    Muchas gracias por la ayuda.

  • Debes estar registrado para responder a este debate.