• Resuelto xuanet

    (@xuanet)


    Hola,

    Recibí el mensaje diciendo que el wordpress se actualizó solo en mi sitio. Ahora no me deja entrar en el panel de control.
    Meto el usuario y la contraseña y no hace nada. No da errores ni mensajes ni nada. La página se recarga y los campos aparecen en blanco.

    Desactivé todos los plugins y sigue pasando lo mismo.

    A alguien más le pasa?

Viendo 15 respuestas - de la 1 a la 15 (de un total de 27)
  • Moderador almendron

    (@almendron)

    ¿Cómo has desactivado los plugins?

    Yo probaría a actualizar manualmente.

    Si deseas desactivar las actualizaciones automáticas de WordPress por completo, abre el archivo wp-config.php y añade esta línea:

    define( 'AUTOMATIC_UPDATER_DISABLED', true );

    Iniciador del debate xuanet

    (@xuanet)

    Los deactivé cambiando el nombre a la carpeta plugin.

    Me recomiendas a reinstalar el wordpress manualmente?

    Gracias por la línea del wp-config. lo voy a poner ya

    Moderador almendron

    (@almendron)

    Yo haría esa actualización manual. Ya sabrás que la carpeta wp-content ni tocarla.

    Lo de la línea del wp-config es para ver si canta algún error.

    • Esta respuesta fue modificada hace 6 años, 8 meses por almendron.
    Moderador almendron

    (@almendron)

    Corrijo. Para ver si canta algún error hay que añadir la siguiente línea:

    define('WP_DEBUG', true);

    Es posible que ya la tengas en wl wp-config.php pero con ‘false’.

    Iniciador del debate xuanet

    (@xuanet)

    Con el modo debug me dice:

    Notice: wp_enqueue_style was called incorrectly. Scripts and styles should not be registered or enqueued until the wp_enqueue_scripts, admin_enqueue_scripts, or login_enqueue_scripts hooks. Please see Debugging in WordPress for more information. (This message was added in version 3.3.0.) in /home/******/public_html/wp-includes/functions.php on line 4139
    
    Warning: Cannot modify header information - headers already sent by (output started at /home/*****/public_html/wp-includes/functions.php:4139) in /home/****/public_html/wp-login.php on line 396
    
    Warning: Cannot modify header information - headers already sent by (output started at /home/*****/public_html/wp-includes/functions.php:4139) in /home/*****/public_html/wp-login.php on line 409

    Si cambio el nombre de la carpeta plugins y pongo una nueva llamada plugins y vacía, el error desaparece, pero sigo sin poder entrar.
    También cambié mediante phpMyAdmin el theme por defecto y tampoco pude entrar.

    Otro cambio reciente fue que el servidor actualizó el php.

    Subí todos los archivos de la última versión del WordPress y también del theme.

    • Esta respuesta fue modificada hace 6 años, 8 meses por xuanet.
    • Esta respuesta fue modificada hace 6 años, 8 meses por xuanet.
    • Esta respuesta fue modificada hace 6 años, 8 meses por xuanet.
    Moderador almendron

    (@almendron)

    En principio, esos errores no deberían darte problemas para entrar en la administración.

    ¿A qué versión de PHP has cambiado?

    Ya se que lo has hecho, pero vamos a intentarlo:
    1) renombra la carpeta «plugins» a «plugins-des». Basta con esto.
    2) accede la carpeta «themes» y primero haz una copia de seguridad de la carpeta del tema que usas. Después borra todo lo que hay dentro de esa carpeta excepto el index.php. Finalmente sube alguna de las plantillas que trae por defecto WordPress. Sube solo una.
    3) Prueba a entrar.

    Moderador almendron

    (@almendron)

    Y otra cosa: según a que sistema de PHP hayan pasado en tu servidor, las directivas sobre PHP pueden ocasionar un error.
    1) Accede vía FTP
    2) Haz una copia de seguridad del archivo htaccess
    3) Borra del servidor dicho archivo

    Toni Miranda

    (@tonisevhdwp2016)

    Yo estoy igual, xuanet se ve que el fallo a sido general, no somos los unicos que no pueden entrar al panel de admin.

    Iniciador del debate xuanet

    (@xuanet)

    Me consuela, Toni. Porque no encontré nada por internet y pensaba que era el único.

    almendron, probé lo que me dices pero sigue igual 🙁
    Es más, si quito el .htaccess me dice Error 402: Payment Required
    La versión que pusieron de php es la última. No sé el número pero sé que actualizaron porque mi compañero de VPS tenía problemas con joomla que necesitaba la última versión de php.

    Si es como dice Toni, sólo me queda esperar una solución. Lo dejaré como estaba

    Toni Miranda

    (@tonisevhdwp2016)

    Supongo que sacarán una actualización que corregirá este error, fijate, seguramente tampoco te funcionarán los oembed de youtube si tienes alguno.

    Toni Miranda

    (@tonisevhdwp2016)

    Es mas mis redactores les es imposible entrar a redactar noticias, se ve que la actualización era mas bien de seguridad que de mantenimiento. No suelen tener este tipo de fallos tan tochos, pero no les habrá quedado otra que lanzarlo por seguridad.

    A esperar, no nos queda otra.

    Moderador almendron

    (@almendron)

    En el foro no hay más avisos sobre este error por lo que, al menos de momento, no se puede decir que sea un error general.
    Yo mismo he actualizado en cuatro sitios sin mayores problemas.

    En cuanto al error «Error 402: Payment Required», es la primera vez que lo veo. La intención original era que este código pudiese ser usado como parte de alguna forma o esquema de Dinero electrónico o micropagos, pero eso no sucedió, y este código nunca se utilizó.

    Ponte en contacto con el soporte de tu hosting a ver qué te dicen acerca de ese error.

    • Esta respuesta fue modificada hace 6 años, 8 meses por almendron.
    Moderador almendron

    (@almendron)

    Indica la URL del sitio donde tienes el problema para echarle un vistazo.

    Iniciador del debate xuanet

    (@xuanet)

    Mi blog es elcachopo.com

    Moderador almendron

    (@almendron)

    De momento, veo que tienes un instalado un certificado SSL pero no has puesto ninguna redirección. Eso significa que, si entro con http, no me redirige a https.

    Por otra parte, al entrar con https observo varios errores debido a que no has cambiado todas las URL,s internas. Si accedes con Chrome, clic en «Inspeccionar» y luego en la pestaña «Consola». Ahí puedes ver el error.

Viendo 15 respuestas - de la 1 a la 15 (de un total de 27)
  • El debate ‘No puedo acceder al login desde la ultima actualización’ está cerrado a nuevas respuestas.