Soporte » Instalación – Actualizaciones » No puedo acceder al login desde la ultima actualización

  • Resuelto xuanet

    (@xuanet)


    Hola,

    Recibí el mensaje diciendo que el wordpress se actualizó solo en mi sitio. Ahora no me deja entrar en el panel de control.
    Meto el usuario y la contraseña y no hace nada. No da errores ni mensajes ni nada. La página se recarga y los campos aparecen en blanco.

    Desactivé todos los plugins y sigue pasando lo mismo.

    A alguien más le pasa?

Viendo 12 respuestas - 16 de 27 (de 27 total)
  • Yo solucioné mi problema, era con un plugin de sistema de afiliados, que tenia sus propias restricciones de acceso, ¿Estas entrando con Admin o SAdmin?

    Con admin. No sabía ni que existiera SAdmin

    Con SAdmin quiero decir, el user que te crea el propio wp de primeras, algo no recomendable de utilizar pero que en estos casos, no suele tener puertas cerradas por ningún plugin. Intenta entrar desde el apartado de tu hosting si es que puedes, ese es el superadmin.

    Si, entro desde el usuario que crea el wordpress.

    Intenta entrar desde el apartado de tu hosting si es que puedes, ese es el superadmin.
    Esto no lo entiendo… Tengo un VPS e instalé yo el WordPress

    Moderador almendron

    (@almendron)

    El único Super Administrador que conozco es el que se puede crear cuando tienes un WP Multisitio, es decir, una red de blogs.
    https://codex.wordpress.org/es:Roles_y_Capacidades
    https://codex.wordpress.org/Create_A_Network

    • @xuanet veo que usas como padre el theme frontier y que tiene actualización del 3 de agosto. ¿También hiciste esa actualización?
    • en tu tema hijo del frotier. Tienes metidas muchas cosas en el funcion.php ?
    • estas usando algún tipo de plugin de seguridad? (he leído que los has desactivado todos.. pero este tipo de plugin es muy pegajoso para desactivarlo bien)
    • puedes revisar el log de errores de php? en él, tras intentar hacer login tampoco sale nada?
    • Esta respuesta fue modificada hace 4 semanas, 1 día por  oldlastman.
    Moderador Fernando Tellado

    (@fernandot)

    Hay varios plugins que no son compatibles con la actualización, antes de nada desactivarlos todos a ver si se arregla y luego ir activando hasta dar con el que dé problemas y esperar a una actualización del plugin.

    – Sí, @oldlastman, el theme está al día. El hijo no tiene funtion.php, sólo un head. Aún así, lo quité y tampoco se solucionó.

    – tengo un captcha (google-captcha). Fue lo primero que pensé que podría ser. Lo actualicé por FTP y como seguía igual, lo cambié de nombre para que no cargase. Pero sin éxito.

    – Supongo que puedo mirar el log de errores de php. un un log pero no había errores de este tipo. Aún así no los entiendo.

    Lo que voy a hacer, viendo que vuelvo a ser un caso puntual, es hablar con los del servidor a ver si me pueden echar una mano.

    Moderador almendron

    (@almendron)

    Tienes varios frentes:

    1) htaccess: hay algo ahí que no me cuadra. Eso del “Error 402: Payment Required” no es habitual.

    2) Certificado SSL. Te falta poner redirección y corregir las URL,s internas: https://cybmeta.com/wordpress-http-a-https

    3) Tienes algún plugin que te da un aviso y dos alertas.

    4) Me da la impresión que es más problema del servidor que de WP.

    oldlastman

    (@oldlastman)

    @almendron donde sacas 3> tienes aviso y dos alertas?

    como he dicho ante una pantalla en blanco lo que te puede proporcionar mas información es el log de errores de php.
    para “entenderlo”

    1. intenta logearte en la página para disparar el error
    2. accede al log de php del servidor (cada proveedor lo proporciona de forma diferente)
    3. lee los registros, vienen ordenados por fecha así que busca el mas reciente = hora y minuto parecidos al momento en el que has intentado logearte
    4. repasa la información que te proporciona, pon especial interés en los “fatal error”
    5. si encuentras alguno intenta verificar si está alojado en una carpeta de plugin, de ser así ese es el culpable
    6. si está todos los errores alojados en carpetas de core (wp-includes y similar).. no es de gran ayuda el log para el tipo de error que tienes

    a modo de locura… y no tiene que ser ni cierto ni posible. ¿has repasado los permisos de archivo? tienen los normales 644 para archivos y 755 para directorios? tal vez permisos mas restrictivos puedan estar fastidiando

    si llegas a corregirlo, por favor, dinos que sucedía.. ya tenemos curiosidad científica

    Moderador almendron

    (@almendron)

    @oldlastman : lo tienes al principio del hilo. De hecho, desaparecen los errores cuando renombra la carpeta plugins.

    Ya está resuelto. Era tema del mod security del servidor. Ya me lo solucionaron.

    Muchas gracias a todos!!

Viendo 12 respuestas - 16 de 27 (de 27 total)
  • Debes estar registrado para responder a este tema.