Soporte » Instalación – Actualizaciones » no puedo actualizar a WP 4.6.1

  • Resuelto mialicanto

    (@mialicanto)


    Estimados

    He tratado varios dias de actualizar a WordPress 4.6.1–es_ES , pero es inutil.
    He desinstalado todos los plugins y a pesar de ello, sigo igual.
    En todos los casos me aparece el siguiente error

    ‘Descargando paquete de instalación desde https://downloads.wordpress.org/release/es_ES/wordpress-4.6.1.zip…

    Descomprimiendo actualización…

    Verificando los archivos descomprimidos…

    Preparando para instalar la última versión…

    No ha sido posible instalar la actualización debido a que no se han podido copiar algunos archivos. Normalmente esto es debido a permisos de archivo inconsistentes.: wp-admin/includes/options.php, wp-admin/includes/class-walker-nav-menu-edit.php, wp-admin/includes/class-wp-screen.php, wp-admin/includes/credits.php, wp-admin/includes/network.php, wp-admin/includes/edit-tag-messages.php, wp-includes/class-walker-comment.php, wp-includes/class-wp-rewrite.php, wp-includes/customize/class-wp-customize-nav-menus-panel.php, wp-includes/customize/class-wp-customize-nav-menu-section.php, wp-includes/customize/class-wp-customize-header-image-control.php, wp-includes/customize/class-wp-customize-image-control.php, wp-includes/customize/class-wp-customize-nav-menu-item-control.php, wp-includes/customize/class-wp-customize-nav-menu-auto-add-control.php, wp-includes/customize/class-wp-customize-nav-menu-setting.php, wp-includes/customize/class-wp-customize-site-icon-control.php, wp-includes/customize/class-wp-customize-media-control.php, wp-includes/customize/class-wp-customize-nav-menu-control.php, wp-includes/customize/class-wp-customize-nav-menu-item-setting.php, wp-includes/customize/class-wp-customize-filter-setting.php, wp-includes/customize/class-wp-customize-nav-menu-location-control.php, wp-includes/class-wp-roles.php, wp-includes/class-walker-category-dropdown.php, wp-includes/class-wp-comment.php, wp-includes/class-wp-tax-query.php, wp-includes/embed-template.php, wp-includes/class-wp-widget.php, wp-includes/class-wp-user-query.php, wp-includes/rest-api/class-wp-rest-request.php, wp-includes/rest-api/class-wp-rest-response.php, wp-includes/rest-api/class-wp-rest-server.php, wp-includes/widgets/class-wp-widget-tag-cloud.php, wp-includes/widgets/class-wp-widget-recent-comments.php, wp-includes/widgets/class-wp-widget-meta.php, wp-includes/widgets/class-wp-nav-menu-widget.php, wp-includes/widgets/class-wp-widget-search.php, wp-includes/widgets/class-wp-widget-categories.php, wp-includes/widgets/class-wp-widget-links.php, wp-includes/widgets/class-wp-widget-rss.php, wp-includes/widgets/class-wp-widget-calendar.php, wp-includes/widgets/class-wp-widget-pages.php, wp-includes/widgets/class-wp-widget-archives.php, wp-includes/widgets/class-wp-widget-recent-posts.php, wp-includes/widgets/class-wp-widget-text.php, wp-includes/class-wp-comment-query.php, wp-includes/class-wp-widget-factory.php, wp-includes/class-wp-http-cookie.php, wp-includes/js/wp-embed-template.min.js, wp-includes/js/wp-embed.min.js, wp-includes/js/wp-embed-template.js, wp-includes/js/wp-embed.js, wp-includes/class-wp-http-streams.php, wp-includes/embed.php, wp-includes/class-walker-page-dropdown.php, wp-includes/class-wp-http-proxy.php, wp-includes/class-wp-meta-query.php, wp-includes/rest-api.php, wp-includes/class-walker-category.php, wp-includes/class-wp-http-curl.php, wp-includes/class-wp-http-encoding.php, wp-includes/class-wp-network.php, wp-includes/class-wp-role.php, wp-includes/class-wp-term.php, wp-includes/class-wp-user.php, wp-includes/class-walker-page.php, wp-includes/class-wp-oembed-controller.php, wp-includes/random_compat/random_int.php, wp-includes/random_compat/random_bytes_libsodium.php, wp-includes/random_compat/byte_safe_strings.php, wp-includes/random_compat/random_bytes_com_dotnet.php, wp-includes/random_compat/random.php, wp-includes/random_compat/random_bytes_mcrypt.php, wp-includes/random_compat/random_bytes_dev_urandom.php, wp-includes/random_compat/random_bytes_openssl.php, wp-includes/random_compat/cast_to_int.php, wp-includes/css/wp-embed-template.min.css, wp-includes/css/wp-embed-template.css

    Instalación fallida’

    Que podra ser?
    Gracias de antemano por sus aportes

Viendo 7 respuestas - de la 1 a la 7 (de un total de 7)
  • Estimado mialicanto, revisa por favor, los permisos de las carpetas wp-admin y wp-includes, por medio de tu panel de hosting para que descartes que las carpetas tengan el permiso correcto.

    Saludos..

    Iniciador del debate mialicanto

    (@mialicanto)

    hola
    tengo las carpetas con permisos 755
    pero igual me impide actualizar wp 🙁

    Amigo, intentó actualizar manualmente..? pero primero haga respaldo completo de todas sus bases de datos y archivos en su PC, luego puede proceder a montar la última versión de wordpress descargada desde la página oficial wordpress.org, luego via ftp monta los archivos de su nueva versión en su sitio sobreescribiendo los archivos de WordPress actuales (Puede obviar el archivo de conexión si lo desea) , luego ejecutas en el navegador «wp-admin/update.php», para que haga las actualizaciones en la base de datos actual.

    Es importante que tengas en cuenta que todas modificaciones que tengas realizadas en algún archivo Php o tema va a desaparecer, además debes verificar que los temas que tengas instalados en tu sitio sean compatibles con la versión de WordPress que vayas a montar para que no tengas problemas.

    Aprende más profundamente acerca de este tipo de actualizaciones antes de proceder para que no se dañe tu sitio web irreversiblemente.

    Saludos..

    Moderador almendron

    (@almendron)

    Las modificaciones del tema que uses no tienen porqué desaparecer. Cuando se actualiza manualmente, la carpeta wp-content ni se elimina ni se sobreescribe.
    https://codex.wordpress.org/es:Actualizar_WordPress

    Iniciador del debate mialicanto

    (@mialicanto)

    no, no habia optado por la actualizacion manual, ya que me daba un poco de susto. Vamos a intentarlo. Les aviso

    Recuerda, aunque es muy cierto lo que indica almendron, nunca esta de más hacer un respaldo completo de tu sitio, por experiencia te lo digo !!

    Espero puedas resolver !

    Saludos…

    Iniciador del debate mialicanto

    (@mialicanto)

    muchas gracias chicos.
    acabo de terminar la actualizacion manual y me parece q el sitio esta ok

    Muchas gracias a todos.. procedo a dejarlo como resuelto

Viendo 7 respuestas - de la 1 a la 7 (de un total de 7)
  • El debate ‘no puedo actualizar a WP 4.6.1’ está cerrado a nuevas respuestas.