Soporte » Instalación – Actualizaciones » No puedo actualizar de ninguna manera

  • Resuelto tognaco

    (@tognaco)


    Tengo un WP corriendo la versión 3.6 y quiero actualizarlo a la última 5.2.2, pero no puedo porque:
    – Si le doy a actualizar me dice que la versión de PHP es antigua (5.6) y no se puede hacer la actualización
    – Entonces voy a mi hosting, cambio la versión de PHP a la 7.1, que es la más moderna disponible allí y al entrar en mi WP me sale una página en blanco diciendo: «Parece que tu instalación de PHP no cuenta con la extensión de MySQL, necesaria para hacer funcionar WordPress.»

    Así que he entrado en bucle, estoy bloqueado y no sé qué puedo hacer. ¿Se os ocurre alguna solución? Gracias anticipadas.

    La página con la que necesito ayuda: [accede para ver el enlace]

Viendo 4 respuestas - 1 de 4 (de 4 total)
  • Debes hacer el update manualmente.
    Mira más info en
    https://wordpress.org/support/article/updating-wordpress/#manual-update

    Te aconsejo hacerlo en algún entorno que no sea producción y después subirlo.

    Hola

    Adamás de lo que te dice @adriandegrafreak ve buscando otro tema, el que tienes lo descontinuó Elegant Themes y no tiene soporte, de hecho puede darte también algún problema al actualizar.

    Gracias a los dos, intentaré a ver qué soy capaz de hacer. Por otra parte, me dice el desarrollador de Migrator (un plugin dependiente de Updraft Plus) que el mensaje ese de error lo tengo que solucionar con el hosting diciéndoles que instalen la extensión de MyQL para PHP, cosa que me parece muy rara porque tengo otros WP en el mismo hosting que corren WP 5.2.2 sin ningún problema. ¿Qué opináis?

    Bueno, al final lo he conseguido. Ya está actualizado y no parece que nada se haya estropeado. Gracias por vuestra ayuda 🙂

Viendo 4 respuestas - 1 de 4 (de 4 total)
  • Debes estar registrado para responder a este debate.