Soporte » Guías – Resolución de problemas » No puedo actualizar ni versión WP ni plugins

  • Resuelto valeriatittarelli

    (@valeriatittarelli)


    Hola a todos.
    No puedo actualizar WP (me dice que no tengo permisos, aunque soy administradora y no es multisite). Tampoco los plugins, solo puedo acceder a ellos y activar/desactivar, pero no puedo subir nuevos. Los he borrado desde FTP restaurado copia de seguridad, activado el de woocommerce y el problema persiste.

    – En salud del sitio me indica como error crítico lo siguiente:
    1 error crítico

    Las actualizaciones en segundo plano no están funcionando como se espera
    Seguridad
    Las actualizaciones en segundo plano garantizan que WordPress se puede actualizar automáticamente si se publica una actualización de seguridad para la versión que estás utilizando actualmente.

    Error La constante DISALLOW_FILE_MODS está definida y activada.
    Error Un plugin ha impedido las actualizaciones al desactivar wp_version_check().
    Aprobado No se han detectado sistemas de control de versiones.
    Aprobado Tu instalación de WordPress no requiere credenciales de FTP para realizar actualizaciones.
    Aprobado Todos tus archivos de WordPress son editables.

    ——-
    ¿Alguien que pueda ayudarme?.

    La página con la que necesito ayuda: [accede para ver el enlace]

Viendo 3 respuestas - de la 1 a la 3 (de un total de 3)
  • Moderador LGrusin

    (@lgrusin)

    Pues eso, si tienes puesto define( 'DISALLOW_FILE_MODS', true ); en el archivo wp-config.php no podrás hacer actualizaciones.

    Debes modificar en el archivo wp-config.php
    define( 'DISALLOW_FILE_MODS', true );
    por
    define( 'DISALLOW_FILE_MODS', false );
    o simplemente eliminar esa línea.

    • Esta respuesta fue modificada hace 1 año, 2 meses por LGrusin.
    Iniciador del debate valeriatittarelli

    (@valeriatittarelli)

    Muchísimas gracias. Justamente esa ha sido la solución. Gracias mil de nuevo!

    Iniciador del debate valeriatittarelli

    (@valeriatittarelli)

    Solucionado. Gracias.

Viendo 3 respuestas - de la 1 a la 3 (de un total de 3)
  • El debate ‘No puedo actualizar ni versión WP ni plugins’ está cerrado a nuevas respuestas.